AppV 5.1 - templatefilepath is not working for PowerShell package creation RRS feed

  • Question

  • I updated my sequencers to AppV 5.1 and now the 'templatefilepath' option is not working when I execute a package creation via PowerShell.

    My script looks like so:

     import-module appvsequencer

    $Date = Get-Date

    $Year = $Date.Year

    $Month = $Date.Month

    $Day = $Date.Day

    $packageName = "MediSolutions_Phantim_7_Test_$Year`_$Month`_$Day`_x86"

    $path =  "$env:USERPROFILE\Desktop\$packageName"

    mkdir $path

    New-AppvSequencerPackage -Name $packageName  -TemplateFilePath "D:\Template.appvt" -path $path -Installer "D:\Phantim\install-PhantimTest.cmd" -FullLoad


    This exact same script works with AppV 5.0SP3.  I can confirm the template isn't being applied because I have VFSWriteMode turned on and it's not when I go to edit the package + I see registry keys that should be excluded.

    Anyone else able to confirm this?  Or did I break my setup?

    Wednesday, December 16, 2015 11:18 PM

All replies

  • I can confirm this, although checkbox for named and com objects gets applied. It's a pain, because I've got a couple of packages automated which update frequently.
    Thursday, December 17, 2015 12:04 AM
  • + Confirming

    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you.)

    app2pack.blogspot.com: app2pack.blogspot.com

    Thursday, December 17, 2015 4:08 AM
  • VFSWriteMode does not yet apply to sequencing templates. :(

    Steve Thomas, Senior Consultant, Microsoft

    App-V/MED-V/SCVMM/Server App-V/MDOP/AppCompat

    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”

    Tuesday, February 16, 2016 4:46 AM
  • Hi Steve,

    I'm confused by your answer.

    1) templatefilepath doesn't appear to be working at all.  None of my file or registry exclusions get applied.

    2) VFSWriteMode can be used in sequencing templates and when loaded through the File menu does have the 'checkbox' set at the end of sequencing.

    <?xml version="1.0" encoding="utf-8"?>
    <SequencerTemplate xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <string>REGISTRY\USER\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap</string>
      <TargetOSes />

    Can you clarify?

    Tuesday, February 16, 2016 4:54 AM
  • I can confirm this as well.  In my case, the COM integration settings get applied just fine using a template but the FullVFSWriteMode do not.

    Using the same template file, if I manually import it into the Sequencer UI, it applies everything just fine.  This issue is only occurring when using the TemplateFilePath option. 

    Here are the known takeaways from the combined posts above:

    • The template we are using works correctly by manually importing it using the 5.1 Sequencer UI
    • When sequencing from the command-line, the template applies the COM integration settings, but ignores the FullVFSWriteMode setting.
    • Not having this ability is a huge roadblock to any automation efforts.
    • Steve Thomas sometimes makes mistakes (but its extremely rare)...lol

    • Proposed as answer by cyberchevalier Tuesday, November 27, 2018 1:56 PM
    • Unproposed as answer by cyberchevalier Tuesday, November 27, 2018 1:59 PM
    Friday, May 27, 2016 1:17 AM