none
Project Server 2013: Set-SPProjectPermissionMode error RRS feed

  • Question

  • Hi,

    In our environment, we need to use Project Server permission mode to fine tune permissions. According to documents, we need to run the Set-SPProjectPermissionMode command. However, when I ran it, I got the following error:

    Set-SPProjectPermissionMode : There is a version mismatch between the Web server and the content databases, and connections to the data have been blocked to avoid data loss. This can happen when a service pack is not completely installed. Notify your server administrators so that they can
    upgrade the Web server and the databases to the same version. For more information about installing service packs and updates, see the Microsoft Web site (http://go.microsoft.com/fwlink?LinkID=177163).

    The linked document does not offer any help. It talks about changes in Project Server 2010, while we're configuring permission mode in Project Server 2013.

    Thanks for any information.

    By the way, we've installed both SharePoint 2013 SP1 and Project Server 2013 SP1 (currently only one server in the farm). In Central Admin's Upgrade and Migration section, neither the content database nor the service packs (or any other updates) report any errors.

    Monday, January 12, 2015 8:19 AM

All replies

  • Hello,

    If you go to Central Admin check the following two pages:

    Manage Servers in this Farm (in System Settings) - on this page what does the status show for each server in the farm, "Action Required" or "No Action Required". If any action is required, please resolve this before attempting this PowerShell command again.

    Review Database Status (in Upgrade and Migration) - do any of the farm databases status display action required or are they all "No Action Required"? If any of them require action, please resolve this before attempting this PowerShell command again.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Monday, January 12, 2015 9:10 AM
    Moderator
  • Thanks for the help. It is working fine now, although we're not exactly sure what happened. We did two things: 1. Run SharePoint Product Configuration Wizard again. 2. Use the SharePoint service account user (who have full access to database) instead of the farm admin to run the command.

    Tuesday, January 13, 2015 3:22 AM