none
Date Type Conversion RRS feed

  • Question

  •  

    hi,

     

    I have an issue while processing a cube.

    I'm using Oracle DB  and the following is the error message:

     

    Errors in the OLAP storage engine: The attribute key cannot be found: Table:Fact, Column: SHIP_DATE, Value: 12:00:00 AM.

     

    Errors in the OLAP storage engine: The record was skipped because the attribute key was not found. Attribute: DATE KEY of Dimension: Time_Fiscal from Database: CUBE NAME, Cube: CUBE NAME, Measure Group:  FACT, Partition: FACT, Record: 730456.

     

    In Oracle DB, the date_key which is PK in date dimension is  '30-Apr-2008'

    In SSAS, the date_key format is showing like ' 2007-09-04 00:00:00Z' when I explore date in DSV and when I run the query through DSV, the format is showing like '2007-09-04 12:00:00 AM'. 

     

    In Fact some ship_date fileds are null and I thought this error came out due to the null processing; however I still see the same error even if I removed the null value.

     

    I do not quite understand how this error comes from and I do not even see the value '12:00:00 AM' and this is may be caused while sql server convert the date time ?

     

    Any kinds advice would be greatly apprecated.

    Thanks in advance.

    Tuesday, May 6, 2008 3:45 PM

All replies

  • Hi,

    you should look in your DSV what are the types of key attribute of time dimension and ship_date column in fact table, they should be the same.

     

    In your dimension, you can specify KeyColumn, which could be one or more DB columns with any type, this is used when dimension is matched against fact table. Then you can specify NameColumn, which might be formatted, user friendly string value. If you want to display another format of date, then create calculated column in DSV with formatted date and assign to NameColumn(this will replace ...00Z). From DSV you will always get 12:00 AM format, which is how BIDS represent date type.

     

    Radim

    Tuesday, May 6, 2008 6:26 PM
  • Thanks for your reply.

    All data type are same as System.DateTime.

    The funny thing is I just created partitions based on 4 months and processed partitions seperately and then now I could process all partitions without any errors.

     

    The number of fact is 5,247,720 and I could not see any error after creating partitions and processing them individually.

    And I do not understand this behavior. Any thoughts or ideas?

     

     

    Tuesday, May 6, 2008 7:39 PM