locked
Unable to mount database (hr=0x80004005, ec=2417) RRS feed

  • Question

  • I recently removed our last Exchange 2003 server. We currently have Exchange 2007 Enterprise running. I've been only able to mount 5 databases. After creating a new one, it is ubable to mount. I've also re-run the option setup.com /PrepareAD twice and restarted the IS. Re-added the product ID and still unable to mount the database.

    -------------------------------------------------------
    Microsoft Exchange Error
    --------------------------------------------------------
    Failed to mount database 'CCC'.

    CCC
    Failed
    Error:
    Exchange is unable to mount the database that you specified. Specified database: HCEXCHSRV\Third Storage Group\CCC; Error code: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-2147467259)
    --------------------------------------------------------
    OK
    --------------------------------------------------------


    • Edited by Nismo350 Monday, May 14, 2012 5:55 PM
    • Changed type Gavin-Zhang Tuesday, May 15, 2012 1:35 AM wrong type
    Monday, May 14, 2012 5:52 PM

Answers

  • Hi,

    How is the issue now?

    Please try to change the number to 50 from ADSIedit and then test the issue again.

    Note: Please have a full backup of Exchange Server and AD in case some unexpected issue would occur.


    Xiu Zhang

    TechNet Community Support

    • Marked as answer by Xiu Zhang Wednesday, May 30, 2012 6:33 AM
    Friday, May 25, 2012 3:33 AM
  • I changed the value for msexchMaxStorageGroups and msExchMaxStoresTotal on Information store from 5 to 50. It now appears to work.

    Thanks

    • Marked as answer by Nismo350 Thursday, May 31, 2012 8:36 PM
    Thursday, May 31, 2012 8:35 PM
  • Sorry I thought you were having this issue. I've already resolved this months ago.
    • Marked as answer by Nismo350 Friday, October 12, 2012 3:27 PM
    Friday, October 12, 2012 3:27 PM

All replies

  • Hi

    Do you see an event 9591 in the application log?  Have you entered the license key yet?

    Steve

    Monday, May 14, 2012 6:15 PM
  • Application
    Log does have event id’s for 9591.
    “Exceeded the max number of 5 MDBs on this server”. And I have also re-applied the product key.<o:p></o:p>


    Monday, May 14, 2012 6:26 PM
  • OK that does sound like a license key problem.  What result do you get when running the EMS command below to reapply the key?

    Set-ExchangeServer [ServerName] -Productkey [Key]

    Monday, May 14, 2012 6:40 PM
  • Set-ExchangeServer : The Exchange server "HCEXCHSRV" is already licensed.
    At line:1 char:19
    + Set-ExchangeServer <<<<  hcexchsrv -Productkey W3MX6-2WXMD-QB887-4WGPK-######
        + CategoryInfo          : WriteError: (hcexchsrv:ServerIdParameter) [Set-E
       xchangeServer], InvalidOperationException
        + FullyQualifiedErrorId : 67BED20B,Microsoft.Exchange.Management.SystemCon
       figurationTasks.SetExchangeServer

    Name                              : HCEXCHSRV
    ProductID                         : 90557-046-0000007-05121
    IsExchange2007TrialEdition        : False
    IsExpiredExchange2007TrialEdition : False
    RemainingTrialPeriod              : 00:00:00

    • Edited by Nismo350 Monday, May 14, 2012 6:49 PM
    Monday, May 14, 2012 6:43 PM
  • Have you restarted the Information Store service since entering the key?

    Edit: ignore that, I just re-read your opening post

    Monday, May 14, 2012 6:52 PM
  • Name                Site                 ServerRole  Edition     AdminDisplayVe
                                                                     rsion        
    ----                ----                 ----------  -------     --------------
    HCEXCHSRV           Default-First-Sit... Mailbox,... Enterprise  Version 8.3...
    Monday, May 14, 2012 7:26 PM
  • It does appear to be licensed correctly but the issue you are seeing is what happens when using the trial version.  I don't have a 2007 system at my disposal right now to see if it can be unlicensed in some way so that you can start again. 

    Monday, May 14, 2012 8:56 PM
  • Hi,

    Please try to use ADSIedit.msc to check the value for msexchMaxStorageGroups and msExchMaxStoresTotal on Information store

     You can navigate to ADSIEIDT --> Configuration --> Services --> Microsoft Exchange -->Administrative Groups --> Exchange Administrative Groups --> Servers-->exchangeserver --> Information store

    If the value is 5, the I recommend yu to apply the latest update to your Exchange Server and then reboot to check the issue agan.


    Xiu Zhang

    TechNet Community Support

    Tuesday, May 15, 2012 8:54 AM
  • I've checked the value and they are both set to 5. What update should I re-apply to change these setting?

    Tuesday, May 15, 2012 11:54 AM
  • Hey, does anybody have any ideas on how to fix this issue?
    Tuesday, May 15, 2012 7:41 PM
  • Hi,

    Then please try to apply the latest update and the check the issue again. We have rollup7 released for Exchange 2007 sp3.

    Update Rollup 7 for Exchange Server 2007 Service Pack 3 (KB2655203)

    http://www.microsoft.com/en-us/download/details.aspx?id=29426

    Xiu Zhang

    TechNet Community Support


    • Edited by Xiu Zhang Wednesday, May 16, 2012 2:52 AM
    Wednesday, May 16, 2012 2:50 AM
  • I've scheduled downtime for this weekend to re-apply the update. Is there anything else I can do before then?

    Thursday, May 17, 2012 3:07 PM
  • I reapplied Update Rollup 7 for Exchange Server 2007 Service Pack 3 (KB2655203) to the Exchange server over the weekend. I'm still unable to mount any additional databases. Below is the error message. What else is there to try?

    --------------------------------------------------------
    Microsoft Exchange Error
    --------------------------------------------------------
    Failed to mount database 'CCC'.

    CCC
    Failed
    Error:
    Exchange is unable to mount the database that you specified. Specified database: HCEXCHSRV\Third Storage Group\CCC; Error code: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-2147467259)

    Monday, May 21, 2012 12:04 PM
  • Hi,

    How is the issue now?

    Please try to change the number to 50 from ADSIedit and then test the issue again.

    Note: Please have a full backup of Exchange Server and AD in case some unexpected issue would occur.


    Xiu Zhang

    TechNet Community Support

    • Marked as answer by Xiu Zhang Wednesday, May 30, 2012 6:33 AM
    Friday, May 25, 2012 3:33 AM
  • I changed the value for msexchMaxStorageGroups and msExchMaxStoresTotal on Information store from 5 to 50. It now appears to work.

    Thanks

    • Marked as answer by Nismo350 Thursday, May 31, 2012 8:36 PM
    Thursday, May 31, 2012 8:35 PM
  • I have the same issue with one of my servers. How and where do you change this "msexchMaxStorageGroups and msExchMaxStoresTotal " please.

    Jaya.

    Friday, October 12, 2012 2:59 AM
  • Run ADSIedit on your domain controller, you will find it under Configuration.
    Friday, October 12, 2012 11:51 AM
  • Hi

    Im not sure whether the issue is fixed or not. If not please post the exact error message which you receive when trying to mount the database and also the Event logs which you get for MSExchangeIS and any other pertaining to the issue, so that i can help.

    thanks

    Friday, October 12, 2012 2:18 PM
  • Sorry I thought you were having this issue. I've already resolved this months ago.
    • Marked as answer by Nismo350 Friday, October 12, 2012 3:27 PM
    Friday, October 12, 2012 3:27 PM
  • Hi,

    Thanks for the reply from Nismo350. I checked the settings in adsiedit and it's correct. It's set msExchMaxStorgaeGroup 50, msExchMaxStoresperGroup 5 and msExchMaxStorestotal 50 similar to other exchange servers that I have with no issues.

    Currently this server has 1 PF SG and 4 Mailbox  SGs. I get this error when try to mount the database in the 6th storage group..

    "Exchange is unable to mount the database that you specified. database < database name>; Error code : MapiExceptionCallFailed: Unable to mount database.[hr=0x80004005,ec=2147467259]"

    Applicationn Event viewer logs this..

    "Error 0x80004005 starting Storage Group /DC=net/DC=siemens/CN=Configuration/CN=Services/CN=Microsoft Exchange/CN=SCN/CN=Administrative Groups/CN=Exchange Administrative Group (FYDIBOHF23SPDLT)/CN=Servers/CN=AUMELBW50MSX/CN=InformationStore/CN=sg05-mb05 on the Microsoft Exchange Information Store.

    Max Storage Groups has been exceeded. "

    ----------------------

    This servber has been in operation for number of months and only now I wanted to add another SG to it.

    I re-entered the product key using the powershell commnad and it said a valid key is installed but updated the key. I'm going to reboot ther server in couple of days time and see whether it makes any difference.

    Regards,

    jaya.

    Tuesday, October 16, 2012 1:25 AM
  • Running eseutil /p (hard repair) method may sometimes leads to serious data loss issues in the database. So, it is highly advised to keep a copy of databases before running these command line tools. If log files are missing and database files are severely damaged, it is good to use most recent backup file or a third party tool http://howtorecoverexchangeserverrecovery.blogspot.com/2012/10/exchange-server-recovery.html
    • Edited by alexrodic21 Wednesday, October 31, 2012 3:18 PM add tools
    Wednesday, October 31, 2012 3:18 PM