none
MDT 2013: WinPE Screen Resolution for Tablets not adapted RRS feed

  • Question

  • Hello guys,

    I'm using MDT 2013 to deploy Windows 8.1 on tablets.

    So, after generated the boot image including the right drivers inside, I boot up my tablets through WinPE (Boot on LAN).

    Once WinPE initiated, I'm now in the Deployment Welcome Screen with a very low resolution. The welcome screen filled the entire screen. Worse, the next window is bigger than the screen.

    So my question is, how to handle with this behaviour?

    Thanks guys in advance for your help,

    Friday, March 27, 2015 1:53 PM

All replies

  • Did you add the following to your customsettings.ini?

    [Settings]
    Priority=Model, Default

    [Surface Pro 3]
    XResolution=2160
    YResolution=1440

    Friday, March 27, 2015 2:30 PM
  • That's for Surface Pro 3 BTW.....
    Friday, March 27, 2015 2:31 PM
  • Hi Prince,

    Thanks for your answer.

    Yes, I've setted my CustomSettings.ini file with the different sizes.

    I can be wrong but in my view:

    This is not used under WinPE environment.

    The size resolution setted in the CustomSettings is for Windows, after MDT has deployed the image.

    Furthermore, the CustomSettings.ini file is red once you logged on into MDT Welcome Screen.

    Friday, March 27, 2015 2:36 PM
  • Well you can also edit the unattend.xml for your WinPE environment. Default is 1024 by 768. Did you see this post?

    http://deploymentresearch.com/Research/Post/256/Setting-screen-resolution-in-WinPE-4-0

    Friday, March 27, 2015 2:44 PM
  • Oh I also meant to mention that your customsettings.ini gets processed right before your Wizard pane shows up!
    Friday, March 27, 2015 2:51 PM
  • Hi,

    Thanks for your help. 

    I've read few posts about injecting an Unattend.xml file in the boot image including this link you mentionned.

    I'm not sure to be right but what I did is the following:

    1) create a file called Unattend.xml with the following content:
    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">
                <Display>
                    <ColorDepth>32</ColorDepth>
                    <HorizontalResolution>1024</HorizontalResolution>
                    <RefreshRate>60</RefreshRate>
                    <VerticalResolution>768</VerticalResolution>
                </Display>
            </component>
        </settings>
    </unattend>
    2) put it in my "extrafolder" in order to be imported when I create the boot image through MDT.
    3) once created, checked that the Unattend.xml file is in the root of my boot image wim file
    4) import the new boot image into WDS

    So, I've tested the new boot image in at least 3 different kind of computers (tablet, laptop and desktop), the result is the same: the machines restart automatically when they try to load the MDT Welcome environment.

    What's wrong?

    Monday, March 30, 2015 6:22 AM
  • I:

    - modify my Unattend.xml file to reflect what's "C:\Program Files\Microsoft Deployment Toolkit\Templates\Unattend_PE_x64.xml" file.

    - changed the resolution to: 1920x1080

    - add video drivers into the boot image

    and it works now on my laptop but not yet on my tablet despite the video driver exist in my MDT Out-of-Box Drivers.

    Monday, March 30, 2015 7:25 AM