locked
Edge Browser Printing with Accounting Codes (Department ID) RRS feed

  • Question

  • When attempting to print web content from the Edge Browser through our print server we do not get the Department ID popup that is required for print accounting. This causes the print job to hang on the local machine because it is awaiting a response to a prompt that is not displayed. It also causes the print queue on the print server to hang because the print server is awaiting a response to a prompt that is not displayed. Requires cancelling the job locally and on the server and then restarting the print spooler in order to clear the print queue (sometimes clearing the queue folder as well).

    Using IE 11, Firefox, Chrome and Opera all operate as expected: opening the department ID dialog so we can use the accounting features to track printing per user or per job.

    Print jobs submitted from all MS Office (2007, 2010, O365 and 2016) work as expected, allowing accounting to be done.

    With over 70,000 entries returned on the TechNet forums regarding Edge browser and printing this seems like it might get lost in the fog but hopefully someone gets a whiff of an idea?

    Tuesday, March 29, 2016 5:39 PM

Answers

  • Hi, 

    It seems that Edge doesn't support this feature. 

    Please capture the system events when reproduce this issue by using process monitor and let's check if there is any components missing when implement this authentication feature. 

    Also the right system events in IE. 

    Post the saved pml files onto Onedrive and share the link here for our research. 

    Process Monitor v3.05
    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx 


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, March 30, 2016 10:24 AM

All replies

  • Hi, 

    It seems that Edge doesn't support this feature. 

    Please capture the system events when reproduce this issue by using process monitor and let's check if there is any components missing when implement this authentication feature. 

    Also the right system events in IE. 

    Post the saved pml files onto Onedrive and share the link here for our research. 

    Process Monitor v3.05
    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx 


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, March 30, 2016 10:24 AM
  • I don't know if you found a solution to this yet but I found this other technet article that may help, it worked for me.

    https://answers.microsoft.com/en-us/windows/forum/apps_windows_10-msedge/appx-applications-like-edge-and-photos-lock-print/be715c06-e52a-4f36-88d7-bfb877baebc5?rtAction=1485906467210

    Wednesday, June 14, 2017 8:45 PM