none
Intel i217/8-LM Network Drivers will not install during OSD to W10

All replies

  • Try this: Install the driver manually to a machine that has that adapter. Then use this tool to grab the driver: https://gallery.technet.microsoft.com/ConfigMgr-Driver-Injector-aae7d17d
    Also check this: http://blogs.technet.com/b/smsandmom/archive/2008/12/09/configmgr-2007-task-sequence-may-fail-to-run-with-error-code-0x80072ee7.aspx. ...it might just be a network issue, are there IDS/IPS/Firewalls between the client and the distribution point?
    • Edited by Narcoticoo Tuesday, February 23, 2016 6:31 PM
    Tuesday, February 23, 2016 6:24 PM
  • i have tried this, i get the exact same result. 

    no firewalls, its only an issue with this NIC, nothing else in my environment. 

    Wednesday, February 24, 2016 9:58 AM
  • I'm getting exactly the same problem as you and currently have a ticket open with Microsoft on it.  We've got 10 different models / makes with the same issue and it's really starting to cause us a headache :(
    Wednesday, February 24, 2016 4:08 PM
  • Upgrade your boot image to 10.0.10586.0

    I've had no issues with this since doing that.

    • Marked as answer by Dan Padgett Thursday, February 25, 2016 11:53 AM
    • Unmarked as answer by Dan Padgett Monday, February 29, 2016 12:37 PM
    Thursday, February 25, 2016 12:24 AM
  • updating made no difference, made things worse as the new adk breaks osd from within windows 

    same error is still present. 

    • Edited by Dan Padgett Monday, February 29, 2016 12:38 PM
    Thursday, February 25, 2016 11:53 AM
  • Dan, I've been having the same issue.  I'm using SCCM 1511 with Windows 10.0.10586.  For OSD I am using Client 2012 R2 SP1 CU2 due to issues with the 1511 client not initializing even with a repair command line task.  I often would see the Dell Latitude E5450 with Intel I218-LM driver have its IP address disappear after applying SETUP WINDOWS AND CONFIGMGR.  The driver would be fine in device manager and disabling/enabling it caused the IP address to return.  That is to say the entry was missing entirely from IPCONFIG.  I was not even getting an APIPA address.  

    What worked for me is adding the latest DELL WINPE drivers to the boot WIM from the Dell Enterprise CAB site AND adding a REBOOT task immediately after SETUP WINDOWS AND CONFIGMGR task during OSD.  This caused the IP address functionality to work for the rest of the task sequence.  The Intel I21x series really is a problem...  All my other machines with other NICs work fine.  

    Note: I have ADK 10.1.10586 installed and used a plain vanilla x64 boot WIM from the 10.1.10586 ADK then added the latest Dell WinPE drivers.  

    Wednesday, March 2, 2016 6:29 AM
  • We're having the same issue with Intel I217-LM and I219-LM network adapters. None of the above suggestions have remedied the issue for us.
    Wednesday, March 2, 2016 4:04 PM
  • ive made a little progress

    1. Update to CU3

    2. Ensure updated client is going out in your TS

    3. delete all drivers from boot image, add only this one (modified) , http://1drv.ms/1XVaCNl  , then also create a new driver package with just that driver, i also deleted all traces of i217 from sccm drivers list.

    4. test

    try just step 3 if u cant update cu3

    Wednesday, March 2, 2016 4:06 PM
  • Does anyone know if this issue is specific to Windows 10 1511? Has anyone had this same issue with Windows 10 LTSB?
    Wednesday, March 2, 2016 4:07 PM
  • I'm currently testing with the latest driver from Intel (12.15.22.3), Win 10 RTM and CM12 CU1 ADK 10240.

    Getting really inconsistent results.  Sometimes machines build OK, other times they drop the network connection half way through the build. 

    I've added a reboot directly after the Setup Windows and Config Mgr step which does seem to help, but the NIC can sometimes lose it's configuration later on in the build.

    @Dan - what has been modified in the driver you just shared?


    Wednesday, March 2, 2016 4:18 PM
  • @Simon

    I removed the [ControlFlags] Items is all.

    my success rate is about 70%, nic still randomly disappears during/after SetupWindows/ConfiMGR step after it initialises the CMClient. 

    Wednesday, March 2, 2016 4:21 PM
  • I just wanted to throw my name in here too. Same issue and no amount of fiddling with any version of the i217 driver seems to fix it 100% of the time currently...
    Wednesday, March 2, 2016 8:00 PM
  • Still investigating this issue, however, I have noticed in the Known Issues for this driver on the Intel site;

    "Release 20.7 (or later) driver installs on Microsoft Windows 10 may time out
    or fail due to extended wait time (up to 4 minutes per Ethernet port). In
    most cases, despite the timeout, the driver installs correctly and is usable.
    If the driver does not install correctly, retry the installation process."

    This ties in with what we're seeing in the setupapi.dev.log;

    Note the 4 minute timeout. 

    So I guess this suggests that it's an Intel NIC issue and that they are aware of it. Doesn't mean they're doing anything about it though.

    Thursday, March 3, 2016 10:45 AM
  • I have the same problem with dell e7470 (i219), e7270(i219), e7450(i218) and e7250(i218). Waiting for intel to fix the problem it looks like what RobertMMoore wrote about adding a restart after "Setup Windows and ConfigMgr" works.

    Joakim Tomren



    Wednesday, March 9, 2016 8:41 PM
  • I'm having this issue with the 9030 AIO (I217) not receiving an ip address after the Setup Windows and ConfigMGR step building Windows 10 Enterprise. It doesn't always occur but its fairly frequent.

    Using SCCM 1602 and ADK 10.0.26624.

    Will try adding the reboot step and update results.

    Tuesday, May 24, 2016 2:42 AM
  • Hi, I've added the restart step and this does improve the reliability, however the issue does still occur. Adding a 2nd reboot seems to get this working every time so far.

    I've looked into it further and what appears to be happening when the machine loses the IP address is that Windows Update is kicking in and downloading updated NIC drivers from Windows Update. As soon as the install of the updated driver completes the machine loses its ip address.

    I'm currently testing adding the registry entry HKLM\Software\Policies\Microsoft\Windows\DriverSearching\SearchOrderConfig=0 after the Setup Windows and ConfigMgr step to see if this prevents the machine updating the NIC drivers.

    Check out the comments on  https://deploymentbunny.com/2016/05/10/osd-prevent-windows-to-randomly-run-windows-update-during-the-creation-of-a-reference-image/

    Friday, May 27, 2016 4:44 AM
  • So you did the following in the task sequence?

    Setup Windows and ConfigMGR step
    Restart Computer
    Restart Computer

    And that's working for you?
    • Edited by NSPILM Monday, May 30, 2016 11:14 AM
    Sunday, May 29, 2016 11:59 PM
  • That's what I did initially and it seemed to catch most of the times when the machines doesn't receive an ip address.

    However I have also now added the following prior to the two restarts to turn off driver update searching. This works as the machine now ends up with the driver version from the Dell cab as opposed to the one from Windows Update.

    cmd /c "reg add HKLM\Software\Policies\Microsoft\Windows\DriverSearching /v SearchOrderConfig /t REG_DWORD /d 0 /f"

    And at the end of the build the following to delete the entry

    cmd /c "reg delete HKLM\Software\Policies\Microsoft\Windows\DriverSearching /v SearchOrderConfig /f"

    • Proposed as answer by RJ09 Tuesday, October 4, 2016 11:59 PM
    Monday, May 30, 2016 12:54 AM
  • I am having similar issues in our environment. SCCM 1511 with Windows10

    Imaging Dell 7020,9020 with Intel Ethernet adaptor I217, I217-LM

    Imaging fails most times during setup Windows and Configuration step. (Only 50% success)

    Computer reboots and loose network connection for few seconds.

    I have tried all above mentioned steps. here is steps for my Task Sequence.

    Network settings - Domain Join

    Setup Windows and Configuration step

    Registry Key - cmd /c "reg add HKLM\Software\Policies\Microsoft\Windows\DriverSearching /v SearchOrderConfig /t REG_DWORD /d 0 /f"

    Restart Computer

    Restart Computer

    Join Domain or Workgroup ( this step contains condition - select Domain from win32_computersystem where Domain != 'domain.net') -

    Delete Registry key

    Adding registry key give some success not 100%

    NetSetup.log

    [DJOIN.EXE] Unattended Join: DsGetDcName fialed: 0x54b, last error is 0x0, will retry in 5 seconds...

    SMSTS.log

    Domain can't be contacted or doesn't exist

    Requesting assistance

    RJ


    RJ09

    Thursday, July 7, 2016 7:16 PM
  • I've actually made a bit of progress in our environment, although not every environment seems to work in the same way....

    I managed to get 10 different models all built yesterday that have all previously failed.  I still have much testing to do, but currently I have;

    • Bare Windows 10 1511 capture (no apps)
    • DriverSearching = 0 added to the WIM registry
    • June Cumulative update added to the WIM
    • Latest drivers from Intel website added directly to the WIM
    • Latest drivers from Intel website added into the driver catalogue in CM12 and assigned to a category
    • Only the above category is included in the AutoApply step at the moment

    BTW, I believe HKLM\Software\Policies\Microsoft\Windows\DriverSearching should be HKLM\Software\Microsoft\Windows\DriverSearching

    I may add a step to re-enable DriverSearching at the end of the build, haven't decided yet though.

    Although the builds now seem to complete, the resulting build has the default Windows 10 Intel driver, not the latest one from the WIM or driver catalogue.  You can also see in the event viewer that there have been a number of driver installs / re-installs occurring for the NIC.

    I still have my call open with MS and I've still got some more testing to do.

    Cheers
    Simon

    Thursday, July 7, 2016 7:26 PM
  • Hi guys, my Win7 and Win10 builds have been working 100% since I've made the above changes.

    The differences I can see is my Network Settings is join Workgroup not Domain and then Join Domain after two restart computers.

    Also the Delete registry key (Driver Searching) I do at the end of the build, other drivers start auto-updating which causes the NIC to disconnect.

    • Proposed as answer by RJ09 Sunday, July 17, 2016 8:46 PM
    Thursday, July 7, 2016 11:39 PM
  • Same issue here with multiple devices. had the same thing with lenovo but solved that issue by using diffrent bluetooth drivers. Just wanted to mention that. make sure all drivers will install. You can also test this by disableling IO devices in the bios and give it a go. Solve most of mine problems

    Now I have this issue with the HP 650 G1.

    I will try the above steps

    Wednesday, September 7, 2016 9:14 AM
  • Still without "official" solution for this errors?
    Monday, October 3, 2016 12:10 PM
  • Official from whom? The problem is with the Intel drivers (or hardware) so they'd be the ones to provide anything official.

    Jason | http://blog.configmgrftw.com | @jasonsandys

    Monday, October 3, 2016 2:39 PM
  • I am still having this issue. I have tried most things in this thread. All my new machines use the Intel I217 driver. I am sure that the docking stations are just pass through for the NIC but I am attempting that now. After that I might try a USB Ethernet Dongle.

    Thursday, October 13, 2016 9:17 PM
  • I know this is old but if someone still runs in to this issue, the Intel® Network Adapter Driver for Windows® 10
    Version: 21.0 (Previously Released) Date: 5/20/2016 (Driver Ver 12.15.23.1) is the only driver that didn't suffer from this issue and it worked for us. No more wait or extra reboots during SCCM's OSD!
    Wednesday, September 13, 2017 10:23 PM