locked
No voice mail on external call through a Dialogic 2000 when setting calls to voice mail greater than 20 seconds RRS feed

  • Question

  • I have a standard Lync install all up to date and a Dialogic 2000 working very well. The only issue I have now is someone changes the default setting for "Unanswered calls will go to:" to something higher than 20 seconds. When I set it to, say, 30 seconds, it works just fine internally (a caller hears ringing for 30 seconds and then it goes to voice mail). Externally, however, when the time is up (30 seconds in this case) it goes to dead air and you never get to the voice mail system. I have Bypass and Refer unchecked (set to not do either) and I have that RTCPActiveCalls setting already set to False. Not sure what more to look at to try to make this work so any pointers would be great.

    Steve

    Tuesday, September 25, 2012 10:31 PM

All replies

  • Hi,

    Please try to enable refer support then check the issue again.

    If still can not work, please run the Lync Server Logging Tool on the mediation server to get more logs about this failure.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, September 26, 2012 9:34 AM
  • well unfortunately enabling refer support isn't an option as it seems to degrade the quality of the calls to the point that people start complaining about calls going in and out

    Steve

    Wednesday, September 26, 2012 4:30 PM
  • Also, the Lync logging tool doesn't show any issues as it thinks the call hung up. i will work with our Dialogic support to see what they know

    Steve

    Thursday, September 27, 2012 10:45 PM
  • Do we know where exactly the call is failing in following call flow of voice mail ?

    Invite ----------->
    <----------- 180 Ringing
    (Timeout)
    Cancel ----------->
    <----------- 200 Ok
    <----------- 487 Request Terminated
    <----------- 181 Call is proxied to VM
    <----------- 180 Ringing
    <----------- 200 Ok
    Ack -------------->

    <---- RTP -------->

    -Santosh


    Thursday, October 18, 2012 2:40 AM
  • This sounds like an issue with an option I've seen on other gateways called "disconnect on broken session." The gateway hangs up on calls whenever it doesn't receive RTP from the far end IP. Combined with silence suppression, this could be tricky.

    Try this: answer call, and mute the IP side of the call. If it disconnects afer 30 seconds or so, then suspect a problem with disconnect on broken RTP. Are you using Media Bypass? Run the lync logging tool and look at the SIP trace.

    Thursday, October 18, 2012 2:00 PM
  • just to keep folks up to date. Dialogic Support is working on this but have not come up with a solution yet. It is funny as I also have an AudioCodes Mediant 2000 running on our system (we have multiple branches etc) and have none of these issues with that device with the same settings so it is clearly a Dialogic issue that they hopefully figure out. I will post here when I have useful info to share

    Steve

    Tuesday, October 23, 2012 8:12 PM