locked
Media Center - Black Screen and other errors RRS feed

  • Question

  •  

    So I wanted to check out what Media Center is, so clicked the icon, and I either get a black screen (and can see mouse pointer)and can hear a logo appear (I'm guessing that's what the noise is) or I get a batch of errors. I did get it working once last night, but then I closed it and opened it again and I get the same errors.
    Here's what the error screen says:

    Warning: No valid focus target found. Input from a keyboard or remote will be ignored until focus is restored to a valid site.
    File: <no filename info>
    line: 0

    Function
    UiSession.Microsoft.MediaCenter.UI.IInputHose.RepairInvalidKeyFocus
    KeyFocusRepairItem.Dispatch
    Dispatcher.DispatchNextItem
    Dispatcher.MainLoopBody
    Dispatcher.MainLoop
    Dispatcher.MainLoop
    Application.Run
    PageBasedUCPService.Run
    UserControlPoint.Launch
    LaunchMediaCenter.LaunchMediaCenterHelper

    Here is the "Problem Reports and Solutions" dump:

    Problem signature
    Problem Event Name: APPCRASH
    Application Name: ehshell.exe
    Application Version: 6.0.6001.18000
    Application Timestamp: 47919b1f
    Fault Module Name: ntdll.dll
    Fault Module Version: 6.0.6001.18000
    Fault Module Timestamp: 4791a797
    Exception Code: 80000003
    Exception Offset: 00000000000da600
    OS Version: 6.0.6001.2.1.0.256.1
    Locale ID: 1033
    Additional Information 1: 5130
    Additional Information 2: af2cdea937a84a261979c21f30b6b6eb
    Additional Information 3: 8cf2
    Additional Information 4: e3ff6035b1c3d2ca8d0797a9ac81da1e

    Extra information about the problem
    Bucket ID: 1213728


    Everything is current and updated. Any ideas?

    Monday, June 2, 2008 4:20 PM

All replies

  • I have the exact same problem.  When I alt-tab out of MC, it becomes visible,  I can see it behind whatever other apps I have up.  When I bring focus on MC again the screen goes black!

    Thanks.
    Sunday, June 29, 2008 1:31 AM
  • I'm getting the exact same error.  Tried different video cards, different driver versions, etc.  I'm at a loss.  Everything is current and updated with me too.

     

    Thursday, July 31, 2008 11:41 PM
  • To the second & third posters:
    My first thought is that you installed a program that also included an MPEG decoder of its own, said program set that decoder as the default, and said decoder isn't compatible with Media Center.
    If you would, install and run the Vista version of the media center decoder check utlity (download from here, and see what it has to say.
    If either the video and/or audio decoders are not
    set to the Microsoft decoders, switch them to that, close apps, and reboot.  Recheck functionality.

    To the first poster:
    Have you installed SP1 yet?  Is Media Center itself up-to-date?  (Current version is 6.0.6001.18000, and can be viewed in Media Center > tasks > settings > general > about media center > software version.)

    Friday, August 1, 2008 2:24 AM
  • I ended up upgrading to Vista Home Premium.  I was, however, using a third party MPEG encoder in WinXP MCE.  That could have been the problem.

    I purchased a Hauppage WinTV HVR 1800.  I guess that came with a compatible mpeg decoder.

    Thanks for the response!

    Dean
    Friday, August 1, 2008 1:19 PM
  • Well, now that we've found that desropolis was running Media Center 2005 (XP)....
    ckmichik:  what OS - Vista or XP?

    Friday, August 1, 2008 3:23 PM
  • Vista Ultimate SP1 with me.  Now that you mention MPEG codecs, I did install the KLCodec package...so I've got a whole bunch of codecs installed that probably aren't compatible with Media Center.  That's a great catch there, I'll uninstall KLCodec and run that codec utility when I get home today and see if that resolves the issue.
    Friday, August 1, 2008 6:18 PM
  • I'd have to say that that's your problem.  K-Lite, in general, sucks.  On a Media Center, K-Lite nearly always breaks Media Center.
    Uninstall that.  Reboot.  Try Media Center again.  It should work correctly.  If it still doesn't, then install the decoder-check utility & run it.
    For future note, ffdshow-tryouts does play well with Media Center (also, 'tis highly recommended by many experts at thegreenbutton), and will handle most anything that Vista can't handle natively.

    Saturday, August 2, 2008 3:08 AM