locked
Internal Email Stuck in Queue During Exchange 2010/2016 coexistence RRS feed

  • Question

  • Hi all,

    i've recently installed a new Exchange 2016 server, in coexistence with our existing 2010 Server.  I've got things set up well in most parts, and email is flowing externally, via the 2016 server.  I can also send emails internally from mailboxes on the 2016 server to 2010 mailboxes but any emails sent from 2010 mailboxes to 2016 mailboxes are not received and are stuck in the 2010 message queue with a status of ready.  I've added the 2010 server as an allowed relay on the 2016 receive connector but I don't know where else to look.

    Can anyone help?

    Thanks in advance.

    Monday, May 23, 2016 8:44 AM

Answers

  • OK, so I've finally managed to get to the bottom of this.  Using https://blogs.technet.microsoft.com/messaging_with_communications/2011/04/22/how-to-manage-exchange-2010-message-queues/  I got the error message of the queue, which pointed me towards this:

    https://blogs.technet.microsoft.com/tkern/2011/03/30/451-4-4-0-primary-target-ip-address-responded-with-451-5-7-3-cannot-achieve-exchange-server-authentication/

    It seems that when you create an additional receive connector, with specific IP addresses as relays, that include the IP addresse of the 2010 server, this causes authentication problems, as the connector with the specific IP addresses always gets used first, so there are authentication problems.

    • Marked as answer by mcollinson Monday, May 23, 2016 2:21 PM
    Monday, May 23, 2016 2:06 PM

All replies

  • Hi,

    Check this,

    1. Configure the Send connector in 2010 using send mail through MX record and Check the MX record of server 2010 pointing to server 2016.

    Please mention the queue type and any queue error is showing

    Monday, May 23, 2016 9:24 AM
  • I've changed the send connector on the 2010 server to use MX instead of smart host (we send email via our Sophos SMTP Proxy) but emails are still not received from 2010 mailboxes to 2016 ones.  The queue type is "SMTP Relay in Active Directory Site".  The emails in stuck in the queue have a status of ready and don't show any error..
    Monday, May 23, 2016 10:14 AM
  • Hi

    Try this

    create SMTP relay

    1. Create Generic host record in DNS mention the name as smtp
    2. Go to EAC->Mail flow->Receive Connector
    3. Create one receive connector with some name and role as front end transport, type custom
    4. n/w bindings as ip4 port 25
    5. In Remote network settings, give the IP address of share point server
    6. Select security tab, give permission groups as check Anonymous user and save it.
    Monday, May 23, 2016 10:27 AM
  • I'm not totally sure I understand what you're saying.  Do I create an internal DNS record?  Like smtp.xxx.xxx?  To point to our new 2016 server?

    Also, I don't know why you mention sharepoint?  Do you mean our exchange 2016 server again?

    Monday, May 23, 2016 10:44 AM
  • Sorry for that, yes its exchange 2016 only.

    Yes, You need to create a host DNS record like smtp.contosomail.com to point 2016.

    Monday, May 23, 2016 11:26 AM
  • Just tried that but it still doesn't work.....
    Monday, May 23, 2016 11:50 AM
  • Sorry for that, yes its exchange 2016 only.

    Yes, You need to create a host DNS record like smtp.contosomail.com to point 2016.

    You do not need a special DNS record for mail to flow between Exchange servers within the same organization.  Exchange knows how to handle that.

    Did you create any custom receive connectors on the Exchange 2016 server that have the IP of the Exchange 2010 server listed? 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread

    • Proposed as answer by Floweezy Thursday, April 4, 2019 8:58 AM
    Monday, May 23, 2016 1:34 PM
  • OK, so I've finally managed to get to the bottom of this.  Using https://blogs.technet.microsoft.com/messaging_with_communications/2011/04/22/how-to-manage-exchange-2010-message-queues/  I got the error message of the queue, which pointed me towards this:

    https://blogs.technet.microsoft.com/tkern/2011/03/30/451-4-4-0-primary-target-ip-address-responded-with-451-5-7-3-cannot-achieve-exchange-server-authentication/

    It seems that when you create an additional receive connector, with specific IP addresses as relays, that include the IP addresse of the 2010 server, this causes authentication problems, as the connector with the specific IP addresses always gets used first, so there are authentication problems.

    • Marked as answer by mcollinson Monday, May 23, 2016 2:21 PM
    Monday, May 23, 2016 2:06 PM