locked
Windows picture viewer make pics really dark PROBLEM RRS feed

  • Question

  • Since upgrading to window 7 64 bit from XP i cannot view any pictures in windows picture viewer as they are soooooo dark! And NOT what they are really like. Now this is a problem as i use it to decide which photo's to edit before pulling them into Photoshop

    Any way i can change this? Thanks

    Saturday, October 1, 2011 3:44 PM

Answers

  • To add a little detail, the settings are controlled in the Color control panel.

    The profile provided by my monitor's maker (Samsung) gave a yellowish cast in the picture viewer. I had to check the box to use a profile I defined, and then set an sRGB profile as default, to get a more normal appearance. (I'm sitting in front of an XP box as I write this, so I'm relying on memory.) That profile doesn't give a calibrated image, but the colors are similar to the defaults in XP.

    Wednesday, October 5, 2011 2:21 PM
  • Hi,

     

    I suggest updating your graphic card driver and display adapter driver from manufacture's site first.

     

    Then, go to Control Panel\All Control Panel Items\Display, click Calibrate color in the left pane.

     

    More information for reference

    http://windows.microsoft.com/en-US/windows7/Calibrate-your-display

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Niki Han Wednesday, October 19, 2011 3:18 AM
    Thursday, October 6, 2011 9:06 AM

All replies

  • To add a little detail, the settings are controlled in the Color control panel.

    The profile provided by my monitor's maker (Samsung) gave a yellowish cast in the picture viewer. I had to check the box to use a profile I defined, and then set an sRGB profile as default, to get a more normal appearance. (I'm sitting in front of an XP box as I write this, so I'm relying on memory.) That profile doesn't give a calibrated image, but the colors are similar to the defaults in XP.

    Wednesday, October 5, 2011 2:21 PM
  • Hi,

     

    I suggest updating your graphic card driver and display adapter driver from manufacture's site first.

     

    Then, go to Control Panel\All Control Panel Items\Display, click Calibrate color in the left pane.

     

    More information for reference

    http://windows.microsoft.com/en-US/windows7/Calibrate-your-display

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Niki Han Wednesday, October 19, 2011 3:18 AM
    Thursday, October 6, 2011 9:06 AM
  • Not sure if you have resolved this yet but I know your issue.  I have the same issue and what people are not realizing is this has nothing to do with windows or display settings or drivers, this is very specific to the Photoviewer software.  I am a graphic/3d artist as well as photographer.  At work I have Dell IPS monitors and at home I have Asus IPS monitors.  At work I have an nvidia Quadro 5000 series and at home I run dual nvidia gtx 580 cards.  I have the newest drivers and firmware available and have all monitors and video card settings set to sRGB space and checked the calibration with a spyder calibration tool.  I have it set so that the nvidia control center is in full control of the color management but have tried it through Windows (using windows calibration) as well.  I have tested many different media viewers and found this problem only on Windows picture viewer and Windows live photo gallery.  Surprisingly Windows media center displays images correctly.  Not only are the images dark in picture viewer but over saturated (mainly in the blues and greens).  I have yet to find a remedy for this but unlike other suggestions in here I would highly recommend against compensating for this as it will display and print wrong every place else.  The only solution i have come up with so far is to set a different default image viewer.  I personally use xnview as it can open almost any file type there is but quicktime viewer and picassa are other good alternatives.  All of them are free so that helps a bunch.  The problem I still have as I am sure you have as well is that when you send images to other people the vast majority will open them in picture viewer as it is the default viewer in windows.  My suggestion is if it is something important for example a client you are working with then make sure to have them view it in a different viewer and give them a link to download whatever viewer you choose.  Its not the best solution but until Microsoft changes the gamma settings in picture viewer your out of luck and any drivers or calibration you do won't make a difference in the world.  Its unfortunate.  The other alternative is to only share your images online.  All main web browsers will show in sRGB which is what you should be shooting in.  Although Adobe RGB has a wider color spectrum it still shows the same amount of colors and also the colors are far more inacurate than sRGB.  Plus sRGB is a world wide standard and is default on most devices so what you see is what everyone else sees.  Veiwing through a browser even IE will show the true accurate color.  Anyway good luck and I as well as you hope that MS will fix this and put it in an update sometime soon.
    Tuesday, February 21, 2012 5:22 PM
  • I am having the same problem: images display just fine in photoshop (color-managed), microsoft word (color-managed), google chrome (non-color-managed), etc, but anything I open in Windows Live Photo Gallery is VERY noticeably darker / higher in contrast. I have verified this by taking screenshots within each application of the same image and overlaying them in photoshop for direct comparison.

    So it appears that Microsoft decided to render its images in WLPG by 'writing the image to a DirectX surface'. That means that DirectX must be causing the color management issues, because I don't believe its color managed at all. I have emailed Nvidia to ask if theres a way to color manage DirectX.

    I don't know what the programmers at Microsoft are smoking, but this is a major inexcusable slip-up thats wasted way too much of my time. Is there such a thing as a computer that 'just works'? Did someone say Mac?

    Sunday, September 9, 2012 4:07 AM
  • OK, I jumped the gun: it looks like DirectX is color-managed. I opened up "Chess Titans" (uses directx) and a photo in WLPG and simultaneously used Windows 7 calibration to change the gamma. Chess Titans and the WLPG photo both updated in real time. I have already dialed in my color profile (by eye, not with calibration hardware) and don't want to mess with it just because a single program didn't correctly implement color management. I am really not liking Microsoft right now...

    Computer: Lenovo T420

    Video Card: Nvidia NVS 4200M (bios set to always use "discrete graphics" instead of "Optimus" which saves power but switches between Nvidia card & integrated video card based on usage)

    Monitor: LG M2280D monitor connected via DisplayPort/HDMI adapter (monitor HDMI input set to "PC" to force 1:1 native resolution)

    Saturday, September 15, 2012 5:13 AM
  • OK, we're making some progress here. I just unhooked the external monitor and retested using the laptop's LCD: PROBLEM SOLVED - No difference in colors between Windows Live and paint, photoshop, ms word, etc.

    I just reconnected the monitor, and changed the color management in the Nvidia Control Panel from "other applications control color settings" to "Use Nvidia Settings". Same problem: WLPG is bumping up the contrast. I verified this in photoshop using the eyedropper: whites are whiter and darks are darker.

    Any thoughts? Thank you!

    Saturday, September 15, 2012 5:52 AM
  • The video card is nvidia, not geforce. I can try the latest nvidia driver for the NVS 4200M, which is v305.93 if you think it will solve this.
    Sunday, September 16, 2012 5:38 PM
  • Installed the latest NVIDIA driver. It didn't fix the problem... Do you think this is a Microsoft bug or an NVIDIA bug?
    Sunday, September 23, 2012 3:32 PM
  • A lot of misleading answers here.

    Firstly, the effect you observe is a major and well-known bug in Windows Photo Viewer - the program that launches by default when you double-click on the picture. Windows Photo Viewer implements improper color management.

    Secondly, people who suggest that you should "calibrate and profile your monitor" are completely missing the crux of the matter. It is exactly "calibrating and profiling your monitor" that activates this bug. This bug will not reveal itself if Windows is set to use its default color profiles.

    This is what happens:

    As many of you know, when you calibrate & profile your monitor using the appropriate hardware/software package, the profiler software generates ICC profile for the monitor as well as gamma correction table stored inside that ICC profile. In order for that new profile to work properly, you have load the gamma correction data into the LUT table of your video card. This can be done in two ways: either 1) by using a small gamma-loader utility supplied by the vendor of your profiling product, or 2) by using Windows 7 built-in capabilities. These gamma-loading capabilities are new to Windows 7 (actually, they were present in Vista as well, but very poorly implemented).

    Many people prefer the latter approach, since they don't want to run an extra third-party utility, when Windows can do it for them by itself. In order to use the latter approach you will have to register the new monitor profile in the Windows Color Management engine and ask Windows to load gamma from the registered ICC profile. It will work as it is supposed to, but unfortunately it will destroy normal functionality of Windows Photo Viewer. Pictures in Windows Photo Viewer woill suddenly appear dark. It is a bug in Windows Photo Viewer, which Microsoft so far failed to address.

    All other software (including the color-managed one) will continue to work properly.

    One workaround for this problem is to stop using the built-in capabilities of Windows 7 for gamma loading. Ask Windows to stop loading gamma, and use the standalone gamma loading utility provided by the vendor of your monitor profiling software.

    Another workaround is to stop using Windows Photo Viewer. Download a properly implemented color-managed third party picture viewer and you should be fine.





    • Edited by Andrey-T Friday, September 27, 2013 6:48 PM
    Friday, September 27, 2013 6:43 PM
  • It is to do with the ICC color management. 
    Go to control panel->color management and you will see the profile you currently have set. Click "add..." and choose another colour management option. I went for an Adobe one as they're usually pretty good with color balancing. It sorted the problem for me.
    Friday, May 16, 2014 7:59 AM
  • I have the same problem in windows 8.1 . Other programs are fine, but the default one shows pictures very dark. This is a very annoying bug which has cost me a lot of time because I though the problem was with my camera settings.
    Saturday, October 18, 2014 2:55 PM
  • Since upgrading to window 7 64 bit from XP i cannot view any pictures in windows picture viewer as they are soooooo dark! And NOT what they are really like. Now this is a problem as i use it to decide which photo's to edit before pulling them into Photoshop

    Any way i can change this? Thanks

    I will need both the video card make and model and the panel make and model to be able to help you configure your system for the best the hardware can do.

    Not everyone has a high-end panel like mine, but there are a few easy steps.

    Best is to use HDMI if available, or DVI if you are using an older TN panel




    Place your rig specifics into your signature like I have, makes it 100x easier!

    Hardcore Games Legendary is the Only Way to Play!
    Vegan Advocate How can you be an environmentalist and still eat meat?


    • Edited by Carey FrischMVP Sunday, October 19, 2014 4:07 AM Removed distracting graphic
    Saturday, October 18, 2014 3:11 PM