none
DPM2010 DPMBackup v1.0 - "Error: Invalid command -db." RRS feed

  • Question

  • Hi all,

    Well, I have a very odd issue. I am trying to backup DPM2010 with the command DPMBackup.exe -db, and I receive the following response:

    C:\Program Files\Microsoft DPM\DPM\bin>dpmbackup -db
    DpmBackup 1.0 - Data Protection Manager backup command-line tool
    Copyright (c) 2010 Microsoft Corporation. All rights reserved.

    Error: Invalid command -db.

    Description:
             DpmBackup backs up the DPM database, and creates shadow copies that can be used for backing up replicas.
             To back up the DPM database, run DpmBackup.exe -db locally on the computer running the instance of SQL Server used by DPM.
     Usage:
             DpmBackup.exe [-db [-instanceName <name>] [-targetLocation <location>]] [-replicas] [-certificates]

             [-db]               Backs up the databases to the default backup location on the DPM server, %DPMInstallLocation%\Volumes\ShadowCopy\Database Backups\.

             [-instanceName]     Specifies the instance of SQL Server that hosts DPMDB. This parameter can be used only with -db.
                                 If you are backing up from a remote instance of SQL Server:
                                 -   From a named SQL instance, provide the instance name with -instanceName.
                                 -   From a default SQL instance, provide "(Local)" with -instanceName.
                                 If SQL Server is not on the same computer as DPM, the default backup location for DPMDB will be %SystemDrive%\DPMBackup.
             [-targetLocation]   Overrides the default backup location and points to a folder on the local computer.
                                 If -db is specified, the folder path should be an absolute path.

             [-replicas]         Creates and mounts shadow copies of the DPM replica volumes to %DPMInstallLocation%\Volumes\ShadowCopy.

             [-certificates]     Creates a file of the public certificates at %DPMInstallLocation%\DPMBackup\Certificates.


    The application event log has no error records. The database is SQL 2008 SP1. The operating system is Windows Server 2008 R2.

    Please help! :-)

    Thank you very much in advance.

    With regards,

    Robert

    • Edited by -Rob.A- Monday, October 18, 2010 3:29 PM
    Wednesday, October 13, 2010 4:09 PM

Answers

  • Hi Robert,

     

    Providing the instanceName parameter probably solves the problem.

    like: DpmBackup.exe -db -instanceName MSDPM2010

    The value for the instance name parameter is available in registry at:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\DB @ InstanceName

     

    Thanks,

    Arun

    • Marked as answer by -Rob.A- Wednesday, October 20, 2010 4:00 PM
    Wednesday, October 20, 2010 7:30 AM
  • Awesome Arun!

    The command failed with; "Error: Backup failed for Server [serverName]\[instanceName]". The Application Error Log had Event ID 18204 from the SQL server instance with the following error:

    BackupDiskFile::CreateMedia: Backup device 'C:\Program Files\Microsoft DPM\DPM\Volumes\ShadowCopy\Database Backups\DPMDB.bak' failed to create. Operating system error 5(Access is denied.).

    I added -targetLocation [networkShare] and the command completed successfully! Now all I need is a script to backup the database daily.

     

    Thanks again Arun!

     

    With regards,

    Robert

    • Marked as answer by -Rob.A- Wednesday, April 29, 2015 8:06 PM
    Wednesday, October 20, 2010 4:00 PM

All replies

  • Hi

    Are you using a local installation of SQL 2008 SP1, is the DPMDB local? Is the SQL service running?

     

    BR

    Robert Hedblom



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Thursday, October 14, 2010 6:13 AM
    Moderator
  • Hi Robert,

    Thank you for your reply. Yes SQL 2008 SP1 is local and running.

    With regards,

    Robert

    Thursday, October 14, 2010 12:28 PM
  • Not sure if there is a specific bump schedule, but this is a rather critical issue and I really need help with this one.

    Thank you.

    Robert

    Monday, October 18, 2010 3:31 PM
  • Hi Rob!

    Have you tried to run the DPMBACKUP.EXE in an elevated prompt? Are you loged on as a domain administrator?

     

    BR

    Robert Hedblom



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Monday, October 18, 2010 6:13 PM
    Moderator
  • Hi Robert,

     

    Thank you for trying to help. Yes the command is being executed in an elevated command prompt, and I am a member of the Domain Administrators group. I receive the following message when trying to run the command from a standard command prompt:

    Please run DPMBackup.exe with administrator privileges.

     

    With regards,

    Robert

    Monday, October 18, 2010 6:35 PM
  • Hi Robert,

     

    Providing the instanceName parameter probably solves the problem.

    like: DpmBackup.exe -db -instanceName MSDPM2010

    The value for the instance name parameter is available in registry at:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\DB @ InstanceName

     

    Thanks,

    Arun

    • Marked as answer by -Rob.A- Wednesday, October 20, 2010 4:00 PM
    Wednesday, October 20, 2010 7:30 AM
  • Awesome Arun!

    The command failed with; "Error: Backup failed for Server [serverName]\[instanceName]". The Application Error Log had Event ID 18204 from the SQL server instance with the following error:

    BackupDiskFile::CreateMedia: Backup device 'C:\Program Files\Microsoft DPM\DPM\Volumes\ShadowCopy\Database Backups\DPMDB.bak' failed to create. Operating system error 5(Access is denied.).

    I added -targetLocation [networkShare] and the command completed successfully! Now all I need is a script to backup the database daily.

     

    Thanks again Arun!

     

    With regards,

    Robert

    • Marked as answer by -Rob.A- Wednesday, April 29, 2015 8:06 PM
    Wednesday, October 20, 2010 4:00 PM
  • This worked for me.  Thanks.
    Thursday, January 27, 2011 2:19 PM