locked
Asterisk & Lync - Ringing after I answer RRS feed

  • Question

  • Hi, all!
    I have integration PBX with Lync.
    PBX <=>(H.323) Asterisk (SIP)<=> Lync
    Almost everything works, calls go both ways

    But if I call from PBX to Lync, then the client Lync after lifting handset heard beep call during the conversation, but  who calls from PBX not heard beep.
    All logs, this for Lync log analizer.

     

    Short logs:
    Report time:
    08.09.2011 17:26:38
    Response code:
    504
    Diagnostic ID:
    1022
    Request type:
    INVITE
    Content type:
    multipart/alternative
    Source:
    nl-lync.ao.nl
    Application:
    From user URI:
    sip:nl-lync.ao.nl@nl.ru;gruu;opaque=srvr:MediationServer:PtZ3-aDre1GAS1qRdpBuhQAA;grid=c5d92958a9f144d495684282e476842a
    To user URI:
    h@192.16.10.4
    From user agent:
    RTCC/4.0.0.0 
    MediationServer
    Diagnostic header:
    1022; reason="Cannot process routing 
    destination"; Destination="sip:h@192.16.10.4:5068"; 
    source="nl-lync.ao.nl"


    TL_INFO(TF_PROTOCOL) [6]0C64.2190::09/08/2011-13:26:23.495.0005a497 ((Shared),SipMessage.DataLoggingHelper:sipmessage.cs(686))[3097936671]
    <<<<<<<<<<<<Incoming SipMessage c=[<SipTlsConnection_2616CEC>], 192.16.10.4:63725<-192.16.10.4:5061
    SIP/2.0 180 Ringing
    FROM: "Inzhener-progro"<sip:474241428;phone-context=DefualtProfile@nl.ru;user=phone>;epid=D044277D44;tag=25473fff30
    TO: <sip:31428;phone-context=DefualtProfile@nl.ru;user=phone>;epid=34a5c0d722;tag=388ad28bd2
    CSEQ: 8999 INVITE
    CALL-ID: af3da14e-8f58-4298-8007-793e0fae7f10
    VIA: SIP/2.0/TLS 192.16.10.4:63725;branch=z9hG4bKeb195cae;ms-received-port=63725;ms-received-cid=44FB00
    CONTENT-LENGTH: 0
    USER-AGENT: UCCAPI/4.0.7577.314 OC/4.0.7577.314 (Microsoft Lync 2010)
    P-ASSERTED-IDENTITY: <sip:kp@nl.ru>
    ms-application-via: nl-lyncmon.ao.nl_sqllync;ms-server=nl-lync.ao.nl;ms-pool=nl-lync.ao.nl;ms-application=51FB453D-5B9F-45df-83B4-ADD1F7E604A8
    Privacy: id
    ------------EndOfIncoming SipMessage

     

    Please, help!

     


    Monday, September 12, 2011 11:51 AM

Answers

  • Hi, I did it!

    This bug in broken Asterisk extension, when PBX call to Asterisk->Lync

    before:

     

     

    exten => _XXXX,n,Dial(SIP/Lync_Trunk/3${EXTEN},20)

    exten => _XXXX,n,hangup()

     

     

    after:

    exten => _XXXX,n,Answer()

    exten => _XXXX,n,Dial(SIP/Lync_Trunk/3${EXTEN},20)

    exten => _XXXX,n,hangup()

     

    I add command  

    exten => _XXXX,n,Answer() and it works!

    thank you all!

    Tuesday, September 27, 2011 8:03 AM

All replies

  • additional: If during the conversation, when I hear a dial tone, a press from lync call hold, then dial tone disappears! why?
    Friday, September 16, 2011 11:31 AM
  •  

    In Lync - try turning Media Bypass off.

    If that does not work, try setting NAT=YES in Asterisk.

    Regards

    Paul Adams

     


    MS Lync Server 2010 Resource Kit writer | website: www.pauladamsit.com
    • Marked as answer by Sean_Xiao Thursday, September 22, 2011 1:41 AM
    • Unmarked as answer by Kuznetsov Pavel Tuesday, September 27, 2011 8:01 AM
    Monday, September 19, 2011 7:28 PM
  • Hi, I did it!

    This bug in broken Asterisk extension, when PBX call to Asterisk->Lync

    before:

     

     

    exten => _XXXX,n,Dial(SIP/Lync_Trunk/3${EXTEN},20)

    exten => _XXXX,n,hangup()

     

     

    after:

    exten => _XXXX,n,Answer()

    exten => _XXXX,n,Dial(SIP/Lync_Trunk/3${EXTEN},20)

    exten => _XXXX,n,hangup()

     

    I add command  

    exten => _XXXX,n,Answer() and it works!

    thank you all!

    Tuesday, September 27, 2011 8:03 AM