locked
Error 0x80070643 during installation RRS feed

  • Question

  • I try to install the MAP 9.0 toolkit but every time I get the message "Setup failed to update the product. Fix the issue and run setup again". When I review the log file i find the 0x80070643 error:

    [1FD4:1DF8][2014-01-15T08:49:51]i323: Registering package dependency provider: {C9EA7601-C4C5-4B98-8405-7EEADCC29F92}, version: 9.0.135.0, package: MAPSetup_x86.msi
    [1FD4:1DF8][2014-01-15T08:49:51]i301: Applying execute package: MAPSetup_x86.msi, action: Install, path: C:\ProgramData\Package Cache\{C9EA7601-C4C5-4B98-8405-7EEADCC29F92}v9.0.135.0\MAPSetup_x86.msi, arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7" INSTALLDIR="C:\Program Files\Microsoft Assessment and Planning Toolkit" TRANSFORMS="" CEIPENABLED="0" LOCALDBDROP="0"'
    [1FD4:1DF8][2014-01-15T08:49:59]e000: Error 0x80070643: Failed to install MSI package.
    [1FD4:1DF8][2014-01-15T08:49:59]e000: Error 0x80070643: Failed to execute MSI package.
    [03E4:0E40][2014-01-15T08:49:59]e000: Error 0x80070643: Failed to configure per-machine MSI package.
    [03E4:0E40][2014-01-15T08:49:59]i319: Applied execute package: MAPSetup_x86.msi, result: 0x80070643, restart: None
    [03E4:0E40][2014-01-15T08:49:59]e000: Error 0x80070643: Failed to execute MSI package.

    I tried to repair my .NET 4.5 installation, removed .NET 4.5 and reinstalled again. Still getting the same error.

    I'm using windows vista Business. What can I do to fix this error message?

    Wednesday, January 15, 2014 8:00 AM

All replies

  • I get the same error message wen attempting to load MAP 9 on Windows 2008 Server. I have yet to find a solution.
    Friday, January 24, 2014 10:34 PM
  • Yeah I am getting the same thing as well.

    My Situation is Win 2k8 R2 + SP2

    I am also trying to install to a Local 2008 R2 SQL instance of MAPS. I thought it was something to do with the Full version of SQL. But I have not found a solution either at this point.


    Padrick Goodwin, MCSE + M

    Tuesday, February 11, 2014 11:56 PM
  • Hi

    I hate to be repetitive but I am also having the same problem. Have tried MAP 9 on both Win Server 2008 and 2008R2.

    Error 0x80070643: Failed to install MSI package


    IT Services | Insight Nordics

    Wednesday, February 12, 2014 8:55 AM
  • In MAP 9.0 we overhauled our installer in order to be able to install SQL LocalDB in the recommended way. Unfortunately, the new MSI appears to have trouble with Vista/2008 versions of Windows. At this time we are dropping support for installing MAP on Vista/2008 while we investigate.


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. Please VOTE as HELPFUL if the post helps you. This can be beneficial to other community members reading the thread.

    Thursday, February 13, 2014 7:35 PM
  • Has anyone has the download link for MAP 8.5 meanwhile?

    Tuesday, March 4, 2014 5:56 PM