none
Struggling with Azure AD and Windows 10 Store RRS feed

  • Question

  • Hi,

    I've joined a new Windows 10 laptop to our Azure AD domain to see how I get on before rolling it out more widely. I'm now in a position where I can't access the Windows Store (the app crashes immediately after loading). The "Application" event log is also full of 5973 errors relating to being unable to activate the store app.  Apparently one potential solution is to change the ownership of the \Program Files\WindowsApps folder to your own account, then to TrustedInstaller.  I can't do this however as I'm not able to reference my Azure AD account in the dialog (AZUREAD\MyAccount isn't accepted). I've also tried creating a new local admin account but that seems to be disabled when I check in the Computer Management MMC.

    Can anyone advise what to do? How can I make myself the owner of the folder in question? I've tried looking for help on this but the documentation appears to be sparse to say the least.

    Thanks!

    Thursday, October 15, 2015 1:49 PM

Answers

All replies

  • Hi,

    Based on my test, yes, we cannot add the Azure AD account into that ownership list.

    So the only way for now is running this command to re-register all Windows Store apps:

    1. Run PowerShell as Administrator.

    2. Copy the following command, press Enter.

    Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} 

    If it doesn't working, delete this Azure Ad account from this computer and re-add it for test.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, October 19, 2015 7:35 AM
    Moderator
  • Hi Karen,

    Thanks for your reply. I've run the command but the store still does not load. I tried registering just the store app (I'm not having issues with any other app) and I get the following error:

    Deployment failed with HRESULT 0x80073CF6, Package could not be registered.
    Merge Failure: error 0x8007003

    I've tried repairing the Windows image with DISM but that hasn't helped.

    I'd prefer not to have to delete the user account in question as it's the one I use on a daily basis.

    Thanks.


    • Edited by NJC1 Monday, October 19, 2015 11:05 AM
    Monday, October 19, 2015 11:05 AM
  • I managed to fix this in the end by creating a new local administrator account, logging on with that account, updating the store app and then logging back in using the Azure AD account.

    I'm still confused as to why I can't set an Azure AD account as a file owner though?

    Monday, October 19, 2015 2:58 PM
  • This is the default. Because that there is no Azure AD location as the object in the list like domain joined.

    Monday, October 26, 2015 8:22 AM