locked
SfB photos blurry RRS feed

  • Question

  • Hi everyone,

    We uploaded user photos to exchange with the resolution 648x648 with the exchange management shell (set-userphoto).

    We’re using Exchange Server 2016 and Skype for Business Server 2016 on premise.

    In the Skype for Business options, the picture shows as 648x648 for the user. Also, with the get-userphoto cmdlet, the picture is retrieved in 648x648. However, when the user is called, the picture that’s shown is blurry.

    We already upped the “MaxPhotoSizeKB” attribute to 300KB on the Skype Server, unfortunately this didn’t help either.

    When you call yourself, the photo will be displayed properly in 648x648. But if anyone else calls you, it isn’t.

    Thanks

    Wednesday, December 5, 2018 2:47 PM

All replies

  • Hi,

    Does it impact all users or specific user? 

    Please make sure you have installed the latest CU for SFB server.

    Also, please run "update-csaddressbook" as admin in sfb mgmt shell.

    After that, please try to use Microsoft Skype for Business Basic version to test if it is fixed.

    Kind regards,

    Calvin Liu


    Please remember to mark the reply as an answer if you find it is helpful. It will assist others who has similar issue. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, December 6, 2018 9:13 AM
  • Hi,

    Are there any update for this issue, if the reply is helpful to you, please try to mark it as an answer, this will make answer searching in the forum easier and be beneficial to other community members as well. :) 

    Kind regards, 

    Calvin Liu


    Please remember to mark the reply as an answer if you find it is helpful. It will assist others who has similar issue. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to shareexplore and talk to experts about Microsoft Teams.


    Tuesday, December 11, 2018 6:33 AM
  • Hi Calvin,

    Thank you for your answer. It does affect all users and our Skype for Business Server is up to date.

    Unfortunately, running "update-csaddressbook" on the skype server didn’t help fixing the issue, both a SfB 2016 client and a freshly installed SfB Basic client do still show blurry pictures.

    Kind regards

    Florian

    Tuesday, December 11, 2018 9:29 AM
  • Hi,

    Please validate that the image was successfully imported go to the following URL in a web browser and the photo should appear in the window. 

    Enter the SMTP address of the desired user account in the URL where indicated in red.

    https://exchangeFQDN/ews/Exchange.asmx/s/GetUserPhoto?email=abc@domain.com&size=HR648x648

    And also please follow the steps introduced here when setting up high resolution photos.

    Besides, please also take a look at the EWS status by checking SFB configuration information, please hold on Ctrl key and right click Skype for Business icon in the taskbar, click configuration information feature.

    If the EWS external URL and EWS internal URL are blank, it's likely that the autodiscover process is failing that cause the failed connectivity with Exchange. 

    Kind regards,

    Calvin Liu


    Please remember to mark the reply as an answer if you find it is helpful. It will assist others who has similar issue. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.


    • Edited by Calvin-Liu Thursday, December 13, 2018 9:23 AM
    • Proposed as answer by Calvin-Liu Monday, December 24, 2018 9:24 AM
    Thursday, December 13, 2018 9:22 AM
  • Hi,

    When entering the URL to the EWS, the picture comes up in the resolution 648x648. We followed the article you linked while setting up the pictures.

    In the SfB configuration information, the external and internal URL aren’t blank (both are https://exchangeserver.com/EWS/Exchange.asmx).

    Best regards,

    Florian

    Thursday, December 13, 2018 2:53 PM
  • Hi,

    Well, so the EWS status shows OK as well, right?

    Please try the following action plan to test again.

    Removed the User profile picture completely. Also check the AD attribute "thumbnailPhoto" make sure its empty.

    Then we can get an photo with the below settings and just try to set the photo for one testing user separately.

    Image Resolution 648 by 648 pixels Color Depth 24-bit Image file size up to 20 MB File format JPEG.

    Once we have the photo then we can upload it from the OWA or we can try uploading it through Exchange shell command as per the following:

    $photo = ([Byte[]] $(Get-Content -Path "{UNCPII}" -Encoding Byte -ReadCount 0))

    Set-UserPhoto -Identity "{Namepii} {Namepii}" -PictureData $photo -Confirm:$False

    Kind regards,

    Calvin Liu


    Please remember to mark the reply as an answer if you find it is helpful. It will assist others who has similar issue. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, December 14, 2018 9:24 AM
  • Hi,

    Yes, the EWS status does show OK.

    We followed your instructions for testing it again, after removal of the photo the “thumbnailPhoto” attribute was empty.

    Unfortunately, after adding the photo with the Exchange command you wrote it’s still the same issue. The photo does show as 648x648 in skype – but in a call it’s blurry. The photo has a resolution of 648x648, depth of 24 bit , is a jpg (also tried it with jpeg, didn’t work either) and is 198 KB in size.

    Thanks for your help and best regards,

    Florian

    Monday, December 17, 2018 8:24 AM
  • Hi Florian,

    Well, it seems that the issue is not caused by the improper importing method for the photo. 

    Please try to check the configuration of Oauth certificate, run Get-CsOAuthConfiguration to see if the connection between Exchange and SFB is OK. Please check if the ExchangeAutodiscoverUrl exists and the suffix is ".svc". If not, please redefine the location of Exchange Autodiscover to make sure SFB could connect with Exchange.

    Kind regards,

    Calvin Liu


    Please remember to mark the reply as an answer if you find it is helpful. It will assist others who has similar issue. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, December 20, 2018 3:44 PM
  • Hi Calvin,

    Sorry for the late answer. The connection seems fine, the ExchangeAutodiscoverURL does exist and it ends with .svc .

    Thanks and best regards,

    Florian

    Tuesday, January 8, 2019 8:53 AM
  • did you ever find a solution ? I have the exact same issue on skype, photo is blurry while on exchange/ews all looks OK
    Sunday, March 22, 2020 4:18 PM