locked
Issue with enabling SSL RRS feed

  • Question

  • Hello,

    I've setup WSUS at one of my client and they want to enable SSL. I've followed a procedure to generate a domain certificate through the IIS within the WSUS server and our Certificate Authority.

    When I run the wsusutil.exe configuressl machine.domain.local command, it should show me the https://server:8531 url. But it shows me http://server:8530.

    Is there something I'm doing wrong ?

    Procedure i'm following is from this external link: http://jackstromberg.com/2013/11/enabling-ssl-on-windows-server-update-services-wsus/

    Best regards,

    Mike

    Thursday, November 1, 2018 1:09 PM

Answers

  • Hello,
     
    Select Required SSL in WSUS Administration SSL settings and then try the command again.
     
    If it return the correct result, then remove the check.
     
    Reference:
     
    https://social.technet.microsoft.com/Forums/en-US/63a799ff-e45a-4f3e-9619-64fdc0ede8d6/wsus-ssl-wsusutil-configuressl-command-returning-unexpected-output?forum=systemcenterupdates
     
    Hope my answer could help you and look forward to your feedback.
     
    Best Regards,
    Ray

    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Mike Dumont Friday, November 2, 2018 6:32 PM
    Friday, November 2, 2018 8:46 AM

All replies

  • Are you talking about the MMC? After enabling SSL through wsusutil.exe, you'll need to start the WSUS MMC and right click-remove the current server name. Then you can add a new one, and specify https/8531 and connect. It should work then.

    FYI, you should use the FQDN instead of just the hostname (best practices) - see part 4 of my 8 part blog series on How to Setup, Manage, and Maintain WSUS - https://www.ajtek.ca/wsus/how-to-setup-manage-and-maintain-wsus-part-4-creating-your-gpos-for-an-inheritance-setup/


    Adam Marshall, MCSE: Security
    https://www.ajtek.ca
    Microsoft MVP - Windows and Devices for IT

    Friday, November 2, 2018 3:27 AM
  • Hello,
     
    Select Required SSL in WSUS Administration SSL settings and then try the command again.
     
    If it return the correct result, then remove the check.
     
    Reference:
     
    https://social.technet.microsoft.com/Forums/en-US/63a799ff-e45a-4f3e-9619-64fdc0ede8d6/wsus-ssl-wsusutil-configuressl-command-returning-unexpected-output?forum=systemcenterupdates
     
    Hope my answer could help you and look forward to your feedback.
     
    Best Regards,
    Ray

    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Mike Dumont Friday, November 2, 2018 6:32 PM
    Friday, November 2, 2018 8:46 AM
  • Hello Ray,

    I knew I had to do something on these folder, but unfortunately forgot to check the require ssl for required folder !

    Now it works.

    Thanks for helping.

    best regards,

    Mike

    Friday, November 2, 2018 12:56 PM
  • Hello Adam,

    Thanks for replying. I was using the FQDN, it was the result of the command that showed me http://hostname:8530.

    I did what Ray suggested and now seems to be working as I get the https://FQDN:8531

    Best regards,

    Mike

    Friday, November 2, 2018 12:58 PM
  • Hello,

    Glad to hear it works.

    It would be helpful if you could mark the reply as answer, so it could help others who have same issue.

    Best Regards.

    Ray


    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 2, 2018 1:21 PM