WSUS on Server 2012 client not browse iuident.cab RRS feed

  • Question

  • I have installed WSUS on Server 2012 R2 that is activate the feature.

    The problem is that the clients and also the server itself cannot connect to \\wsusserver.domain:8530/iuident.cab
    In IIS on the server i right click the WSUS administration and choose manage - browse then nothing appears on that page.

    On the server in the browser give in: \\wsusserver:8530 then a IISpage appears with the version on it but when putting after this: /selfupdate or /iuident.cab 404 page not found appears..

    The cabinet files are present in c:\program files\updateservices\.....
    User rights for the folders are set to anonymous and everyone have rights.
    Strange thing is when i go in explorer to the folder .../sellfupdate/iuident.cab and look at the user rights then anonymous and everyone have no rights on the cabinet.. When i want to change the user rights for that cabinet file i cannot change that and also not when i make administrator the owner. This is also the fact when i change the above folder userrights and want to deploy it to all folders beneath that folder, then a error appears that access is denied although i am local and domain admin on the Windows Server 2012 R machine...

    I have changed nothing in the configuration in IIS done a standard installation with proxy configuration but local sites are not through proxy server...

    How can i solve this so that the cabinet files can be reached and that the updates on de the clients can be done thru the WSUS server?
    In WSUS console i can see several computers joined and several are in the not yet reported status.


    Friday, November 13, 2015 10:37 AM

All replies

  • Hi,

    >>The problem is that the clients and also the server itself cannot connect to \\wsusserver.domain:8530/iuident.cab

    I check it on my WSUS server, it seems that the iuident.cab file doesn't exist in the root directory.

    The path of this file is http://FQDN_of_WSUSServer:8530/Selfupdate/iuident.cab.

    Best Regards.

    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, November 17, 2015 3:21 AM
  • Hi,

    The file is there but the user rights to it can be the problem although i have changes the anonymous and everyone read & access rights. The files are blue colored but they are present.

    Firewall is not blocking it because the service is not running. A lot of machines are visible in WSUS however but non of them and also not on the server itself can display the cab files in the /selfupdate....


    Friday, November 20, 2015 1:57 PM
  • Strange this thing. The cabinet files on der Windows Server 2012 WSUS server cannot be seen by clients nor by the IIS onder server itself. The files are in blue in explorer maybe that is an issue?

    I browse to: http://wsusserver.domainname:8530/selfupdate/wuident.cab but still get a 404 error on the client. When browsing within IIS itself with the command: manage virtual - browse in the selfupdate virtual folder then nothing displays, a white empty page although the cabinet files are there...

    Given anonymouse and everyone read access to the cabinet files.

    Updated the server with all updates from Microsoft without luck.

    What can be the reason that i cannot browse to the cabinet files?

    When browsing to the iis administrator i can see the IIS page.


    Sunday, November 29, 2015 11:02 AM
  • Was there ever a resolution to this? I can access the CAB file on my server but the clients don't seem to pull any updates.  I am pretty new with server 2012 R2 though and not sure where to even look.
    Friday, January 15, 2016 5:49 PM
  • Phil, did *you* ever find a resolution? I'm in the same boat...
    Monday, September 12, 2016 3:59 PM
  • What worked for me:

    Open IIS Manager,

    Navigate to Sites/Default Web site

    Edit Bindings 

    change the default IIS Web site to port 8080 or something other than port 80

    Navigate to Sites/WSUS Administration

    Edit Bindings 

    change the HTTP port to port 80.

    Retstart IIS manager.

    Then check you can open http://<server name>/selfupdate/wuident.cab

    Tuesday, October 25, 2016 1:05 PM
  • Thank you very much this was driving me crazy!
    Thursday, December 1, 2016 5:06 PM
  • Duders, you saved me some hard work. This worked for me as well. Tyvm. 

    Thursday, May 23, 2019 12:56 PM
  • Editing bindings in IIS directly, while it works, is NOT the correct way to do this.

    You should use from an Admin PowerShell Prompt

    & "$env:ProgramFiles\Update Services\Tools\WsusUtil.exe" usecustomwebsite false

    This properly changes the ports back to 80, and changes the appropriate items in the registry and other locations too.

    Adam Marshall, MCSE: Security
    Microsoft MVP - Windows and Devices for IT

    Monday, May 27, 2019 2:06 PM
  • I ran into a similar issue having started using WSUS installed on a Windows Server 2019 system. I was finding that anything running on Windows 10 or later technology was having no problem picking up updates from WSUS. However, systems running older server OSes, like 2003, 2003 R2, 2008, 2008 R2, 2012, and 2012 R2, were unable to pick up anything from WSUS. Their WindowsUpdate.log file was reporting that the client was encountering an error while trying to retrieve the /selfupdate/wuident.cab.

    After testing the URL it showed from other computers, I confirmed it was kicking up a 404. As well, the 2019 server running WSUS definitely had the selfupdate materials on it. Since we were upgrading from WSUS on a 2008 R2 system, I still had it to compare to. What I discovered was that the WSUS Administration website on the 2019 server was missing a virtual directory that pointed to the SelfUpdate folder. After creating a virtual directory that pointed at it, the older servers were able to pick up updates.

    In our case, here's what I did:

    1. Started up the IIS Manager.
    2. Located the WSUS Administration site.
    3. Right-clicked on it and picked "Add Virtual Directory".
    4. In the Add Virtual Directory dialog that appeared, I set the "Alias" field to "SelfUpdate" and pointed the "Physical path" field at "C:\Program Files\Update Services\SelfUpdate".
    5. Clicked OK to finish creating the virtual directory.

    After that, the servers were able to get new updates.

    Friday, August 23, 2019 6:11 PM