locked
Parser error RRS feed

  • Question

  • Hi All,

    I'm having an issue with my web part. I got a parser error and can't find how to debug it.

    Here is the error i encounter.

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; MS-RTC LM 8; .NET4.0C)
    Timestamp: Fri, 21 Jan 2011 07:37:11 UTC


    Message: Sys.WebForms.PageRequestManagerParserErrorException: The message received from the server could not be parsed. Common causes for this error are when the response is modified by calls to Response.Write(), response filters, HttpModules, or server trace is enabled.
    Details: Error parsing near '<HTML dir="ltr">
    <H'.
    Line: 5
    Char: 62099
    Code: 0
    URI: https://www.sharepoint.com/ScriptResource.axd?d=-_hK0sn_wBhdCY1bs2fdCaXnsjYpfsrRvqceio2RmqUvbaEpD4PvIMUUArbyQbJ-TWmoGPE8MyDEobOzrD5dcDzIe5ko_0ifwWvz5W_SYSCPygKhK-dj1ZII1Dhb8mPFMWwkDeghJnSp-uviKBbOUQZCFmc1&t=1770089

    When i checked this in fiddler here is the output

    HTTP/1.1 200 OK
    Cache-Control: private
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=utf-8
    Server: Microsoft-IIS/6.0
    MicrosoftSharePointTeamServices: 12.0.0.6303
    x-href: ctcws5504
    X-Powered-By: ASP.NET
    Set-Cookie: ACNSESSION=AAAAAQABAGhgucbLsnQCUPF287qC3sFB9Gtm4Ixu5Rl0bTWo2xd0210XpK62xMBqMHj4RpsP0m7OKs%2F3Hdo5g85x%2FAw7R2MmVTr2LYPMqTUfRwyWEI%2BjKpqjnHe5xcmv1jVyIouql%2B7ZUUzVOVBCbw%3D%3D; secure; domain=.accenture.com; path=/; HttpOnly
    X-AspNet-Version: 2.0.50727
    SharePointError: 0
    Set-Cookie: WSS_KeepSessionAuthenticated=443; path=/
    Set-Cookie: MSOWebPartPage_AnonymousAccessCookie=443; expires=Fri, 21-Jan-2011 04:00:12 GMT; path=/
    Set-Cookie: ASP.NET_SessionId=ozkw0cjk2yuqbu45oxi1mbzu; path=/; HttpOnly
    Date: Fri, 21 Jan 2011 03:30:12 GMT
    Set-Cookie: BIGipServerKX.accenture.com=1978534410.47873.0000; expires=Fri, 21-Jan-2011 04:30:12 GMT; path=/

    19b5
    <HTML dir="ltr">
    <HEAD><meta name="GENERATOR" content="Microsoft SharePoint" /><meta name="progid" content="SharePoint.WebPartPage.Document" /><meta HTTP-EQUIV="Content-Type" content="text/html; charset=utf-8" /><meta HTTP-EQUIV="Expires" content="0" /><meta name="ROBOTS" content="NOHTMLINDEX" /><title>
     
     Error

    </title><link rel="stylesheet" type="text/css" href="/_layouts/1033/styles/core.css?rev=5msmprmeONfN6lJ3wtbAlA%3D%3D"/>
    <script type="text/javascript" language="javascript" src="/_layouts/1033/init.js?rev=yOq8IoAABYCtaZjMVrjxtg%3D%3D"></script>
    <script type="text/javascript" language="javascript" src="/_layouts/1033/core.js?rev=XtdKG9EwDUHSo03sNRdLzQ%3D%3D"></script>

     <meta name="Robots" content="NOINDEX " />
     <meta name="SharePointError" content=""/>
    </HEAD>

    Im thinking that the error is in BOLD letters above but can think of any ways to debug it.

    Hope you can help me with this.

    THanks a lot.


    ®©™½¼
    Friday, January 21, 2011 7:41 AM

All replies

  • Is it a custom web part? Can you remove it from the page and add it again?

    Use the [url]?contents=1 trick to remove the existing web part if you need to.

     

    Friday, January 21, 2011 9:52 AM
  • yes its a custom web part, i tried to remove and add it again but the parser error is still there,

    the error came out when i click a button in the custom web part


    ®©™½¼

    Monday, January 24, 2011 2:26 AM
  • Hi,

    If you are in development environment, you can debug it by attaching it to the w3p.exe process.

    You can find detail steps from the following document.

    http://msdn.microsoft.com/en-us/library/ff650703.aspx


    Microsoft Online Community Support
    Monday, January 24, 2011 3:49 AM
  • actually its kinda weird,. in my development environment, i cant see this error, but when deployed in production environment, the error occur

    the custom web part has 3 update panel and a dropdownlist, then when i click the button error came out

     

    any idea to look at?


    ®©™½¼
    Monday, January 24, 2011 3:56 AM
  • can somebody help me with this? thanks
    ®©™½¼
    Wednesday, February 23, 2011 10:14 AM
  • up up
    ®©™½¼
    Tuesday, March 29, 2011 2:44 AM