locked
RCDC Control Attribute Text Formatting RRS feed

  • General discussion

  • Does anyone know if it's possible to change the text color of a RCDC Control attribute's text and if so, how it's done?  For example, if I wanted to change the text of the Hint attribute to red? I've been searching through here and have yet to find anything that seems relevant so far. 

    Thanks!

    Friday, October 21, 2011 9:07 PM

All replies

  • you need to modify the CSS Stylesheet for FIM-SharePoint site, RCDC controls are using CSS classes for different visual behavior ...

    for hint property I think it's "ms-formdescription" CSS class, you can go the theme folder in SharePoint:

    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\TEMPLATE\THEMES\

    and make a new theme based on a copy of "FIM theme", please refer to this of how to create a new theme

    http://technet.microsoft.com/en-us/library/ee534913%28WS.10%29.aspx (search for FIM Portal Visual Theme Customization)

     

    then in your new custom theme you can do the following:

    .ms-formdescription
    {
        font-family: "Segoe UI", "Arial", "Verdana", "Sans-Serif", "Helvetica";
        font-size: 12px;
        color: Red;
        text-align: left;
    }

     


    It's never too late in life ... to start living



    Friday, October 21, 2011 10:03 PM
  • The IE developer tools makes easy work of figuring out which styles apply particular UI elements. The version included in IE9 is a real time saver. Maybe someone can post some cool looking portal designs..
    Frank C. Drewes III - Consultant: Certified Security Solutions - My blog: http://www.css-security.com/author/fdrewes
    Saturday, October 22, 2011 1:45 PM
  • Thanks Amer. I tried implementing this copying the FIM theme and then modifying the ms-formdescription to a new text color. When I try to pick the new theme from within the FIM Portal, I get an error back that reads "Unable to process your request". I tried doing the copy a second time to make sure I did everything correctly, but I still get the same error when trying to pick the new theme. Do you have any additional thoughts on what might be wrong? Thanks! Bryan
    Monday, October 24, 2011 8:01 PM
  • try to revise your steps, anyway you can try to turn off custom error in WSS and enable debug by modifying the sharepoint web.config

    <SafeMode MaxControls="200" CallStack="true" ...>

     

    <customErrors mode="Off" />

     

    <compilation batch="true" debug="true">


    It's never too late in life ... to start living
    Monday, October 24, 2011 8:13 PM
  • Hi Amer.  I ran through this a couple of times and I am fairly certain that the steps are good.  I still get the error.  I will try this and see what I get.

    THanks,

    Bryan

    Tuesday, October 25, 2011 3:04 PM