none
Turn off caching on the front end RRS feed

  • Question

  • Our web designer is working on some layout changes to one of our html pages located under SitePages.  There used to be an html page there and a .css stylesheet that controlled the layout of the html page.  She deleted that .css stylesheet a couple of days ago but the layout is still the same (as of that .css was still there).  She cleared her browser cache.  I deleted that .css from the first and second recycle bin so the .css file is definitely not there.  I've seen posts about how to clear Sharepoint cache on the server itself but I don't want to give access to the server to just any person that needs to make some html or css changes.  Is there any way to handle this from the front end, by users who don't have access to the server?  Or is there some configuration on SitePages or a folder that I can configure so that anything placed at that location is not cached at all?

    thanks,

    Thursday, February 6, 2014 3:37 PM

Answers

  • I think I figure it out.  The files were originally placed under "SitePages" which are wiki pages.  Once I moved them to "Pages" instead of "SitePages" then any change in the .css file or deleting the .css file had an immediate effect on the .html file which is what we wanted.  thanks

    Thursday, February 6, 2014 5:41 PM

All replies

  • Hi Bbatl,

    One of the best practice is to avoid javascript and css cache ,use url parameter yourScript.js?rev=1.0.0.0 so that browser will re-load new file every time.For more details refer this wonderful article 

    Avoiding bugs from cached JavaScript and CSS files in SharePoint


    Thanks

    Thursday, February 6, 2014 4:13 PM
  • Thanks but I'm not sure I understand how this applies to my case.  I don't have any .js files.  We used to have  a .html file that was referencing a style.css file.  Now, the web designer deleted the style.css file from Sharepoint but when we view the .html file it still shows the styling that was implemented in style.css.  What do I need to do to get the .html page to show up in the browser without these styles applied (since the .css file is gone).  Also, the link you provided discusses files placed in the _layouts folder.  Our webpage is directly under <url>/SitePages

    thanks,

    Thursday, February 6, 2014 5:30 PM
  • I think I figure it out.  The files were originally placed under "SitePages" which are wiki pages.  Once I moved them to "Pages" instead of "SitePages" then any change in the .css file or deleting the .css file had an immediate effect on the .html file which is what we wanted.  thanks

    Thursday, February 6, 2014 5:41 PM