locked
Windows Server 2012 Essentials R2 - Windows Server Essentials Connector Wizard fails - server not available RRS feed

  • Question

  • When attempting to run the Windows Server Essentials Connector Configuration Wizard, I am able to go thru the first few screens:

    1. Server is auto detected and I can select it on from the list (only 1 server present and found)

    2. Wizard connects and asks for user name and password.  I have tried to different accounts on the server (first is an admin account which it gives me a warning and I say yes I want to use the admin account, second is non-admin account).

    3. Wizard fails with error message "the server is not available. Try connecting this computer again...." (see image)  Server can be reached by IP address and name at this point, so it is available.

    I am trying to connect from a computer that was connected to a WHS V.1 server.  WHS V.1 connector software was uninstalled thru control panel, and then Serever 2012 connector was installed.

    In step 1 have have tried connecting by selecting the server name that is found, and also by typing the server address. Fails at same point no matter which I use.+

     

    Monday, October 21, 2013 6:01 PM

All replies

  • You might be experiencing the same issue I was. When I upgraded to Windows 8.1 I did not uninstall my connector, yet the connector software was unavailable in remove programs. I posted here and was told to look in Programs and Features > View Installed Updates. From there I searched for a Server Connector update. I found one, clicked on it and the connector was completely uninstalled. I did reboot the server, but I don't know if that was needed. I was then able to get past the screenshot you mentioned.
    Monday, October 21, 2013 6:50 PM
  • Just tried that, removed Server Connector update from Installed Updates, and re-installed the connector software and it did not fix the problem, still cannot connect to the server.
    Monday, October 21, 2013 7:11 PM
  • Did you ever get an answer to this? I am having the same issue.
    Sunday, February 9, 2014 5:18 PM
  • My response worked for me, but it didn't seem to help daneb1. Sorry. I'm not any more help.
    • Proposed as answer by SDail Friday, February 14, 2014 10:39 PM
    Sunday, February 9, 2014 8:42 PM
  • No, I have never been able to resolve this issue.  At some point will do a clean install and go from there.
    Wednesday, February 12, 2014 4:28 PM
  • My response worked for me, but it didn't seem to help daneb1. Sorry. I'm not any more help.

    Worked for me! I had connected my laptop to Server 2012 Essentials and then "upgraded" the server to Server 2012 R2 (with Essentials role.) I removed the laptop from the old domain and uninstalled the connector software but kept getting the above error until I removed the update as you described.

    Thanks!

    Friday, February 14, 2014 10:41 PM
  • I'm experiencing the same problem, only there is no "Server Connector" update to uninstall.
    Tuesday, July 28, 2015 5:07 AM
  • Tuesday, July 28, 2015 5:18 AM
  • I am having this same issue on two different servers I manage. I have gone through all the troubleshooting steps Microsoft provides and everything posted on this thread with no luck. I have tried to connect machines using both Windows 7 and 8.1 with the same result. I'm wondering if a bad update broke functionality? I can't even manually join computers to the domains through System Properties, it fails saying it can't find the domain.
    Wednesday, July 29, 2015 4:52 AM
  • Set dns on the client to the ip of the server

    Grey

    • Proposed as answer by Todd McDermid Wednesday, May 18, 2016 7:50 PM
    Saturday, August 1, 2015 10:56 PM
  • Please check the clientdeploy logs
    Tuesday, August 4, 2015 5:49 AM
  • Have this same problem: Wizard fails with error message "the server is not available".

    I've tried everything, anyone who had this problem had any luck fixing it??

    Server WSE 2012 R2, client Windows 10 Pro, upgraded from Win 7 Pro.

    Thursday, August 6, 2015 10:48 PM
  • for win 10 you need a new connector and set dns on the client to point to the server

    http://blogs.technet.com/b/sbs/archive/2015/07/23/client-connector-availability-with-windows-home-server-small-business-server-and-windows-server-essentials-for-supported-client-os.aspx

    The Client Connector for Windows 10 to connect to Windows Server 2012 R2 Essentials has been released. 

    For x64 bit Windows 10 Client download it from here.

    For x86 bit Windows 10 Client download it form here.


    Grey


    • Edited by Still Grey Friday, August 7, 2015 12:15 AM
    • Proposed as answer by Still Grey Sunday, August 9, 2015 1:06 PM
    Friday, August 7, 2015 12:15 AM
  • Thank you for the reply, I have tried installing that new x64 Windows client connector.

    I have not tried setting my DNS to the server's IP. This may be the step I'm missing.  Does that link describe this, I'm missing that part.

    So to be clear, I would manually change my client's DNS Server address - to "Use the following DNS Server Addresses" - "Prefered DNS" to the local, non-routable server's IP, in my case 192.168.0.100. What do I do about the Alternate DNS Server address?

    Will it be OK to leave the client's DHCP assigned IP address as is??

    Thank you!

    Saturday, August 8, 2015 7:11 AM
  • No you change the client (the one that can't find the server) dns to point to the server.  The connector install will actually do this for you, but if it never runs, it does not get there.

    And just to be sure cause I missed it, when you download/install the win 10 connector, you now have a new app connect to the server.  You do not install that then go server/connect like some of the beta versions of the connector


    Grey

    Saturday, August 8, 2015 11:25 AM
  • Thank you Grey, I really appreciate the help. Here is what I was doing and what happened, the step I'm not doing was resetting the client's (the one that cannot connect to the server) DNS to point to the static IP of my server.

    I run the connector (usually as admin).

    My Server is auto detected and I can select it on from the list (only 1 server present and found)

    The wizard connects to my server, then asks for client's user name and password. 

    Cursor changes to whirling blue circle for about 5+ minutes.

    Then I get error message "the server is not available. Try connecting this computer again...." (jujst like SS above in the OP) 

    I'm heading to my office later this morning, I'll circle back and let you (and anyone else googling this same problem) with my results. 

    Thank you again!  I'm a full time business owner only part time IT Director!  ;-)

    Saturday, August 8, 2015 12:49 PM
  • Try uninstalling any previous connector, it should in program and features or installed updates.

    Delete client deploy log and then reinstall the connector from connect website. if it fails again, please check or paste the error from the logs.

    Sunday, August 9, 2015 9:40 AM
  • Thank you guys, the DNS was the trick, I had tried everything else.

    Here is what I did. 

    On the stubborn client, I left the IP assigned automatically (it gets that as DHCP from my router), under the DNS I set that manually, and made the primary DNS the Server's IP.  I left the secondary DNS blank. Those steps made the install work properly.

    Now that it is working, what should I permanently set the client's DNS's to?

    Should I leave the primary DNS as the server IP, and perhaps add the router's IP as the secondary DNS?

    Many thanks!

    Sunday, August 9, 2015 10:34 AM
  • for giggles, set the primary dns to the router on the stubborn client and reboot.  And or look at your other clients.  They should all have primary pointed to the server.  The connector does that for you.

    Grey

    Sunday, August 9, 2015 1:06 PM
  • Hello,

    I read carefully this thread because I have a problem since I upgraded my first PC to Windows 10.

    This PC is joined to a domain and the connector worked perfectly under Windows 8. After the upgrade to W10, I uninstaled the old connector, installed the connector for W10 and started the wizard:

    My Server is auto-detected and I can select it on from the list (only 1 server present and found). But the wizard couldn't connect to the server: server not available, contact administrator (translated from French).

    In the log file, I found this:

    ...

    [7120] 150824.072434.0500: ClientSetup: The selected server name is SAN-FAMILIAL
    [7120] 150824.072434.0500: ClientSetup: The server info: SAN-FAMILIAL, System.Collections.Generic.List`1[System.Net.IPAddress]
    [2704] 150824.072434.0969: ClientSetup: Entering ConnectorWizardForm.RunTasks
    [2704] 150824.072434.0969: ClientSetup: Running Task with Id=ClientDeploy.PreConfiguration
    [2704] 150824.072434.1125: ClientSetup: The configuration cab will be downloaded from 192.168.1.2
    [2704] 150824.072434.1282: ClientSetup: Download file Setup.cab from server
    [2704] 150824.072434.1438: ClientSetup: Making web request: https://192.168.1.2//connect/default.aspx?Get=Setup.cab&LanguageId=1036&64bit=1

    [2704] 150824.072434.2532: ClientSetup: Failed to download Setup.cab from server: System.Net.WebException: La connexion sous-jacente a été fermée : Impossible d'établir une relation de confiance pour le canal sécurisé SSL/TLS. ---> System.Security.Authentication.AuthenticationException: Le certificat distant n'est pas valide selon la procédure de validation.

    ...

    I even tried an old procedure to install the connector without joining the domain.

    I verified that my PC is connected to the domain (Familialecb.local) and that I can access the server from this PC via RDP

    Any help?

    Christophe



    • Edited by C3B12 Monday, August 24, 2015 10:16 AM
    Monday, August 24, 2015 10:11 AM
  • Setting DNS to point to server did the trick.

    Thanks a lot.

    Monday, August 24, 2015 12:24 PM
  • Thank you.

    It did not for me.

    I already changed, as said in the thread, the ipv4 network parameters as follows (network and share -> change adapter settings...) and used the following DNS server addresses:

    - Preferred DNS server: 192.168.1.2 (my server address)

    - Alternate DNS server: 192.168.1.1 (my router address)

    I have the same issue as above so it didn't work.

    The wizard actually detected the server name (SAN-FAMILIAL) and its IP address (192.168.1.2) but failed to connect due to some security issue (SSL/TLS secure channel---> System.Security.Authentication.AuthenticationException)


    • Edited by C3B12 Monday, August 24, 2015 1:42 PM
    Monday, August 24, 2015 1:32 PM
  • Thank you forr this very usefull link.

    I did the Test 2: Test CA infrastructure (other tests passed). there is indeed a problem with CA Online:

    Testing CA Name..

    Certificate Authority Online  : Error

    Certificate Authority Name    : OK

    Certificate Authority Cert    : OK

    Testing /Connect Certificate Package..

    Connect Computer Certificate  : OK

    Testing CRL Download..

    CRL Location                  : http://SAN-FAMILIAL/CertEnroll/FAMILIALECB-SAN-FAMILIAL-CA.crl

    CRL Destination               : c:\windows\temp\crl.crl

    Exception lors de l'appel de «DownloadFile» avec «2» argument(s): «Le serveur distant a retourné une erreur: (403)

    Interdit.»

    Au caractère F:\ServerFolders\SI Familial\SAN-Familial

    2009-2014\Programmes\Scripts\Robert_Pearlman_EssentialsTester.ps1:1060 : 9

    +         $wc.DownloadFile($source,$destination)

    +         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

        + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException

        + FullyQualifiedErrorId : WebException

    CRL Download                  : Failed

    Testing CRL Distribution Configuration..

    437.625.0:<2015/8/25, 8:36:29>: 0x80070002 (WIN32: 2 ERROR_FILE_NOT_FOUND): CADescription

    419.6336.0:<2015/8/25, 8:36:29>: 0x80070002 (WIN32: 2 ERROR_FILE_NOT_FOUND)

    437.2132.0:<2015/8/25, 8:36:29>: 0x80070002 (WIN32: 2 ERROR_FILE_NOT_FOUND)

    437.625.0:<2015/8/25, 8:36:29>: 0x80070002 (WIN32: 2 ERROR_FILE_NOT_FOUND): ParentCAName

    It is normal to see some 'File Not Found' messages above when using this CmdLet (Get-CACrlDistributionPoint)

    CRL Extension (CDP)           : OK

    CRL Extension (CRL)           : OK

    Testing Dashboard Certificate..

    Dashboard Certificate         : OK

    Review your results, items in red should be investigated.

    What should I do? I fear making a fatal mistake manipulating CA parameters

    Christophe

    Tuesday, August 25, 2015 12:07 PM
  • on the server can you click start

    type \\SAN-FAMILIAL  enter

    See the CertEnroll share and open it and see the cert?


    Grey

    Tuesday, August 25, 2015 12:48 PM
  • Yes I can see it in the folder \\SAN-FAMILIAL\CertEnroll\: FAMILIALECB-SAN-FAMILIAL-CA.crl

    I also did the http test in a browser from a connected PC  going to:

    http://SAN-FAMILIAL/CertEnroll/FAMILIALECB-SAN-FAMILIAL-CA.crl

    Then I have the 403 error (is it the cause of my issue?)

    But when I write https://SAN-FAMILIAL/CertEnroll/FAMILIALECB-SAN-FAMILIAL-CA.crl, I can reach the certificate (asking me if I want to open it or saving it).

    I remember that I changed a parameter in the IIS manager due to a BPA recommandation (SSL parameter: require SSL / Client certificate: ignore)


    • Edited by C3B12 Tuesday, August 25, 2015 4:16 PM
    Tuesday, August 25, 2015 4:16 PM
  • The log file you posted above with the failed https cab request is normal. Mine all have the same error. Farther down you should see it download http

    But the cert download is http.  I would undo the changes you made for the BPA and give it a go


    Grey

    • Proposed as answer by C3B12 Thursday, September 3, 2015 6:08 AM
    Tuesday, August 25, 2015 4:44 PM
  • Thank you for your advice: it did the trick finally.

    I unchecked "require SSL" in the SSL parameter of the IIS manager et voila!

    NB: I also set the SkipDomainJoin hook in the registry before lauching the wizard because my PC already joined the domain when it was Under W8.

    Many thanks

    Christophe

    Tuesday, August 25, 2015 8:28 PM
  • Thanks for the update !

    Happy trails :)


    Grey

    Tuesday, August 25, 2015 8:32 PM
  • Hard to believe that even after two years, Microsoft still doesn't have an answer as to how to connect a Windows 10 Enterprise server to a Windows Business Essentials 2012 R2 server.

    R, J

    Friday, September 23, 2016 2:25 PM
  • I was having the same problem with Windows 10 Pro and Server 2016 Essentials.

    I couldn't get the connector software to install on windows 10 Pro connecting to Server 2016.  Kept giving me 'server not available' after entering the credentials.  I used the essentials tester Powershell program and the only thing is error was TLS1.0.  Been trying to get the connector to work for months.  I had changed my IIS settings to only use TLS1.2, but it seems the connector only works with TLS1.0 (I know.. right?).  I had to disable TLS1.2 and TLS1.1 and enable TLS1.0 in IIS registry to get connector to install.

    Hope this helps others out there.

    Wednesday, August 23, 2017 7:06 PM
  • I know this is a really old thread, but I keep crashing into this issue every time I try to add a new PC onto the network. I thought I'd post my solution in case it helps some:

    On the network connection of the client PC, specify a static IP with the DNS & gateway pointing to teh server IP.

    Disable IPv6 on the network connector.

    Doing both of these works every time for me - I can run through the connector then set everything back to auto (and re-enable IPv6) once done.

    Hope this helps someone!

    • Proposed as answer by Genshi-V Wednesday, October 4, 2017 9:54 PM
    Tuesday, September 26, 2017 7:31 PM
  • I know this is a really old thread, but I keep crashing into this issue every time I try to add a new PC onto the network. I thought I'd post my solution in case it helps some:

    On the network connection of the client PC, specify a static IP with the DNS & gateway pointing to teh server IP.

    Disable IPv6 on the network connector.

    Doing both of these works every time for me - I can run through the connector then set everything back to auto (and re-enable IPv6) once done.

    Hope this helps someone!

    This is exactly what I found as well. If you're NOT setup on your domain to use IPv6 for internal use, you will run into this issue every time you try to attach a Windows 10 pc to the domain. It will throw a "The Server is not available" error if you use the connector. If you try to use the powershell command add-computer -domain -credentials it will throw a similar "cannot find target" error. 

    The disabling of IPv6 was the only thing I found that would make it work. And like pebrey1, I could enable it after joining the domain and everything worked fine. 
    Wednesday, October 4, 2017 9:53 PM
  • I know this is really old, but I did find the solution here after I found the solution.  Meaning, I read one reply stating to undo the BPA changes someone had made and I recalled recently making some BPA suggested changes.  Specifically the one that tells you to secure your RPC site by checking the Require SSL box.  I'm really annoyed that these BPA suggestions/warnings keep coming up and when I really dig into them find that they are bogus or like this one end up finding out it's crippling my server.  I never had these issues with WHS.  I think I will just be completely ignoring the BPA findings going forward, as they seem to all end up doing more harm than good.  If it ain't broke...
    Thursday, April 16, 2020 12:01 AM