locked
Change StaticDomainControllers in Exchange 2010 without using EMC nor EMS RRS feed

  • Question

  • Hello experts,

    I have used this command to change default DC used by Exchange:

    SetExchangeServer -StaticDomainControllers "NewDC.ourdomain.com"
    SetExchangeServer -StaticGlobalCatalogs "NewDC.ourdomain.com"

    Unfortunately after doing that, neither EMC nor EMS are able to open.

    Any urgent help please? How to change those two settings back to their null default value? 

    Saturday, June 11, 2011 7:28 PM

Answers

  • Are the Exchange services started, and have you checked your event logs?


    [string](0..33|%{[char][int](46+("686552495351636652556262185355647068516270555358646562655775 0645570").substring(($_*2),2))})-replace " "
    • Marked as answer by Haythamk Sunday, June 12, 2011 2:49 AM
    Sunday, June 12, 2011 2:28 AM
  • Thank you ! Yes, I found many errors in applicaion log. The problem was that IPv6 disabled. I don't know why it should be enabled for Exchange 2010 while it's not used in the organization.

    • Marked as answer by Haythamk Sunday, June 12, 2011 2:49 AM
    Sunday, June 12, 2011 2:48 AM

All replies

  • hi,

    you can remove static domain controller configuration with this command;

    Set-ExchangeServer "ExchangeServerName" -StaticDomainControllers $Null -StaticGlobalCatalogs $Null
    regards,

    Mumin CICEK | www.cozumpark.com | Please click Vote As Helpful if it is helpful for you and Propose as Answer!!!
    Saturday, June 11, 2011 7:43 PM
  • Again: I cannot connect to neither EMC nor EMS. That's why I am posting here.
    Sunday, June 12, 2011 2:15 AM
  • Are the Exchange services started, and have you checked your event logs?


    [string](0..33|%{[char][int](46+("686552495351636652556262185355647068516270555358646562655775 0645570").substring(($_*2),2))})-replace " "
    • Marked as answer by Haythamk Sunday, June 12, 2011 2:49 AM
    Sunday, June 12, 2011 2:28 AM
  • Thank you ! Yes, I found many errors in applicaion log. The problem was that IPv6 disabled. I don't know why it should be enabled for Exchange 2010 while it's not used in the organization.

    • Marked as answer by Haythamk Sunday, June 12, 2011 2:49 AM
    Sunday, June 12, 2011 2:48 AM
  • I have the same problem, no access to EMC and EMS.

    How have you solved the problem?

    Wednesday, October 29, 2014 1:15 AM
  • Sorry for diggin this up

    My exchange 2010 went beserk when setting GC in powershell

    IPv6 is enabled, still no access no EMC and EMS

    Help needed!!!

    Wednesday, November 29, 2017 12:29 PM