none
Tape not filling up RRS feed

  • Question

  • I'm having a bit of an issue wiht my DPM 2007 backups.   I've got a pretty simple setup.  I've got a single backup server with DPM 2007 running on Windows 2008 32bit OS.   I've got a HP LTO Ultrium SCSI tape drive connected to my backup server.  I've made sure I have the latest drivers for this tape device

    I've got only one protection group on my backup server.  In the protection group settings, I am backing up my office data server to disk (short-term-protection) and to Tape (long term protection).   The backup  to disk is working fine, but the backup to tape isn't using the full capacity of my LTO 2 tapes.   I'm supposed to get 200GB uncompressed / 400 compressed.  I've setup the job to compress the data; however, I'm only able to get around 115 GB per tape.  Not even the native 200GB!!   I have 850Gb of data to backup, so that would be a bunch of LTO 2 tapes.

    I've started out with new tapes, but have tried this several times without success.  Each time I go back into the Management | Libraries area an mark tape as free before I try running the job again.

    I've done some technet searches, but have yet to find how to fix this.  I've got colocation enabled per another article I read but it didn't help

    I'm pretty new to DPM software, so there may be something I'm missing.  Any help would be greatly appreciated!!

     

    Terry

    Network Admin

    Thursday, August 4, 2011 7:50 PM

Answers

All replies

  • Hi,

    please refer to the HP tech support recommendation - this has fixed other dpm users experiencing the same issue:

    http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=110&prodSeriesId=254838&prodTypeId=12169&prodSeriesId=254838&objectID=c01655150

     


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, August 5, 2011 4:17 AM
    Moderator
  • Mike

    Thanks for your reply.  I don't think this is the issue because my backups are running and not erroring out, it's just that there not using hte full capacity of the 200 / 400GB tapes.

    Through a web search, I found this info before regarding a registry tweak that sets the tape size.  The number I had in this was too low; however, I don't know yet if this was the cause.  I've made the registry tweak and am in the process of running another job now.  I'll know in a few hours if this was the fix.   Do you have any thoughts about this registry setting? 

    If you had a 400GB tape the registry entry should look like this
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection
    Manager\Agent]
    "TapeSize"=dword:00399000

     

    Thanks for yoru help Mike!

     

    Terry

    Friday, August 5, 2011 8:09 PM
  • Hi,

    DPM processes an IO error as an end of media, and just graps another tape, so you most likely won't see a failure. 

    To see if you are getting IO errors under the covers, open a command prompt and navigate to the c:\program files\microsoft dpm\dpm\temp folder, then run:

        Find "0x8007045D" msdpm*.errlog

    If you find any, the try adding the original registry setting I gave you and also this one to the registry:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent]
    "BufferQueueSize"=dword:00000002


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, August 5, 2011 8:51 PM
    Moderator
  • Mike,

     

    None of these things have worked.  Do you have any other suggestions?  Could really use some assistance on this. 

     

    Thanks,

     

    terry Brewer

    Thursday, August 11, 2011 7:39 PM
  • Hi,

    What was the result of:    Find "0x8007045D" msdpm*.errlog

    The other possibility is that the tape drive itself is reporting END_OF_TAPE_REACHED before it's actually full.  Not real sure how to troubleshoot that but you can download the DPMEracetape.Zip file from the below link, then use mct.exe and mytape.exe to mount a tape, and write to fill the tape and see what the last block number is that we write to.  If you run it multiple times and get different results each time, then that's the problem.

    http://cid-b03306b628ab886f.office.live.com/self.aspx/.Public/DPMeraseTape.zip?wa=wsignin1.0&sa=801749705#resId/B03306B628AB886F!822

    The utilities are not that user friendly, but here are the basics.

    Always Stop DPMLA Service prior to running MCT.EXE Commands.

      NET STOP DPMLA


    For MCT utility we have the  -m [MOVE] command to move media around inside the library.

     -m [ElemType-T] Transport# [ElemType-Source] S_lot#/D_rive# [ElemType-Destination] S_lot#/D_rive#

    Get / view command syntax for –m (move) command for changer 0

    C:\tools\mct>mct-x64 0 -m

    Opening changer \\.\Changer0
    MoveMedium : mct -m t N s\d N s\d N  [Where s/d means Slot or Drive and N is ZERO based].

     

    Some Examples:

    mct-x64 1 -m t 0 s 0 d 0    (Using transport-0, move media from slot-0  to drive-0)
    mct-x64 1 -m t 0 d 0 s 0    (Using transport-0, move media from drive-0 to slot-0)
    mct-x64 1 -m t 0 s 0 s 100  (Using transport-0, move media from slot-0  to slot-100)
    mct-x64 1 -m t 0 d 0 d 1    (Using transport-0, move media from drive-0 to drive-1)
    mct-x64 1 -m t 0 s 0 ie 0   (Using transport-0, move media from slot-0  to IEPort 0)

     

    Once you move a tape into a slot, use mytape.exe commands Loadtape, taperewind, locktape, Disable hardware compression, Set block size to 65536 (64K).

    You need the symbolic name for the tape drive you loaded media into - look in the DPM console by clicking the tape drive and look at the details for \\.\tape########.  use that in the following command.

     

    Mytape.exe \\.\Tape2147483638

    Status: Getting the handle for \\.\Tape2147483638...Success

    \\.\Tape2147483638>TapeConsole_1.0>loadtape

    Status: Loading the tape...Success

    \\.\Tape2147483638>TapeConsole_1.0>taperewind

    Status: Rewinding Tape ...Success

    \\.\Tape2147483638>TapeConsole_1.0>locktape

    Status: Locking the tape...Success

    \\.\Tape2147483638>TapeConsole_1.0>setdriveinfo

    Hardware error correction  [y]-Enable / [n] Disable : y
    Hardware data compression  [y]-Enable / [n] Disable : N  (BE SURE TO DISABLE)
    Data padding  [y]-Enable / [n] Disable : n
    Setmark reporting   [y]-Enable / [n] Disable : n
    Number of bytes between the end-of-tape warning and the physical end of the tape: 0
    Status: Setting Drive Information...Success


    \\.\Tape2147483638>TapeConsole_1.0>settapeinfo 65536

    Enter BlockSize: Status: Setting Tape Information...Success

    \\.\Tape2147483638>TapeConsole_1.0>writeforspanning

    Status: Writing onto tape...Failed !!!
    Error_ID reported: 1100                 (net helpmsg 1100 = The physical end of the tape has been reached.
    Number of bytes written: 983040     (Ignore bytes written, we'll get physical tape position later)
    Giving up
    Time taken: 15788ms


    \\.\Tape2147483638>TapeConsole_1.0>gettapeposition

    Status: Getting Tape Position...Success
    ------------------------------------------------------------------
                          Tape Position
    ------------------------------------------------------------------
    Absolute Position:
    Current tape partition: 0
    Current tape position: 0,32015    (Note these numbers, they should not change much between tests, but multiply by 65536 to get total bytes written)
    Current tape partition: 0
    Current tape position: 0,32015

    \\.\Tape2147483638>TapeConsole_1.0>taperewind

    Status: Rewinding Tape ...Success

    Then repeat the writeforspanning and gettapeposition commands to see how much variance you get.


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, August 11, 2011 10:36 PM
    Moderator
  • housekeeping - closing old post.  Open a new post if you still have a need.



    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, November 24, 2011 3:10 PM
    Moderator