locked
Forefront won't run, "service not registered" error RRS feed

  • Question

  • There is a PC at my office, that when logging in, complains that the Forefront service is not registered.  In looking at the list of services, and comparing it to another PC that is working, the "Microsoft Forefront Client Security Antimalware Service" is missing from the list of services.  I know that Forefront was working previously on this PC, in looking through event logs, it seems around 11/4, it started giving errors when attempting to update the Antimalware definitions.

    I've tried to uninstall Forefront from this PC, to allow it to be re-installed by the Group Policy, the uninstall failed, and reported a "fatal error."

    I would like to try to avoid a format and re-install of this PC, if at all possible.

    Thank you,
    Jason A
    Tuesday, November 10, 2009 8:48 PM

Answers

All replies

  • Hi,

     

    Thank you for the post.

     

    Please use Windows Installer CleanUp Utility to uninstall the FCS and then re-install it.

    http://support.microsoft.com/kb/290301

     

    Regards,


    Nick Gu - MSFT
    • Marked as answer by Jason A_ Thursday, November 12, 2009 2:03 PM
    Wednesday, November 11, 2009 5:42 AM
  • Thank you, this helped do the trick.

    If anyone else runs into a similar problem, I had to run the Installer CleanUp Utility above, then also uninstall the ForeFront Security State Assement and Operations Manager components.  Then I had to delete the \program files\microsoft forefront\ folder, in order to get it to re-install properly.

    A good bit of work, and several reboots, but far less painful than having to reload a client PC...

    Thank you,
    Jason
    Thursday, November 12, 2009 2:05 PM