locked
Event 106 - MSExchange Common - Performance counter updating error RRS feed

  • Question

  • Our Exchange 2010 Mailbox server is getting some Event 106, Source = MSExchange Common, errors. They are all related to a performance counter category that after looking at Perfmon, doesn't exist on the server.

    The errors look something like this

    Performance counter updating error. Counter name is Base for Average Number of Mailboxes Processed per Request, category name is MSExchange Availability Service. Optional code: 1. Exception: The exception thrown is : System.InvalidOperationException: The requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly.

    Can I safely ignore these errors or should I try and create the counter category?


    Orange County District Attorney

    Friday, October 31, 2014 3:49 PM

All replies

  • It appears this error isn't uncommon - I found several threads that were based on it.  Here's a link to one with a good solution:  https://social.technet.microsoft.com/Forums/office/en-US/eb15c6ad-216f-4a70-a78a-1d09bf82c0db/eventid-106-performance-counter-updating-error
    Friday, October 31, 2014 5:35 PM
  • Thanks for the link Willard. Looks like it may be time to rebuild the counters on that server.

    Orange County District Attorney

    Friday, October 31, 2014 5:54 PM
  • Hello,

    This issue can be occurred due to missing registry key. Please compare the followings with another working Server:

    SYSTEM\CurrentControlSet\Services\ MSExchange availability service\Performance

    If any keys or values are missing, you can backup and export the keys from the good machine.

    Then unload/Reload of Exchange counters via Exchange Management Shell:

    How to unload/reload performance counters on Exchange 2010

    http://blogs.technet.com/b/mikelag/archive/2010/09/10/how-to-unload-reload-performance-counters-on-exchange-2010.aspx

    Thanks,

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Simon Wu
    TechNet Community Support

    Tuesday, November 4, 2014 8:42 AM
    Moderator
  • Thanks for the note back, Simon. I found the counters on one other Exchange server. I imported them into the server with the errors and then followed the instruction in the link to reload the counters. After doing that I saw a message in the Application log

    Performance counters for the ESE (ESE) service are already in the registry, no need to reinstall. This only happens when you install the same counter twice. The second time install will generate this event.

    I opened Perfmon but they're not in there. I can see the registry entries that I imported but they're just not in Perfmon.


    Orange County District Attorney

    Tuesday, November 4, 2014 11:05 PM