none
FIM export stopped-server error for SSPR RRS feed

  • General discussion

  • Hi folks,

    I am facing some problems for FIM Export. When I ran a delta sync, in the Sycn Service Manager, I got Status "Stopped-Server". It worked before for a few months and all of sudden, it stopped working. It used to take about 2 min to finish successfully, now it takes about 20 min to show this error. The export statistics shows all 0 for all the fields.

    In the system Application log, I got this "The management agent "FIM Service MA" failed on run profile "FIM Export" because the server encountered errors."

    In the FIM event log, I got this:

    Log Name:      Forefront Identity Manager Management Agent
    Source:        ForefrontIdentityManager.ManagementAgent
    Event ID:      3
    Task Category: None
    Level:         Error
    Computer:      FIMSyncSrv.domain.local

    Description:
    System.InvalidOperationException: The export session has timed out waiting for responses.  

    That amount of time can be configured using the exportActivityTimeoutInSeconds attribute of the resourceSynchronizationClient element within the Forefront Identity Management Synchronization Service application configuration file.  The default duration is 600 seconds.  If the volume of requests is very high, then using that attribute to increase the duration would be advisable. 

    However, one should investigate why no responses to export requests have been received within the default amount of time.  Requests created on behalf of the Forefront Identity Manager Synchronization Service should be investigated to determine whether they are taking an unexpectedly long time to process. 

    I have checked that both FIM Service server and Sync server are running on the same version of FIM binary. No hotfix or update was installed on either FIM boxes when the problem started to happen. I never manually touched sync service application config file before so I don't really I corrupted it. Both servers have been rebooted multiple times and I also manually bounced both FIM Service and Sync service multiple times with the same error.

    I dont know where to look at this point. Is there a log to trace it or how to continue troubleshooting?

    Thanks,

    Thursday, June 6, 2013 8:56 PM

All replies

  • Was there ever a solution for this?


    Carlos O. Butts

    Monday, July 1, 2013 5:29 PM
  • This is a known issue with certain patchlevels of FIM. If you run the FIM MA with a different account than what runs the FIM sync service you have to give the account running FIM sync service the SQL permissions.

    In SQL security, add login for FIMSynchronizationServiceAccount (the account
    running the synchronization service), give it ‘FIM_SynchronizationService’
    permissions on the FIMServiceDB

    Regards

    Patrik

    Wednesday, July 24, 2013 6:55 PM
  • Sorry for the late response folks.

    I finally open a ticket with MS tech support and here is the article with solution:

    http://social.technet.microsoft.com/wiki/contents/articles/11331.troubleshooting-fim-r2-stopped-server-error-on-the-fim-service-management-agent.aspx

    The steps that fixed issues are:

    • Restart the Forefront Identity Manager Synchronization Service
    • Stop the Forefront Identity Manager Service
    • Run the Sync.ClearExport stored procedure

       Note
      You need to run the stored procedure on the SQL server hosting the Forefront Identity Manager Service database. To run the stored procedure, you need Execute permissions.

    • Start the Forefront Identity Manager Service

    Thanks,

    Wednesday, July 24, 2013 7:05 PM