none
RDS VDI Personal Pool is corrupted and unable to start from RD Gateway if shutdown RRS feed

  • Question

  • I can duplicate this error, but haven't yet found the reason why this happening and more importantly how to avoid/fix it.

    Servers are 2012R2 Datacenter and VDI VM's are Windows 8.  All are domain joined.

    1-Hyper-V Host

    -Runs Hyper-V and Hyper-V Virtualization Host

    1- VM Domain Controller

    -Runs DHCP, AD, DNS, and RD Licensing

    1- VM Connection Broker for VDI

    -Runs RD Web, RD Gateway, and RD Connection Broker

    5- Windows 8 Personal VDI's running on Host

    All looks great and runs great.  I can assign the VM's to the user that I want, and connect internally and through the RD Gateway. If the user selects "Disconnect" then all remains fine.   The problem comes in when the user "Signs Out" of the VM, or if the VM is run from the Host (to apply patches etc...) and is then "Shut Down."

    Once this happens, and you try to connect internally or externally to the particular VM, the following message is given:

    "This computer can't connect to the remote computer.  Try connecting again.  If the problem continues, contact the owner of the remote computer or your network administrator."

    

    I can assign this user to another desktop that hasn't yet suffered the same fate.  Of course, we then have to setup what wasn't included in the Master VM image.

    Here's what I know:

    I can log into any of these "corrupted" VM's without any trouble from the Host directly.  Running System Maintenance, and restarting hasn't helped.

    I do get info in the Event Viewer but searches for these errors hasn't turned up much of anything.

    On the Connection Broker, in the Microsoft-Windows-TerminalServices-SessionBroker/Operational log, I get:

    TerminalServices-SessionBroker

    Event ID 2057

    Failed to cleanup VM 85559E57-DA57-4723-BB18-8FE883B421BF on host HV1.kdb.local. Error: The RPC server is unavailable. 

    On the Connection Broker, in the Microsoft-Windows-TerminalServices-SessionBroker/Admin log, I get:

    Event ID 802

    RD Connection Broker failed to process the connection request for user KDB\khobbs. 
    Error: The RPC server is unavailable. 

    On the Hyper-V Host, in the Microsoft-Windows-TerminalServices-TSV-VmHostAgent/Admin log, I get:

    Event ID 4878

    Remote Desktop Virtualization Host could not orchestrate the virtual machine with the GUID of BB65335C-CE88-4A9D-856E-C114881A8AB8.

    Virtual machine GUID: BB65335C-CE88-4A9D-856E-C114881A8AB8
    Hresult: 0x800700AA

    On the Hyper-V Host, in the Microsoft-Windows-TerminalServices-TSV-VmHostAgent/Operational log, I get:

    Event ID 8964

    Remote Desktop Virtualization Host failed to process the orchestration request because virtual desktop [Standard-1] is busy processing cleanup from previous logoff event.

    As I stated earlier, I can duplicate this issue because after my first go around with this, I realized the VM was the issue ONLY after completely rebuilding the Connection Broker and the Windows 8 VM's from scratch.  My first login to one of the VDI's worked and I of course thought something was funky with the Connection Broker.  It wasn't until I updated the VM for the user from the Host, and then "Shut Down" the VDI VM that I realized the problem was back.  Putting the User to the next VM in line did the trick.  To make sure I wasn't going crazy, I logged into the VM as the user, and "disconnected/reconnected" without trouble, but "Signing Out" or Shutting down seems to be the kiss of death.

    I don't doubt that I'm an idiot, so feel free to point out the obvious....I don't care as long as I can fix/prevent this.

    Thanks in advance.

    Sunday, April 27, 2014 10:58 PM

All replies

  • I assume from your descriptions that these are private VMs, and not a pooled collection?  Have you looked at any strangeness in the Virtual Switches?

    I had something very similar happen - I sincerely hope that I don't fall into the same trap.  I have single 2012 R2 server with Hyper-V all RDS roles, and a DC running 2012R2 with the usual roles.

    I noticed on our Hyper-V/RDS host, one of the NICs picked up a DHCP address.  The odd thing, was that that NIC was associated with a Virtual Switch (non management), so it shouldn't have been able to do that (when it's assigned to a virtual switch, the ability to configure IPv4 usually goes away, so I don't know how this happened).  I had to blow away all the Virtual switches, and recreate them (I used 3 NICs and NIC teaming in 2012R2 this time for all the VMs, and one for Hyper-V management), and then tried to check out the RDS collection - it complained that the broker was gone.  It seems like the Broker had associated itself with the old Virtual Switch with the weird DHCP address.

    So, I uninstalled, reinstalled the broker, which made the collections disappear.  So I went and manually deleted all the VMs, removed them out of AD/DNS (thank god the template was still there), and recreated the RDS setup, and recreated the collections with the same names and using the same template, and was able to get back in again.  I REALLY hope that the VDI VM's are good for more than one login before they check out since I"m on call this weekend ;-/.

    Did you ever find a solution for your issue (I realize your post was in April, but I'm casting around to find out what happened in my situation, and found this).

    Friday, June 20, 2014 3:42 PM