none
How the firewall should be configured to allow quantmod.getQuote() access internet in SQL Server R services? RRS feed

  • Question

  • Hi Pros,

    I got an error below while calling package "quantmode"'s function getQuote() in sp_execute_external_script.  However, it works fine if I turned off windows firewall.    

    ================================================================

     This message is shown once per session and may be disabled by setting 
     options("getSymbols.warning4.0"=FALSE). See ?getSymbols for more details.
    Error in download.file(paste(google.URL, "q=", Symbols.name, "&startdate=",  : 
      cannot open URL 'http://finance.google.com/finance/historical?q=MSFT&startdate=Jul+05,+2007&enddate=Jul+05,+2017&output=csv'
    Msg 39019, Level 16, State 1, Line 587

    ================================================================

    Does anyone know how I should configure the firewall to allow such R packages' functions to get data from Internet?

    Thank you for your answer in advance.  

    Best,

    Kelvin

    Wednesday, July 5, 2017 1:53 PM

All replies

  • You'll need to turn off the Windows Firewall outbound rule "Block network access for R local user accounts in SQL Server instance MSSQLSERVER".

    See the section "Remote compute contexts blocked by firewall in SQL Server instances running on Azure virtual machines" on the page https://docs.microsoft.com/en-us/sql/advanced-analytics/known-issues-for-sql-server-machine-learning-services

    Bob

    Thursday, July 6, 2017 11:07 PM
  • Problem solved.  

    Thanks Bob.  

    Saturday, July 8, 2017 8:27 AM