locked
How to block certain users from folders i.e. EditForm.aspx, Upload.aspx?List=%... RRS feed

  • Question

  • I am barely learning how to use SharePoint so I am sorry if I do not use the correct terminology, as of now I am only familiar with SharePoint Designer 2007 and my company uses WSS not MOSS.

    I need to develop a website using SP for customers. Different customers will be able to see different files.  I assigned customers "read only" permissions so the "Upload" links and all links such as that one do not display; however, if you type in the exact file path such as http://mysite/customer1/_layouts/Upload.aspx?List=[list number] they are able to see this.  There are a couple dozen of files that act the same way i.e. /WebFldr.aspx /Combine.aspx /EditForm.aspx.  If the user tries to upload or modify something they will be redirected to an access denied page, but the issue is they should not see these pages at all as they will have personal data.

    A SharePoint trainer came to my company, but he could not answer this question and I have been googling a lot for an answer that I understand and that works for us, but am not having any luck.  Any help would be greatly appreciated.

    Thank you!

    Friday, December 2, 2011 5:58 PM

Answers

  • Hi,

    Follow thees steps:

    1. Go to Site permissions by adding _layouts/user.aspx to your site URL.

    2. Go to settings-->Permission levels

    3. In the next page click on Read or anything else you want to modify.

    4. In the next page uncheck the option of view application pages.

    I hope this will help you out.


    Thanks, Rahul Rashu
    Monday, December 5, 2011 3:22 AM
  • Excellent Rahul,

    You can create a permittion level and rename it to "deny app" and deselect the option Application pages view

    Give this permittion level to you're user or sharepoint group, and the person or sharepoint group will not be able to the these pages..

    you can read more here: http://mikesnotebook.wordpress.com/2010/11/

     

    Kr, Gokan


    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    Monday, December 5, 2011 10:17 AM

All replies

  • Hi,

    Follow thees steps:

    1. Go to Site permissions by adding _layouts/user.aspx to your site URL.

    2. Go to settings-->Permission levels

    3. In the next page click on Read or anything else you want to modify.

    4. In the next page uncheck the option of view application pages.

    I hope this will help you out.


    Thanks, Rahul Rashu
    Monday, December 5, 2011 3:22 AM
  • Excellent Rahul,

    You can create a permittion level and rename it to "deny app" and deselect the option Application pages view

    Give this permittion level to you're user or sharepoint group, and the person or sharepoint group will not be able to the these pages..

    you can read more here: http://mikesnotebook.wordpress.com/2010/11/

     

    Kr, Gokan


    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    Monday, December 5, 2011 10:17 AM
  • Rahul,

    Thank you very much I am amazed at how simple that was and it appears to be working!  I'm going to do some tests to make sure all the links are blocked.

     

    Gokan,

    Thank you as well I need to look more into this to see that I understand completely then will try to implement your suggestions.

     

    Thanks again everyone!

    Monday, December 5, 2011 2:26 PM