locked
"Presence Unknown" for old email address RRS feed

  • Question

  • One of our users noticed that when you search for their name in SfB, you get two contacts. One of which is the correct one and one of which just shows "Presence Unknown". 

    I took a look at the contact cards and the old one seems to be pointing to an email address that was changed. For example, it was previously johndoejr@test.com and now it's johndoe@test.com because they wanted the "Jr" removed.

    I imagine the "Jr" address is still active and just sends the emails to the non-Jr address, but I haven't checked into it too much.

    Is there anything we could do to remove the "Presence Unknown" contact? 

    Wednesday, August 10, 2016 12:56 PM

Answers

  • I would start by suggesting websearchonly so you're not concerned about old GAL entries after name changes.   http://blog.schertz.name/2010/11/forcing-lync-address-book-web-query/.  This forces all queries to occur online through a web search rather than using the old GAL.  I'd also confirm that all users see the same thing, and it's not coming from an old Outlook contact. 


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Proposed as answer by Alice-Wang Thursday, August 11, 2016 6:22 AM
    • Marked as answer by Alice-Wang Friday, September 9, 2016 10:15 AM
    Wednesday, August 10, 2016 3:17 PM

All replies

  • I would start by suggesting websearchonly so you're not concerned about old GAL entries after name changes.   http://blog.schertz.name/2010/11/forcing-lync-address-book-web-query/.  This forces all queries to occur online through a web search rather than using the old GAL.  I'd also confirm that all users see the same thing, and it's not coming from an old Outlook contact. 


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Proposed as answer by Alice-Wang Thursday, August 11, 2016 6:22 AM
    • Marked as answer by Alice-Wang Friday, September 9, 2016 10:15 AM
    Wednesday, August 10, 2016 3:17 PM
  • Hi CAShadle,

    You could also try to add the registry HKLM\Software\Policies\Microsoft\Office\15.0\Lync\v GalDownloadInitialDelay /t REG_DWORD /d 0 /f to force the address book download.

    After adding this key you must exit and re-enter the SFB client.

    If only the specific user has the issue, please try to delete SFB client cache files and try to compare user attributes in AD between affected user and other normal users.

    %userprofile%\AppData\Local\Microsoft\Office\15.0\Lync\sip_UserName@Domain.com

    Moreover, make sure your SFB client with the latest update.

    Best regards,

    Alice Wang


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Alice Wang
    TechNet Community Support


    • Edited by Alice-Wang Thursday, August 11, 2016 6:40 AM
    Thursday, August 11, 2016 6:39 AM
  • Hi CAShadle,

    I am checking to see how things are going there on this case.

    would you please provide us with an update on the status of your issue?

    If there's anything you'd like to know, don't hesitate to ask.

    Best regards,

    Alice Wang



    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Alice Wang
    TechNet Community Support

    Saturday, August 13, 2016 8:03 AM
  • Sorry about the delay - ran into some other issues and forgot to follow up!

    We have the GAL set to websearchonly, so it shouldn't have to download the address book as far as I'm aware.

    Other users in the company also see this old alias as a second account and it doesn't seem to be specific to any individual group of users either. Would it be pulling it from anywhere else like a contact on Exchange?

    There are also other users that were deleted from AD/Exchange/SfB servers and they still show up as presence unknown.  Any other ideas?

    Thursday, August 18, 2016 7:27 PM
  • Hi CAShadle,

    It seems that something wrong with your Address Book.

    Please run the command line Update-CsUserDatabase and Update-CsAddressbook, after this make sure your CMS has the latest update and test again.

    Moreover, check if the user set the contact information in the Lync client manually.

    Best regards,

    Alice Wang


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Alice Wang
    TechNet Community Support

    Sunday, August 21, 2016 2:14 AM