locked
getting prompted when connecting to any sharepoint 2007 site RRS feed

  • Question

  • I know this has been discussed many times before but i can't believe the solutions I am getting from google searches

    I am logged into the Domain.

    I am A Domain Admin, a Farm Admin, Application Admin, and site Collection Admin.

    When I try to access Central Admin or any site I am prompted for credentials everytime.  Once I enter my credentials, I can access this sites.

    The environment is like this:
    Windows SharePoint 2007 Office Server Enterprise
    Windows 2003 SP2
    SharePoint is older version 12.0.0.4518 ( I will upgrade later)

    Somethings that I have tried:
    Added the site to Tructed Sites and enabled user authentication to automatically Logon with username and password
    Did the same in Intranet
    Checked the Authentication providers in sharepoint and they are Windows Only
    Checked in IIS site properties > Document Security > Windows Integrated AUthentication is the only thing checked.

    Why is pass-through not happening?
    I don't believe i should have to remember password or place it under my trusted sites for a microsoft product not to pick up my logged in credentials from a microsoft OS.

    any ideas?


    Tony Parker, MSCE . MCTP. MCITP "Anything worth doing, is worth doing right"
    Saturday, May 7, 2011 6:36 PM

Answers

  • Hi TonyParker,

     

    This behavior may occur if the lockdown feature is enabled for the Limited Access permission level. The lockdown feature prevents anonymous users from viewing form pages and using remote APIs.

     

    To resolve this issue, use the Stadm.exe command-line tool to disable the lockdown feature. To do this, follow these steps:

    1.     Click Start, click Run, type cmd in the Open box, and then click OK.

    2.     Type the following lines at the command prompt. Press ENTER after each line.

        cd /d %commonprogramfiles%\Microsoft Shared\Web Server Extensions\12\Bin

        stsadm -o deactivatefeature -url http://<var>ServerName</var> -filename ViewFormPagesLockDown\feature.xml

    3.     Type exit to exit the command prompt.

     

    Note After you run this command-line tool against your site, you must toggle the Site Settings advanced permissions to turn off Anonymous access. Then, turn on Anonymous access again. You must do this for the command to take effect on content that exists in the site.

     

    Thanks & Regards,

    Peng Lei

    • Marked as answer by David HM Monday, May 16, 2011 2:36 AM
    Monday, May 9, 2011 2:20 AM