locked
Vista Backup error puzzle RRS feed

  • Question

  •  

    Can anyone provide a definitive answer to this question? First the issue - when I first installed Vista a year ago now, the command or file for Vista Backup only ever worked once but never since. It could be that the backup file that Vista created on the Slave Drive was the issue as it was deleted due to there being a problem with the Drive resulting in it having to be formatted again - that's just a guess by the way.  Anyway when I tried to carry out any further backups I always got an error message with text saying backup file missing or corrupted. Now it's not the end of the world as I use Acronis 10 which probably does a much better job, but it's just one of those mysteries I would like to solve as I hate things that should but don't work.

    The error message is as follows - Task image is corrupt or has been tampered with 0x80041321

    If anyone has any ideas short of a reinstall of Windows then I would be grateful for any advice.

     

    Faustus1

    Sunday, February 10, 2008 7:31 PM

All replies

  • I had the same problem with my Vista home premium.
    For a long time, automatic backeup worked fine, then one day I got the same error message.

    What helped was: (sorry i can only tell the path in germen, because i'm workin with a german vista):
    - open Computer / Verwalten (rightclick on computer)
    - click on 'aufgabenplanung' (task ... ?)
    - an error message similar to the above appears with 'AutomaticBackup' in it

    Open regedit
    - search for 'AutomaticBackup'
    - find it in the path:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks\{8E9EF5BB-34BB-4B51-9017-798044A2F0CC}]
    - copy the task-id (here: 8E9EF5BB-34BB-4B51-9017-798044A2F0CC)
    - delete the key
    - find all occourences wtih 8E9EF5BB-34BB-4B51-9017-798044A2F0CC
    - delete the keys
    - find all other occourences of 'automaticbackup'
    - delete them

    Now you should be able to start backup again and create new scheduled backups.

    Not neccesary to say that you should have a valid sytem restore point before altering the registry... ;-)

    Let me know, if this worked for you.

    Sunday, April 20, 2008 10:11 AM
  • Hallo Stefan

    Ich wollte nach langer Suche nach einer Lösung für das 0x80041321 - Problem schon aufgeben. Dann bin ich per Zufall noch auf deine Lösung gestossen. Auch wenn mir sie etwas seltsam erschien und es etwas Mut brauchte, die Schlüssel mitsamt Unterschlüssel zu löschen, versuchte ich es, und

    ES HAT GEKLAPPT
    !

    Allerbesten Dank!

    Ein Hinweis noch: die Zeichenfolge {8E9EF5BB-34BB-4B51-9017-798044A2F0CC} war bei mir eine ganz andere. Entscheidend war erstens der Schlüssel

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks\{irgendein Ziffern- und Buchstabengemisch ***}]

    ***) bei mir hiess der Schlüssel [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks\{5512E923-464A-4CBC-A796-38D662563762}]

    Dort stand das erste Mal "AutomaticBackup" und ich löschte also diesen Schlüssel.

    Und dann suchte ich zweitens weiter nach "AutomaticBackup" und ich fand den Schlüssel

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\Microsoft\Windows\WindowsBackup\AutomaticBackup]

    Und auch den löschte ich. Dann startete ich (glaube ich wenigstens) den Computer neu. Und danach funktionerte der Vista Backup wieder wie eh und je.

    Übrigens hat das System diese beiden Schlüssel wieder neu angelegt, allerdings den ersten mit einem anderen Ziffern- und Buchstabengemisch (glaube ich zumindest).

    Für alle die so suchen wie ich:

    Taskabbild beschädigt
    0x80041321 Vista Backup
    Saturday, May 3, 2008 5:42 PM
  •  

    Hi Faustus1,

     

    The error sounds like there's something wrong wih the scheduled backup task in task scheduler. Maybe you can try deleting the task, go through backup configuration to start backup again and see if it works? 

     

    Regards,

    Christine

    ______________________________________

     

    This posting is provided "AS IS" with no warranties, and confers no rights
    Monday, May 5, 2008 9:37 PM
  •  

    Hi Christine,

          I've also recently started experiencing this issue, let me tell you what I've done so you better understand whats going on. First off I started having this prob when I installed Acronis, which is incredible its already saved my butt, and in fact has allowed me too try different experimentations, then restore back so you know what I've tested as Im computer savvy myself. I've done all system checks, run SFC and all is good NO Integrity Violations, I've run "chkdsk %systemdrive% /r" with  Windows finding NO errors and drive is in great state. It should be as this computer is only 4 months old if that...I do have Service pack 1 running and all is good and healthy registry wise. So now comes to the tests I've run, first off I thought maybe the offending file was the SR file in Windows>System32>Tasks>Windows>SystemRestore, by removing and it and NOT deleting it but moving it to another folder, I try to restore to see if Windows would generate another file but no dice instead I get another problem about "The file already exists or something" I cant delete the the System Restore Folder in Task Scheduler either, it states that all tasks must be removed however which is why we;re getting this error anyway...there are no tasks at all in the Task Scheduler for System Restore, however the file is in its place to be read, doesnt seem like Windows is reading it. I've also tried deleting the registry key under HKEYLocalMachine>Software>Microsoft>WindowsNT>Schedule>Tasks, but was also unlucky as this simply causes Task Scheduler to hang throw an error in event viewer that it couldnt start a specific task, then states to restart Task Scheduler, but of course we cant because it cant be STOPPED, DISABLED, RESTARTED, or anything because its greyed out entirely in services. I've restored to my good state with none of the above changes but still currently have this prob, Im much like anyone else I dont like having things wrong with my system that should be running and would finally like this to be resolved. I would like to know more on this backup configuration you speak of...as Im a little confused on that. Please reply soon as I cant take much more of this not working.

     

                 Thanks much,

                       Christian

    Tuesday, May 6, 2008 10:38 PM
  •  

    Hi Christian,

     

    I'm a little confused. Are you having problem with System Restore or file backup? If it's file backup, the task I was mentioning is task scheduler->Microsoft->Windows->WindowsBackup. Once the task is deleted, it'll be recreated if you configure file backup again.

     

    Thanks,

    Christine

    ______________________________________

     

    This posting is provided "AS IS" with no warranties, and confers no rights

    Wednesday, May 7, 2008 12:20 AM
  • Christian,

     

    I am having the same problem but it wont let me delete the folder even though i removed the tasks, still getting the same error.

     

    Tuesday, August 26, 2008 10:06 AM
  • The same problem occurs whenever I open Task Scheduler or try to create a Manual Restore Point in a brand new HP laptop with Vista Home Premium. The problem is with System Restore, *not* with Scheduled Backup. The error messages are:

     

    1. When I open the Task Scheduler: "The task image is corrupted or has been tampered with. SR"

     

    2. When I try to create a manual restore point in System Properties/System Protection: "The scheduled task could not be created for the following reason: "The task image is corupted or has been tampered with (0X80041321)"

     

    Someone suggested in another forum to select "C:" in the System Protection window and click on "Apply" to create the restore point; but "Apply" is greyed out.

     

    There are no visible tasks in the SystemRestore folder in the Task Scheduler. Nothing shows up. Browsing through C:Windows\System32\Tasks\Microsoft\Windows\SystemRestore I found the XML script file named SR, but nothing else.

     

    I have posted this problem on several forums, and found that is not an uncommon occurence, but have not yet found a solution. The one posted here by our german friend looks appealing, but the translation problems make it too dangerous to try. It seems he is even refering to a problem with scheduled file backups, and not System Restore.

     

    Thank you very much in advance for any light you can bring on this!

     

    Best wishes,

     

    Luc.

     

    -------------------------

    HP Pavilion dv6951la Notebook

    TL-62 AMD Turion 64

    4 GB RAM

    -------------------------

     

     

    Friday, September 12, 2008 9:40 PM
  • Ran across the same issue. Although this corrected the problem there is still no root cause from what I can determine.

     

    Example -- The task image is corrupt or has been tampered with.script  - "in this example script is the name of the affected scheduled task" 
      Check if task is corrupted
    At a command prompt type : schtasks /query | findstr /i "replace with name of task example above would be script"
    Look for
    ERROR: The task image is corrupt or has been tampered with.
    ERROR: Task cannot be loaded: task name
    If the above is true delete the task at the following location and recreate: (you should notice a file with the affected schedule task at this location) c:\Windows\System32\Tasks 

    Tuesday, September 30, 2008 6:53 PM
  • Hello, Daisy:

     

    Thank you very much for your reply! Could you please tell us how to recreate the task after deleting it, exactly? The affected task is c:\Windows\System32\Tasks\SystemRestore\SR . I cannot recreat it from Task Scheduler, since it won't open its parameters for editing --the task doesn't even show in there.

     

    Best regards.

     

    Wednesday, October 1, 2008 12:34 AM
  • In our particular case the task called "scripts" was located under c:\Windows\System32\Tasks. There was simply a file with no extension called "scripts". After verifying it was truly corrupt using the schtask command described earlier I deleted the "scripts" file. At that point I was able to create the task through the GUI or using the schtask command as originally setup. From what you are describing it appears the task you are having issues is located under a SystemRestore directory and a file called "RS". I would delete that file and recreate it following the original procedures used when you originally set this up. I would be sure to save a copy off to a location in the event you need to restore the config back to your current state.

     

    Bill

     

    Wednesday, October 1, 2008 3:06 PM
  • Vielen Dank, diese Info war der Schlüssel, um die Aufgabenplanung zu reparieren.

    Fehlermeldung:

    FEHLER: Aufgabe kann nicht geladen werden: Google Software Up
    FEHLER: Das Taskabbild ist beschädigt oder wurde verfälscht.

    Lösung:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks\TREE]

    hier nach Google Software Updater geschaut und gelöscht.

    Danke

    Thursday, December 6, 2012 1:54 PM