locked
cannot select Require users to press Ctrl+Alt+Delete RRS feed

  • Question

  • Hello,

    I'm a relatively new Windows user and recently upgraded to Windows 7 64-bit Home Premium on my laptop.

    I do not want to advertise which user accounts are available on my laptop and would prefer the standard Ctl-Alt-Del
    method of logging in.

    I tried the various steps of accessing password management, went to the Advanced tab, but the "Require
    users to press Ctrl-Alt-Delete" check box is grayed out. 

    I am the administrator on this lap top, so I am at a loss.

    Is this not possible with Home Premium?

    Am I missing something?

    Thanks in advance,

    Ken Reed
    Thursday, November 12, 2009 2:53 AM

Answers

  • And, here they are:
    HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\DontDisplayLastUserName
    HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System, value=DontDisplayLockedUserId
    HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableCAD
    For all of the above, a ValueData of 1 = enabled; 0 = not enabled.  Reboot after making the changes.

    Standard warning:
    incorrect editing of the Registry can have far-reaching and dire consequences, possibly resulting in an unbootable system (and, requiring reinstalling the operating system to correct.)  Proceed at your own risk! 
    /warning

    HTH,
    Chris

    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    • Marked as answer by kenreed Tuesday, November 17, 2009 4:04 PM
    Saturday, November 14, 2009 10:48 PM

All replies

  • In "Run" keying control userpasswords2 (where accounts can be seen), call for Ctrl-Alt-Del which supposedly obviates robotic attempts.
    Thursday, November 12, 2009 8:49 AM
  • Hi Ken,

    Is the computer in domain? If so, the setting may be changed by domain admin which we will not able to change it back.

    You can check a group policy:

    1. Input gpedit.msc to start Local Group Policy Editor.
    2. Nagtive to Local Computer Policy --- Windows Settings --- Security Settings --- Local Policies --- Security Options
    Thursday, November 12, 2009 9:29 AM
  • Thanks TheGonzoIsIn.

    I did try that, but the check box for Ctrl-Alt-Del is grayed out.  I cannot select it.

    I think this may be a limitation to Home Premium, which is disappointing but not a show stopper.
    Friday, November 13, 2009 1:14 PM
  • Hi Shaon Shan,

    No domain.  It's a standalone laptop that I basically take with me everywhere.

    Home Premium, according to the docs I've read, doesn't provide a mechanism for Group Policies. 

    I even went as far as to try and create a MMC and add that, but the Local Users and Groups management add-in only provides a message that
    states something like "Windows 7 Home Premium does not...Please use "Manage User Accounts".

    If I go into Computer -> Manage, Local Users and Groups doesn't exist there anymore.

    So, I guess, if I want that functionality, I would have to upgrade to Professional (or whatever the next step up is).  Not sure it's worth
    the delta in cost so I may just have to live with this current configuration.

    The thing that is annoying to me is that I should be able to run "netplwiz", go to Advanced and check that Ctrl-Alt-Del button.  According to technet
    and Windows 7 Support, that should be available/applicable to all versions of Windows 7.  But it won't allow it on mine.  Very strange.

    I'll keep digging.

    Thanks!
    Friday, November 13, 2009 1:23 PM
  • In User accounts window that arises from RUN->control userpasswords2
    do you see a check in box  "users must enter user name & password...?
    You need one. If you have one, read on

    At bottom it also says
    Password for XXX
    a) To change your password, press Ctrl-Alt-Del and select Change Password.
    b) Below this is a Button with "Change Password" that is non functional to me.
    Doing a) above may set your account to normal state allowing you to see the
    Require users to Ctrl-Alt-Del

    Note: 1) I've always used Ctrl-Alt-Del (Xp OSs, Vista Home Prem etc.)

    Friday, November 13, 2009 5:57 PM
  • Hi, Ken.
    Normally, I'd give the suggestion that Sharon did - change settings in Group Policy Editor.
    But, you're running Home Premium.  Therefore, no gpedit for you.  :(

    However, gpedit.msc is but a nice, orderly frontend for all of the Registry keys that it can modify.  Somewhere around here, I have a reference spreadsheet for that.
    Give me a little time to find it.

    (side note: I also post this now, to remind me to post the info later.  :P )

    -Chris
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Saturday, November 14, 2009 10:37 PM
  • And, here they are:
    HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\DontDisplayLastUserName
    HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System, value=DontDisplayLockedUserId
    HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableCAD
    For all of the above, a ValueData of 1 = enabled; 0 = not enabled.  Reboot after making the changes.

    Standard warning:
    incorrect editing of the Registry can have far-reaching and dire consequences, possibly resulting in an unbootable system (and, requiring reinstalling the operating system to correct.)  Proceed at your own risk! 
    /warning

    HTH,
    Chris

    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    • Marked as answer by kenreed Tuesday, November 17, 2009 4:04 PM
    Saturday, November 14, 2009 10:48 PM
  • Thank you Chris, for helping finished the monitor registry job. Hope this can help get the issue fixed.
    Monday, November 16, 2009 8:52 AM
  • TheGonzoIsIn,

    I appreciate the help.

    I do see the check box, "users must enter username and pasword" and it is checked.

    However, the "Require users to Ctrl-Alt-Del" check box is still grayed out.

    Chris's post, using the Registry, did the trick so I'm all set now.

    I appreciate your postings.

    Thank you,

    Ken Reed.
    Tuesday, November 17, 2009 4:04 PM
  • Chris,

    Thank you very much.  That was exactly what I was looking for.

    I appreciate your help.

    Take Care,

    Ken Reed.
    Tuesday, November 17, 2009 4:05 PM
  • Hi,

    My name is Cole.  I am a 9 year old practicing on computers.  To require users to press control-alt-delete go to User Password, then press advanced, then select the box "require users to press control-alt-delete.  If this does not work, go to the internet and type in make users press control-alt-delete, then select the link that says http://www.sevenforums.com/tutorials/612-secure-logon-press-ctrl-alt-delete-log.html 

       

    Saturday, March 3, 2012 8:26 PM
  • For XP users you must do the following if you want the actual CAD box no longer greyed out:

    HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System

    delete the DisableCAD key

    Tuesday, October 2, 2012 6:22 PM