none
Stuck on Tasks page loading RRS feed

  • Question

  • Hello! We have a Project Server 2013 on-premises environment (with SP1 installed).

    One of our project managers cannot load Tasks page https://<PWA_URL>/Tasks.aspx in browser.

    When he opening link, image "loading.." appears and got stuck on it.

    All other functions working correctly, all other pages loading normally.

    This bug happens only with small number of users.

    What can be cause of that behaviour?

    Wednesday, May 21, 2014 10:52 AM

All replies

  • Hello,

    Do they get the same issue if they try another browser (Firefox, Chrome etc.) or try from another machine?

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Wednesday, May 21, 2014 10:57 AM
    Moderator
  • Could have to do with load balancing, perhaps the .aspx page is messed up on one front end, reboot should fix it.

    Or like Paul said it could be a browser-related issue. Is there something different about the users who experience the problem?

    Wednesday, May 21, 2014 12:37 PM
  • Is there any java script errors being noticed in IE status bar ?

    Thanks | epmXperts | http://epmxperts.wordpress.com

    Wednesday, May 21, 2014 2:16 PM
    Moderator
  • Hi Lehus,

    Are you getting any error message like Unknown Error Occurred?

    Try doing a SP_Updatestats on Project Database.

    Please let me know if that helps.

    Cheers Troubleshooting!!!

    Phani

    Wednesday, May 21, 2014 2:23 PM
  • Hi Lehus,

    As my colleagues already stated, it looks like an IE issue. Try to access the page from another browser to confirm it. Which IE version do you have? Evenif the latest IE version (11) is supposed to support PS2013, some pages might not rend as expected.

    Try the following:

    • Press CTRL F5 to refresh IE deleting the cache,
    • Add the ULR in the compatibility mode settings,
    • Press F12 (developper tool) in IE and set the default browser to IE9.

    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Wednesday, May 21, 2014 2:42 PM
    Moderator
  • Hi all and thanks for your replies! Unfortunately, nothing helped..

    What i've tried:

    • x32 IE, Chrome
    • Open from different machine
    • IE with -extoff option
    • add to Compatibility View Lists
    • IE Developer Tools -> IE9 mode
    • Reboot Project server

    Still no success, and no Java or Silverlight-related errors at page loading. No other unknown errors in ULS. Only one user affects this. 

    Just stucks on rolling "Loading" icon. 

    Since my attempts from the other machines haven't helps and only one user experienced this bug, its looks like an project-user-related issue. How can i properly delete and recreate \ repair \ update user and his tasks in Project server (and save all his tasks and other related info)? (We use Project-permission mode)

    Monday, June 2, 2014 6:31 AM
  • Before concluding that it is a user related issue, have you tried to connect with another account?

    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Monday, June 2, 2014 12:06 PM
    Moderator
  • I'm not concluding, just supposing, since i've tried from another machine, where there are no troubles with another user, but trouble exists with this one. But at current i have no possibility to try with another user, only have access to Project server.

    Yes, i've tried one more time on another PC. This trouble roams with this single user.

    • Edited by Lehus Thursday, June 5, 2014 11:58 PM add info
    Monday, June 2, 2014 8:56 PM
  • Hi Lehus,

    Disable Dynamic compression and static compression for the site and check the behavior.

    Do you see any errors in event log or ULS?

    Thanks,

    Phani

    Monday, June 9, 2014 10:08 PM
  • After some research, i've found some clues )

    This bug happens only when user specified in specific single project. When we delete user from this project and reassign all resources, all's good. When we add another user to this project, he also being faced with this bug.

    But what project features can cause this.. i've not found yet..

    Friday, June 27, 2014 1:11 PM