none
outbound Queue full of emails nobody sent with 400 4.4.7 and 441 4.4.1

    Question

  • testing EXCHANGE 2016 DEV

    example:

    Identity: EX1\29075\6682969112595
    Subject: Undeliverable: Check Worrying Off Your List. Start the New Year Right With Term Life.
    Internet Message ID: <dd7874ca-23af-4f9b-a5ff-1ad86613c862@EX1.DOMAIN.LOCAL>
    From Address: <>
    Status: Ready
    Size (KB): 14
    Message Source Name: DSN
    Source IP: 255.255.255.255
    SCL: -1
    Date Received: 1/8/2017 4:10:56 PM
    Expiration Time: 1/10/2017 4:10:56 PM
    Last Error: 400 4.4.7 Message delayed
    Queue ID: EX1\29075
    Recipients:  Haven_Life_Teamm@yourself.bpounce.us;2;2;[{LRT=};{LED=400 4.4.7 Message delayed};{FQDN=};{IP=}];0;CN=Send connector,CN=Connections,CN=Exchange Routing Group (DWBGZMFD01QNBJR),CN=Routing Groups,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=JC,DC=LOCAL;0

    I have scanned for a virus and non found. Who is sending these??


    • Edited by jamicon Tuesday, January 10, 2017 3:15 PM
    Tuesday, January 10, 2017 3:11 PM

Answers

All replies

  • Hi,

    Thanks for contacting our forum. 4.4.7 Message expired. Message wait time in queue exceeds limit, potentially due to remote server being unavailable.

    Most likely those are NDRs for users who don’t exist in your org. Please check the user Haven_Life_Teamm@yourself.bpounce.us

    For instance if you are trying to send mail to someone , someone’s mail server is not liking something ( your mail server is missing PTR record, or your mail server is listed in RBL ( real time block list) list, you’re sending spam mails, your MX record is missing.

    It’s recommended to check the message tracking log via the message internal message ID “dd7874ca-23af-4f9b-a5ff-1ad86613c862@EX1.DOMAIN.LOCAL” or message subject “Check Worrying Off Your List. Start the New Year Right With Term Life” as command below:

    Get-MessageTrackingLog –ResultSize Unlimited –Start "11/2/2015 2:30PM” –End “11/2/2015 3:30PM” -MessageSubject "XXX" | fl

    Get-MessageTrackingLog –ResultSize Unlimited –Start "11/2/2015 2:30PM” –End “11/2/2015 3:30PM” - InternalMessageId "XXX" | fl

    Please refer to Get-MessageTrackingLog.

    We could following the steps below for troubleshooting:

    • Create an SPF record for your domain configured with a HardFail
    • Configure the InternalSMTPServers property on your transport servers
    • Install the Anti-Spam agents on Exchange
    • Configure SenderID filtering to reject emails that fail SPF checks
    • Test SenderID Agent

    Hope it’s helpful for you.


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 11, 2017 3:17 AM
    Moderator
  • Thank you for your response, not sure we are on the same page though, let me break it down.

            • My OUTBOUND queue is FULL
            • There is only 1 user account mailbox created
            • That user does not send any email other than test emails as this is a test site for Exchange 2016.
            • All 3rd party remote tests, MX TOOLS, Exchange Connectivity Tester all GREEN.

            So if these are NDR's who sent them?

            I remember in earlier versions of Exchange I had to actually go in and set to receive email from directory only otherwise my queue would fill up and look exactly like this is, however in recent years that feature has been built in and has not been necessary to "set". My current PROD environment is 2013, I did not "set" that nor do I have this problem.

            Is this unique to 2016?

          • Configure the InternalSMTPServers property on your transport servers - DONE
        • Install the Anti-Spam agents on Exchange - DONE
      • Configure SenderID filtering to reject emails that fail SPF checks - DONE

        Mailbox role.



    • Edited by jamicon Wednesday, January 11, 2017 12:33 PM
    Wednesday, January 11, 2017 12:30 PM
  • Thank you for your response, not sure we are on the same page though, let me break it down.

            • My OUTBOUND queue is FULL
            • There is only 1 user account mailbox created
            • That user does not send any email other than test emails as this is a test site for Exchange 2016.
            • All 3rd party remote tests, MX TOOLS, Exchange Connectivity Tester all GREEN.

            So if these are NDR's who sent them?

            I remember in earlier versions of Exchange I had to actually go in and set to receive email from directory only otherwise my queue would fill up and look exactly like this is, however in recent years that feature has been built in and has not been necessary to "set". My current PROD environment is 2013, I did not "set" that nor do I have this problem.

            Is this unique to 2016?

          • Configure the InternalSMTPServers property on your transport servers - DONE
        • Install the Anti-Spam agents on Exchange - DONE
      • Configure SenderID filtering to reject emails that fail SPF checks - DONE

        Mailbox role.



    Are you rejecting messages that aren't in the GAL? You should have some sort of recipient filtering that does this.  You cant do this on the mailbox servers. You would need to use the Edge role or a 3rd party anti-spam solution.

    https://technet.microsoft.com/en-us/library/bb123891(v=exchg.160).aspx


    Blog:    Twitter:   

    Wednesday, January 11, 2017 1:20 PM
  • No, I do not have an Edge Server, just Mailbox role with what AV features are allowed (works well though) in this test environment as neither does my PROD environment.

    Note: I do not have an Edge server in my PROD environment either and this is not happening.

    "Are you rejecting messages that aren't in the GAL?"

    This is what I referred to above....

    Are you saying that I can not limit to the GAL unless I have an Edge server?

    ----------------------------------------------------------------------------------------------------------

    PS] C:\Users\Admin\Desktop>Get-RecipientFilterConfig


    RunspaceId                 : 39ed86fc-37ad-4484-94b1-09479886d107
    Name                       : RecipientFilterConfig
    BlockedRecipients          : {}
    RecipientValidationEnabled : False
    BlockListEnabled           : False
    Enabled                    : True
    ExternalMailEnabled        : True
    InternalMailEnabled        : False
    AdminDisplayName           :
    ExchangeVersion            : 0.1 (8.0.535.0)
    DistinguishedName          : CN=RecipientFilterConfig,CN=Message Hygiene,CN=Transport Settings,CN=First
                                 Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=DOMAIN,DC=LOCAL
    Identity                   : RecipientFilterConfig
    Guid                       : ddbbe1a5-24e1-4e2e-9e5b-384281b8c51b
    ObjectCategory             : DOMAIN.LOCAL/Configuration/Schema/ms-Exch-Message-Hygiene-Recipient-Filter-Config
    ObjectClass                : {top, msExchAgent, msExchMessageHygieneRecipientFilterConfig}
    WhenChanged                : 10/25/2016 5:05:43 PM
    WhenCreated                : 10/25/2016 5:05:43 PM
    WhenChangedUTC             : 10/25/2016 10:05:43 PM
    WhenCreatedUTC             : 10/25/2016 10:05:43 PM
    OrganizationId             :
    Id                         : RecipientFilterConfig
    OriginatingServer          : DC1.DOMAIN.LOCAL
    IsValid                    : True
    ObjectState                : Unchanged

    --------------------------------------------------------------------------------------------------

    so Set-RecipientFilterConfig -RecipientValidationEnabled $true won't work then?

    I ran it:

    [PS] C:\Users\Admin\Desktop>Get-RecipientFilterConfig | Format-List RecipientValidationEnabled


    RecipientValidationEnabled : True

    [PS] C:\Users\Admin\Desktop>

    so we'll wait and see then?

    • Edited by jamicon Wednesday, January 11, 2017 2:35 PM
    Wednesday, January 11, 2017 2:27 PM
  • In the link I posted:

    https://technet.microsoft.com/en-us/library/bb123891(v=exchg.160).aspx

    Although the Recipient Filter agent is available on Mailbox servers, you shouldn't configure it. When recipient filtering on a Mailbox server detects one invalid or blocked recipient in a message that contains other valid recipients, the message is rejected. The Recipient Filter agent is enabled when you install the antispam agents on a Mailbox server, but it isn't configured to block any recipients. For more information, see Enable antispam functionality on Mailbox servers.


    Blog:    Twitter:   

    • Marked as answer by jamicon Wednesday, January 11, 2017 4:25 PM
    Wednesday, January 11, 2017 2:48 PM
  • Set-RecipientFilterConfig -RecipientValidationEnabled $true  solved my problem.


    thanks for the link
    • Edited by jamicon Wednesday, January 11, 2017 4:24 PM
    Wednesday, January 11, 2017 4:24 PM