none
Home Router changes Internet DNS settings and points to new 2008 R2 Server RRS feed

  • Question

  • Background:

    I have a Linksys router for my home network (which does DNS and DHCP), I recently installed a Windows Server 2008 R2 server with HyperV and Active Directory Roles (which I plan on using as a Lab environment with SQL and SharePoint as virtual machines)

    Problem:

    All the other computers in the house (notebooks, xboxs etc) lose internet connectivity, but still have network connectivity (can see other computers, printers etc.).  When I check on the Linksys router, in the setup tab there's a section for "Internet DNS" and there are 3 entries - all pointing to the IP addresses of the new R2 server and the 2 VMs. 

    Question:

    Why is my router automatically picking up the R2 servers and thinking they should be used for internet DNS?  Is there a role or feature in R2 that I need to disable? Thanks

    Wednesday, June 9, 2010 12:40 PM

Answers

  •   If you are using Active directory you should be using your internal DNS server only for your network. The successful operation of AD depends on this.

      Incidentally, it is bad practice to run Hyper-V on a DC.

       If you want to run all of these machines (physical and virtual) as if they were on your local network, modify the DHCP on your router to hand out the router's IP for a gateway but the DC's IP address for DNS. Modify your local DNS to forward to a public DNS service to resolve foreign URLs for you local machines. Do not give your AD clients any external DNS addresses, even as secondary addresses.

      I would not have set it up like that. I would have left the home network as it is and run your test lab in virtual machines only. You can run them in their own subnet in their own private virtual network. If you need to give them Internet access you can run a NAT router (in a vm) to link this network to the physical network.

     


    Bill
    Thursday, June 10, 2010 12:00 AM
  • Hi Nillac  ,

     

    Thank you for your post here.

     

    Before we move on, I would like to confirm the following information with you:

    ·         How this router obtain DNS address ?

    ·         Have you assigned DNS address for it ?

    Usually , if you assigned a specific DNS address for router ,it will not change itself , except reset or someone change it manually.

     

    Besides, I agree bill’s suggestion, since you have deployed Hyper-V server, so it’s recommend that run the test environment in their own subnet in Hyper-v ‘s private virtual network .it will avoid many unexpected issuers in your experiment.

     

    Thanks.

     

    Tiger Li

     

    PS:

     

    On July 1st we will be making this forum read only. After receiving a lot of feedback from the community, it was decided that this forum is a duplication and therefore redundant of the Network Infrastructure Servers Forum. So, until July 1st, we will start asking customers to redirect their questions to the Network Infrastructure Servers Forum. On June 11th, CSS engineers will move any new threads to the Network Infrastructure Servers Forum.

    Please post a reply to the announcement thread if you have any feedback on this decision or the process. You can also email WSSDComm@microsoft.com. 

     

    Friday, June 11, 2010 3:49 AM

All replies

  •   If you are using Active directory you should be using your internal DNS server only for your network. The successful operation of AD depends on this.

      Incidentally, it is bad practice to run Hyper-V on a DC.

       If you want to run all of these machines (physical and virtual) as if they were on your local network, modify the DHCP on your router to hand out the router's IP for a gateway but the DC's IP address for DNS. Modify your local DNS to forward to a public DNS service to resolve foreign URLs for you local machines. Do not give your AD clients any external DNS addresses, even as secondary addresses.

      I would not have set it up like that. I would have left the home network as it is and run your test lab in virtual machines only. You can run them in their own subnet in their own private virtual network. If you need to give them Internet access you can run a NAT router (in a vm) to link this network to the physical network.

     


    Bill
    Thursday, June 10, 2010 12:00 AM
  • Hi Nillac  ,

     

    Thank you for your post here.

     

    Before we move on, I would like to confirm the following information with you:

    ·         How this router obtain DNS address ?

    ·         Have you assigned DNS address for it ?

    Usually , if you assigned a specific DNS address for router ,it will not change itself , except reset or someone change it manually.

     

    Besides, I agree bill’s suggestion, since you have deployed Hyper-V server, so it’s recommend that run the test environment in their own subnet in Hyper-v ‘s private virtual network .it will avoid many unexpected issuers in your experiment.

     

    Thanks.

     

    Tiger Li

     

    PS:

     

    On July 1st we will be making this forum read only. After receiving a lot of feedback from the community, it was decided that this forum is a duplication and therefore redundant of the Network Infrastructure Servers Forum. So, until July 1st, we will start asking customers to redirect their questions to the Network Infrastructure Servers Forum. On June 11th, CSS engineers will move any new threads to the Network Infrastructure Servers Forum.

    Please post a reply to the announcement thread if you have any feedback on this decision or the process. You can also email WSSDComm@microsoft.com. 

     

    Friday, June 11, 2010 3:49 AM
  • Hi Nillac  ,

    If there is any update on this issue, please feel free to let us know.

    We are looking forward to your reply.

    Thanks.

    TIger Li

    Monday, June 14, 2010 3:19 AM
  • I didn't get any email notifications that there were responses?

    Tiger - to answer your question, the DNS addresses (3 of them) are automatically set by the router when I connect it to my service provider.  I don't seem to have the ability to edit those settings using the routers web based admin site.  As soon as I start up my host server, and the 2 VMs, the router automatically changes the DNS addresses and points to the servers. 

    I just bought a new Linksys Router yesterday and I haven't powered on the servers yet so I'll have to update tomorrow with the results.  I'll check the network adapter setting on the servers as well.

    Bill - thanks for your answer, I'm still trying to digest it...I'm not familiar with creating private virtual networks, subnets etc.  I know the configuration is not recommended, I'm just trying to keep it as simple as possible.  All I really want is a working SharePoint environment - which I use to be able to do (easily) with Virtual PC, now with 64bit I have to use Hyper-V so I'm stumbling through that as I go.

    Thanks again.

    Tuesday, June 15, 2010 4:54 PM
  •   Even with VPC, you should put domain machines in their own network and their own IP subnet.

        What I am suggesting in not any different from what I would recommend for a physical network. If you have a home network linked to to the Internet through an ADSL "router", that is fine. If you want to set up a test lab for AD and whatever else, that is also fine. Just don't try to put them both in the same network. It causes all sorts of problems. It is far bettter th keep you domain network completely separate from your home network.

      Put your server in its own network and give it an IP address in its own IP subnet. Promote it to a domain controller and let dcpromo configure DNS for your new domain. If you want to run DHCP in your test network you can install that as well (because you are in your own network and it will not interfere with your home network).

       If you want to connect this network to the Internet, the best approach is to put a NAT router between the test network and the original network. If the test network is in a virtual network, you can run a router in a virtual machine.

       Regardless of whether it is a physical or virtual network setup, you need to set up the DNS in the domain network to forward to a public DNS service. All domain machines should use only the local DNS address. They should not have any public DNS addresses, even as secondaries. They resolve public URLs through the local DNS forwarding their requests.

     

          


    Bill
    Wednesday, June 16, 2010 6:53 AM
  • OK, you've forced me to brush up on my TCP/IP addressing and subnetting basics...

    After I installed the new router and turned on all the servers everything seems to be working fine.  So my initial problem has been resolved, I have a feeling it was a configuration error on my part (in the router settings) that was causing the DNS problems.

    Based on your other recommendations I need to look into:

    1 - Moving my lab domain into its own IP subnet
    2 - Somehow move the DC off the Hyper-V server
    3 - Setup DNS in the local domain, have all VM's use the local DNS and have the local DNS server forward to a public DNS service...

    If you know of a blog or white paper that walks through this that would be great, for now I'm starting with Virtual machine guidance (SharePoint Server 2010) and the related links it provides.

    Thanks for your help.

    Wednesday, June 16, 2010 2:16 PM
  •   I doubt that you would find a step by step guide which would fit your needs. There are lots of ways to do it and everybody thinks his method is the best.

      You can run your home network as a domain. You can run a domain and a workgroup on the same physical network. You can even run your Hyper-V server as a DC in a test setup. I don't do any of those things, and I don't recommend them, but they can work.

       What I outlined earlier is how I run my domain setup on a home network which is basically a workgroup  behind a Netgear ADSL NAT device. Here is a basic diagram of how it is set up.

          Internet
               |
           Netgear
          192.168.0.1
              |
          LAN machines  (workgroup)
         192.168.0.x  dg  192.168.0.1
         config from DHCP on Netgear
               |
          192.168.0.254  dg  192.168.0.1
          RRAS/NAT (vm) 
          192.168.31.254  dg   blank
                |
               DC
          192.168.31.1  dg  192.168.31.254
                |             DNS and DHCP
                |
            other vms
          192.168.31.x  dg  192.168.31.254
            config from DHCP on DC

       All AD machines use 192.168.31.1  for DNS.
      Local DNS is set to forward to 4.2.2.2 (public DNS)   

      The RRAS router vm has one NIC in an external virtual network (linked to a physical NIC in the host and hence to the physical network) and one in the private virtual network with the other vms. 

      The workgroup machines use standard NAT to access the Internet through the Netgear. The AD machines are behind the RRAS/NAT router and can access the Internet or the LAN machines, but the workgroup machines do not see the domain machines because they are behind a NAT. The two DHCP services are inependent and do not interfere because thay are in different networks.

       You will note that there is no special mention of the host machine in this diagram. It is just one of the LAN machines in the workgroup.


    Bill
    Thursday, June 17, 2010 2:21 AM
  • The same problem was happening with my router for a long time. I am glad to appreciate the answers that the users have left there as the solution for this problem. I was tired of asking my friends for the solution but finally got the answer here. Feeling relieved at last.
    Monday, December 9, 2019 8:01 AM
  • Home router is a new trends of present scenario. the internet DNA settings are not too easy of DNA server. this is shared by   <a href="www.facebook.com">facebook</a> in a article. new 2008 R2 server is totally faster equipment. high speed internet connection is required for this router. through home router we can access so many devises. 
    Monday, December 23, 2019 6:48 AM