locked
Elevated command prompt not allowing admin rights RRS feed

  • Question

  • I have 7 each of 2 types different laptops on which I've configured a user account's interface (using a combination of Group Policy and local settings)to be severely restricted. On one type of laptop when I type 'cmd' in the start-run box and right-click it to choose 'Run As Administrator', I get the credentials box pop up, which is as it should be - I put in the credentials and can do whatever I need, such as run the TaskBarAndStartMenu.

    On the other type of laptop, when I type 'cmd' in the start-run box and right click to run as admin, I get no credential popup - the cmd prompt opens. BUT, if I try to invoke 'control /name Microsoft.TaskBarandStartMenu, I get a popup telling me I don't have rights.

    Somehow, right clicking for 'Run As Administrator' is not working for that specific laptop (and its the same for all 7 of that type of laptop, and the same (working properly) for the other 7 laptops. Considering they're all using the same group policy what could be happening?

    Thanks

    Friday, June 15, 2012 6:55 PM

All replies

  • Hi,


    You may double check the group policy setting.

    1. Click Start, type in “gpedit.msc” and press Enter.

    2. Navigate to Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options.

    3. Set security setting of “User Account Control: Behavior of the elevation prompt for standard users” as “Prompt as credentials”.


    In addition, if the issue occurs recently, we can perform System Restore for a test.

    http://windows.microsoft.com/en-US/windows7/products/features/system-restore


    Kim Zhou

    TechNet Community Support

    Monday, June 18, 2012 9:46 AM
  • Thanks, I gave it a whirl, and force-updated the policy a couple of times. Still no difference. Am I right in believing there's no local policy that could override a group policy? - If that's the case it's still pretty baffling because the other model of laptop gets the credentials prompt, using the same group policy.
    Monday, June 18, 2012 2:10 PM
  • Hi,


    At this situation, we may try to check if there is any wrong value in registry keys of UAC. Please refer to this document to collate.

    http://technet.microsoft.com/en-us/library/dd835564(v=ws.10).aspx


    Kim Zhou

    TechNet Community Support

    Wednesday, June 20, 2012 7:09 AM
  • None of these registry settings seem amiss...I tried changing a couple of them but it made no difference
    Thursday, June 21, 2012 7:11 PM