locked
After Installing IE10, Outlook 2010 has lost its default for MAILTO RRS feed

  • Question

  • Hi

    After having upgraded IE8 to IE10, I have noticed that Outlook 2010 has lost its default to Mailto.

    Hence, when I fireup Outlook it says it is no longer default program.

    Is there a way to fix this programmatically? That is via Registry?

    Thanks,

    DM

    Monday, May 5, 2014 1:15 PM

Answers

All replies

  • Windows 7 64-bit or 32-bit?

    Was IE10 offered & installed via Windows Update or did you choose to install it manually?

    Is Firefox, Chrome or any other alternate brower installed?


    ~Robear Dyer (PA Bear) MS MVP-Windows Client since 2002 Disclaimer: MS MVPs neither represent nor work for Microsoft

    Monday, May 5, 2014 5:40 PM
  • I think you let it "express install".

    Read here:
    Though Windows Mail is used as the default e‑mail program by web browsers and other programs that support sending e‑mail, you can choose a different e‑mail program as the default. If you decide you want to change the default e‑mail program back to Windows Mail, you can do so at any time.

    1. Open Default Programs by clicking the Start button and then clicking Default Programs.

    2. Click Set your default programs.

    3. Under Programs, click the e‑mail program you'd like to use, and then click Set this program as default.

    4. Click OK.

    ______________________________________________________


    • Edited by N Live Monday, May 5, 2014 6:09 PM
    Monday, May 5, 2014 6:01 PM
  • Windows Mail is the default Mail Client in Vista. Win7 doesn't include a default Mail Client.


    ~Robear Dyer (PA Bear) MS MVP-Windows Client since 2002 Disclaimer: MS MVPs neither represent nor work for Microsoft

    Monday, May 5, 2014 6:07 PM
  • Hi

    On Windows 7 64bit, with no other browsers installed.

    Used IEAK to create the MSI, but noticed the GPO is disabling external branding, so the changes made in IEAK is not taking effect. In no situation to change that policy at the moment.

    Anyway, using the MSI created by IEAK, and using reg hacks in combinations with GPO for settings at the moment. Managed to supress the Internet Search Provider pop up, but now im getting pop up for Outlook not being default email program. If i check the "defaults program", shows that the MAILTO isn't defaulted to Outlook 2010. MS Office is running 32bit.

    I think i may have found the reg keys, but not sure if i am doing the right thing here.

    These three keys seems to do it, but not sure if they are all necessary... probably not. Need more testing.

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\UrlAssociations\mailto\UserChoice]
    "Progid"="Outlook.URL.mailto.14"

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Protocols\Mailto]
    "UTF8Encoding"=dword:00000001

    [HKEY_CURRENT_USER\Software\Clients\Mail]
    @="Microsoft Outlook"

    However, on my other machine with IE8 on, half of those keys are not there, and Outlook is default. Hmmm....

    Thanks, DM.

    Monday, May 5, 2014 10:10 PM
  • Dunno how it got broken but reasserting MS Outlook as the default for E-mail in the CUSTOM (<=important!) section of Set Program Access and Computer Defaults and then restarting the computer should fix it.

    ~Robear Dyer (PA Bear) MS MVP-Windows Client since 2002 Disclaimer: MS MVPs neither represent nor work for Microsoft

    Monday, May 5, 2014 10:21 PM