locked
International Calls on Comcast RRS feed

  • Question

  • I have the task to start setting up international calling. I am focused on getting London's 020 area code to work.

    So far I have tested a plan that translates dialed numbers into:

    +44(0)20XXXXXXXX

    44(0)20XXXXXXXX

    +01144(0)20XXXXXXX

    01144(0)20XXXXXXX

    And not a single format has worked for me. Its attempting to dial domestically with these formats most of the time. Despite sending the 011 international code.

    We have Comcast voice and a Dialogic DMG1008 for our gateway. We have confirmed we have international calling enabled with Comcast. Am I just getting the format Comcast is looking for wrong? Perhaps a setting on our Dialogic needs to be changed to allow it? Domestic calls work perfect.

    Monday, December 24, 2012 5:08 PM

All replies

  • You should input the phone number as 01144(020)XXXXXXX, then this phone number should be translated to +44(020)XXXXXXX.

    You can check the rule IntlCallingUS in following link.

    http://technet.microsoft.com/en-us/library/gg413082.aspx

    You can also refer to the International Normalization chapter in below link.

    http://ucken.blogspot.com/2011/01/enterprise-voice-best-practices-in-lync.html


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, December 25, 2012 10:10 AM
  • You are short a digit. The 0 in front of the 20 is optional, but the 20 is followed by 8 digits. An example:

    [44] (20) 7499-9000 is the number to the US Embassy in London.

    I have indeed used the format you said (plus the extra digit which needs to be there), and that did not work. I tried both with dialing the optional 0 and without.

    Wednesday, December 26, 2012 4:00 PM
  • And to further update I just tested that format. I dialed 011442074999000 and 0114402074999000 and neither worked. The first one without the optional 0 didnt get anywhere past Lync. The second one with the 0 was sent out to the PSTN but didnt make it overseas. It stayed domestic. It said "The number you have reached- 499-9000 in area code- 207 is not in service, please check the number and dial again."
    Wednesday, December 26, 2012 4:35 PM
  • This is a mystery to me and I need to get it work. Any help?
    Friday, December 28, 2012 5:28 PM
  • You should check you normalization rule.

    If you want to dial 011442074999000, you should create normalization rule in dial plan as the follow image.

    If you want to 0114402074999000, the normalization rule should be created as below image.

    Or you can select at least under the length, then you can use one normalization rule for numbers of different length.

    From your description “The second one with the 0 was sent out to the PSTN but didn’t make it overseas”, it seems you normalization rule is like the second option. The problem seems with the PSTN usage. Please check you have selected the right PSTN usage and router for the international call in Lync control panel.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    • Edited by Lisa.zheng Monday, December 31, 2012 4:55 AM
    Monday, December 31, 2012 4:54 AM
  • I took a look in my DMG1008 call log and noticed what the problem was. Here is whats happening:

    Lync is correct. It sends +4402074999000 (or +442074999000 if I leave out the 0) to the gateway.

    In the log I can see thats what it is receiving:

    rom VoIP Network VoIP: Normal 27,Sam Edson,,27@lync02.domain..com->+4402074999000,,192.168.1.101,+4402074999000@192.168.1.101->,,, [Rsn=Direct]


    But then for some reason if I dial the extra 0 the gateway changes it to: 02074999000 and dials that, which connects to the PTSN, but then fails as a number not in service.

    If I dont dial the extra 0 the gateway changes it to: 42074999000 which isnt valid and doesnt reach the PTSN.

    If I send the gateway +01144XXXXXXXXXX it changes it to "144XXXXXXXXXX".

    I cant find any settings in my gateway that mention any translations either!

    Monday, December 31, 2012 5:23 PM
  • I don't have a Dialogic gateway in front of me, but look in the Config -> Routing section of the interface and then (I think) select the Inbound VOIP Rules radio button. Look in that general area for any number manipulation.

    If you find some manipulations there, be careful before changing them as it may lead to unintended consequences. This is the exact reason most Lync folk like to do as many of the normalizations as possible within Lync so you don't have to figure out an entirely different interface.

    Thursday, January 3, 2013 7:49 PM