none
Project Server 2013 Workflow error RRS feed

  • Question

  • Hello Experts,

    My project workflow was working fine until the data moved from one server to other. Now I am getting a strange issue in case of Workflow as described below :

    Whenever the users try to create a new project the workflow stage shows as "The workflow is still processing. refresh the page and try again".

    And when i check the Additional workflow Data the status is "Cancelled" with below Error info :

           "System.ApplicationException: HTTP 401 {"x-ms-diagnostics":["3001000;reason=\"There has been an error authenticating the request.\";category=\"invalid_client\""

    This is happening with most of the users, when they try to create project. Few users are able to create project successfully.

    I tried following trouble shooting, but none of it helped so far :

    1. I deleted all users in user profile service app

    2. Restarted the user profile service and user profile sync service

    3. Did a full Profile synchronization in user profile app

    4. Verified the users in the user profile app

    5. Did a complete active directory resource pool sync in the PWA

    6. Verified the users in the PWA

    7. Restarted the Project server service

    8. Restarted the Workflow timer Service

    9. Did an IIS Reset

    Still no use of any of these steps. My users still get the same error while creating new projects.

    Please help me solve this issue.

    Regards,

    shanky

    Monday, May 18, 2015 1:34 PM

Answers

  • Hi Guys,

    I tried manually adding the users to User Profile App and now it is working. Dont know why it needs manual entry, strange.

    Thanks,

    Shanky

    • Marked as answer by shankyshan Tuesday, May 19, 2015 8:58 AM
    Tuesday, May 19, 2015 8:58 AM