locked
Crash accessing Mapi since build 8229.2073 RRS feed

  • Question

  • We excperiance a crash while accessing the mapi interface with the newest outlook version Version 1706, Build 8229.2073.

    e.g. Click on Logon in MFCMAPI.exe

    brings up "the operating system is not presently configured to run this application" error message and then crashes:

    0191fd5c 666cefcc 0140b1d2 00000000 66da1f2c mso20win32client!Ordinal2055+0x55
    0191fd7c 666028e5 658a4eaa 01000048 0191fdd8 mso98win32client!Ordinal2003+0x77ee
    0191fda4 66603339 0550beb4 0191fe40 63694ca7 mso98win32client!Ordinal2129+0x1da5
    *** ERROR: Symbol file could not be found.  Defaulted to export symbols for OLMAPI32.DLL - 
    0191fdb0 63694ca7 0191fdd8 00000004 6c072f1e mso98win32client!Ordinal816+0x22
    0191fe40 63694a1e 01000048 6c072fda 00000000 OLMAPI32!FNewUserInfo+0x1745d
    0191fe84 63694d60 0100004e 6c072f92 63693bd7 OLMAPI32!FNewUserInfo+0x171d4
    0191fecc 63693be7 0100004e 0191feec 75ca38f4 OLMAPI32!FNewUserInfo+0x17516
    0191fed8 75ca38f4 00eff108 75ca38d0 3ee6f8ed OLMAPI32!FNewUserInfo+0x1639d
    0191feec 77145de3 00eff108 c48de06c 00000000 kernel32!BaseThreadInitThunk+0x24
    0191ff34 77145dae ffffffff 7716b7c6 00000000 ntdll!__RtlUserThreadStart+0x2f
    0191ff44 00000000 63693bd7 00eff108 00000000 ntdll!_RtlUserThreadStart+0x1b

    the same happens to your application if it tries to access MAPI.

    We allready tried to reinstall office, new profile, remove all addins.

    It started with one of our customers and more & more coming up with the same error (as soon as they update to Version 1706).  Does anyone experience the same issue or has a fix ?


    • Edited by MarinusP Tuesday, July 11, 2017 3:28 PM
    Tuesday, July 11, 2017 3:27 PM

All replies

  • Hi, yes I've got the same experience, any interaction with MAPI on build 1706 8229.2073 triggers a crash of the interfacing process.

    Fr attempts sending adobe pdfs via right client send to --> mail recipient or through the program, the mail is sent with the attachment but then the mapi process behind it fails.

    Same occurs for sending other file types through right click send to menu - tested word doc and jpg, each crashed their appropriate mapi interface processes.

    Wednesday, July 12, 2017 3:46 AM
  • Our quick fix is switching to the deferred channel, running these commands (as admin):

    C:\Program Files\Common Files\Microsoft Shared\ClickToRun\OfficeC2RClient.exe /changesetting Channel=Deferred
    C:\Program Files\Common Files\Microsoft Shared\ClickToRun\OfficeC2RClient.exe /update user


    Wednesday, July 12, 2017 7:29 AM
  • Hi,

    Do you mean Outlook application will crash when try accessing accessing MAPI? I couldn't reproduce this issue when testing in my Outlook 2016 Version 1706 (Build 8229.2073) environment. Is there any special step I need to pay attention to when testing? If possible, please provide the detailed steps here so that I can try it again.

    Thanks,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, July 12, 2017 8:29 AM
  • Reproduce:

    1. Open Windows Explorer and browse to a folder containing files.

    2. Right click on one of your files --> go to send to option --> select mail receipient.

    3. An email will open and attach the document.

    4. Regardless of whether you a) cancel the email you now have on screen; or b) proceed to send the email.

    5. Result is an error with the MAPI handler. (also note that if you are sending the email, it does in fact go through)

    Note that the mapi handler for send to mail recipient(c:\windows\syswow64\fixmpai.exe) is not to blame - the issue occurs with other MAPI interface handlers such as Adobe Acrobar Reader DC v11 (latest update), for me it points to an issue with how Office/Outlook is responding to these handlers, I'd assume its not sending an appropriate response back through and so the programs just crash.

    One interesting thing to note is that if you do it through Adobe Reader DC then the process ("C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\plug_ins\pi_brokers\32BitMAPIBroker.exe") then it will stay open and not crash until you close the reader window.


    • Edited by Nathan EMG Wednesday, July 12, 2017 10:06 PM
    Wednesday, July 12, 2017 10:06 PM
  • Apprently we have the same issue. It works on your VMs but some customers from different companys and with different AV/Addin ... products. All I have is some memory dumps which looks ok on the first sight. There must be another setting, application, ... which causing the issue but it is hard to tell. The only thing they have in common is Version 1706 and that it worked the version before.

    We are accessing the MAPI over the Redemption http://www.dimastr.com/redemption/home.htm from an seperate process and it crashes on initialization - its the same for MFCMAPI https://github.com/stephenegriffin/mfcmapi so i can exclude an issue with the remption library.

    I had to switch back our customers to the prev. version so they can continue to work, apprently we have no test system.

    Thursday, July 13, 2017 7:05 AM
  • Thank you for the update. I have followed the exact steps you provided but I still couldn't reproduce the issue. May I know the detailed Windows version you are using? Meanwhile, please also try starting Outlook in safe mode (outlook /safe) and see whether this issue continues.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 14, 2017 5:07 AM
  • Hi Steve,

    I just reinstalled my computer actually (MDT custom Image), updates from WSUS and still no dice.

    Windows Information:

    Win 10 Pro

    V 1607 (aware this isn't the latest)

    Build 14393.1358

    Prod ID 00331-10000-00001-AA099

    Office Version:

    v1706  build 8229.2073

    my colleague just updated to Office Version 1706 Build 8229.2086 and the issue still exists.

    Having outlook already open in Safe mode had no bearing on this issue - it still crashed the fixmapi.exe

    It seems we are also plagued by search issues with the June updates released not all of which are fixed.

    • Edited by Nathan EMG Wednesday, July 19, 2017 5:53 AM My screenshots that let me paste in didn't come up after posting so I edited in the details.
    Wednesday, July 19, 2017 5:41 AM
  • Hi Guys, 

    I found a similar issue but it's for Outlook 2010 version. See:

    https://support.microsoft.com/en-us/help/3050312/program-crashes-when-you-send-an-attachment-through-outlook

    However, we haven't received any report about similar issues in Outlook 2016. I'll try to submit a feedback regarding this issue via internal way to see if I will get any update on this.

    Regards,

    Steve Fan 


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 20, 2017 2:15 AM
  • Same issue here since v1706 (build 8229.2073)

    I'm using My Phone Explorer (MPE) to sync MS Outlook 2016 contacts & calendar entries over USB with an Android phone.  Has worked fine with no problems up to build 8229.2073 on the 11th July.  When running the sync it crashes MPE with the error "The operating system is not presently configured to run this application".  Am currently on build 8229.2103 with the same issue.

    Interestingly if I do a full online repair of MS Office Professional Plus 2016, reboot the computer, then run MPE it works once then comes up with the same error.

    Any information (or solution) would be appreciated.

    Regards.

    Monday, July 24, 2017 12:28 PM
  • MS Office has just been updated to v1707 build 8326.2058 today (28th July) and appears to have fixed the issue. This would indeed appear to be an issue with MS Outlook!!
    Friday, July 28, 2017 6:48 AM
  • I still see the same error with 8326.2062
    Tuesday, August 1, 2017 12:54 PM
  • Agree with you, still having that issue.  Crashes out the application.  that is even with the latest release

    Version 1707 (Build 8326.2062)

    Tuesday, August 1, 2017 3:45 PM
  • Hi All,

    This has been confirmed a known issue and our product group is working on the fix.

    Thank you for your understanding and support.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Steve Fan Monday, August 7, 2017 1:46 AM
    Wednesday, August 2, 2017 5:14 AM
  • Thanks Steve, good to hear. Presumably will be listed in an upcoming release note.
    Monday, August 7, 2017 3:01 AM
  • Thank you for the understanding. I heard that this issue will be fixed soon.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, August 8, 2017 3:18 AM
  • Hi!

    Does anyone know something new about this? I can't find a bugfix in any update channel yet.

    Regards Thorsten

    Tuesday, September 5, 2017 7:27 AM
  • Hi Term~,

    I have updated to the latest current channel 1707 8326.2096 for Office 2016 but still encounter the issue as well.

    I've just got a standard response to users that your email has gone and you just have to close the error until MS fix it.

    For a constantly updating platform it seems quite a poor omission for bug fixes.

    We still encounter our search and indexing issue also but won't get into that here.

    Wednesday, September 6, 2017 12:35 AM
  • It sounds like I may be having a similar issue as we have a web form in IE11 which sends an email through Outlook and upon clicking Submit or closing IE11 it gives me an IE has stopped working.  Problem began in build 1706 and still no resolution in latest build in insider fast.
    Wednesday, September 6, 2017 2:28 PM
  • From what I was told here and in my ticket with Microsoft it is being addressed in a future build.

    I am currently on the Office Insider build 8509.2001 where it works, but can't release a build like that to my users.  If you roll back to a deferred channel or a June release of current channel things should work fine, UNTIL Microsoft updates the releases to fix the issue.

    Wednesday, September 6, 2017 3:27 PM
  • Try Build 1709 Insider build .... 8509.2001
    Wednesday, September 6, 2017 3:28 PM
  • I still seem to get an IE stopped working error after closing the browser on 1709 8509.2001.  Maybe i don't have the same issue but seems it started in 1706 also for us.
    Wednesday, September 6, 2017 9:20 PM
  • It seems better in 8431.2079 - can anyone confirm?

    Only problem then seems to be that Outlook is unable to close if it was not opened before sending.

    It leaves a grey icon by the clock saying "Outlook is closing".

    Thursday, September 21, 2017 9:57 AM
  • Sorry I don't really use the feature and haven't had reports in a while from my users so I've checked and I'm now running v 1709 build 8528.2147 and confirm that the MAPI crash no longer occurs.

    the search indexing in outlook failing however still reoccurs despite my best efforts.

    I've had time-limited success by moving the search index, then deleting the index files while the service is restarting, but the issue just comes back again sometimes quickly sometimes slowly. but time to go and find a thread about that.

    Wednesday, November 22, 2017 3:39 AM