Not able to edit 2013 workflow in SharePoint Designer 2013 RRS feed

  • Question

  • I have installed SharePoint Designer 2013 and Visio Professional 2013 (both 64) in my machine(windows 7). Then I connected it to a SharePoint 2013 online site(in O365). I can open and edit all the contents including pages and 2010 workflow. But I can't view the 2013 workflow. When I try to edit 2013 workflow I get a blank workflow. 

    WF 2013

    Any help will be highly appreciated !!

    Thursday, November 28, 2013 1:23 AM


All replies

  • try this, lookalike its a known issue with MSFT.


    Please remember to mark your question as answered &Vote helpful,if this solves/helps your problem. ****************************************************************************************** Thanks -WS MCITP(SharePoint 2010, 2013) Blog: http://wscheema.com/blog

    Thursday, November 28, 2013 1:37 AM
  • I am having the same issue.  The answer below from Waqas Sarwar did not work for me, not to mention it did not relate to the original problem you posted.  Were you able to resolve this?

    Any help is appreciated.

    Thank you,


    Monday, January 12, 2015 6:54 PM
  • I finally found the answer.  I applied the hot fix http://support.microsoft.com/kb/2837633

    • Proposed as answer by Betty B Monday, January 4, 2016 8:10 PM
    Monday, January 12, 2015 8:58 PM
  • KateKateKate,

    ThanksThanksThanks!  Exactly what I needed today!  My PC was updated from Office 13 to Office 15 and turns out SPD is not installed with Office 15.  But after the reinstall, I had the problem reported in this post.  So glad you found the answer!  Saved me a lot of trouble and research!

    • Edited by Betty B Monday, January 4, 2016 8:19 PM
    Monday, January 4, 2016 8:09 PM
  • JijoJoy,

    Thanks for reporting this.  Still turned out to be helpful two years later believe it or not!  Had to re-install SharePoint Designer 2013 after upgrading to Office 15 from Office 13.  However, had the problem you mentioned, so it was nice to find a post that addressed my problem AND had the resolution!

    • Edited by Betty B Monday, January 4, 2016 8:19 PM
    Monday, January 4, 2016 8:13 PM
  • Help. I have the same issue as this thread.

    Background: I have a Win7 machine with SPD 2013 that I used to create 2010 and 2013 workflows. I have a new Win10 machine that I was using with SPD 2013 for a few weeks but had to reimage it. I installed SPD 2013 but now when I edit one of the 2013 workflows the text editor screen is blank as if all the workflow steps are missing. I freaked and opened my Win7 machine where I see them. I tried installing the fix KB/2837633 mentioned here but was told it was already installed. I also cleared the cache in the different SPD appdata folders per another thread but still the problem exists.

    Any suggestions?

    Wednesday, March 30, 2016 6:22 PM
  • Thank you very much!!!!

    Wednesday, June 15, 2016 6:11 AM
  • I just had to reformat my machine running Win 10/Office 2016.  After installing SPD 2013, I could open 1 2013 workflow, but not the one I really needed to open.  I don't recall installing this patch in the past, but it worked for me.  The only thing I needed to do was reboot my machine after to get the workflow to load properly.  
    Friday, July 1, 2016 5:10 PM
  • Thanks Kate,

    This really worked for me.

    Kunal Rane

    Sunday, February 12, 2017 4:47 PM
  • Same thing for me. I was struggling to find how to fix it on a Windows 10 machine, I even tried to install some KB's that didn't work but this one (http://support.microsoft.com/kb/2837633) solved my problem. Thanks.
    Thursday, May 18, 2017 8:43 AM
  • Fixed, Thank you!!! I can't tell you the number of unhelpful 'solutions' I have dug through. Thanks again!!!

    Tuesday, July 11, 2017 5:37 PM
  • Thanks Kate,

    Your answer has helped me too.

    Tuesday, July 25, 2017 4:44 PM
  • Thank you!

    My heart stopped this morning when I had to reinstall Designer and found my workflow steps were all gone! Installing hotfix 2837633 resolved my issue.

    Friday, March 2, 2018 3:30 PM
  • ShiffrinP, did you ever find a solution for this?  I am having the same issue on my Windows 10 machine and have tried the same steps as you above. 
    • Edited by SC Erin Wednesday, August 29, 2018 1:49 PM
    Wednesday, August 29, 2018 1:48 PM
  • This saved me, Thankssssssssssssssssssssssss a million times
    Thursday, March 14, 2019 7:41 PM