locked
Project server 2010 - unable to logon - "An unexpected error has occurred" RRS feed

  • Question

  • We have Project server 2010. Couple of users are unable to logon to PWA home page from their machines. However they are able to logon on different machines.  When these users logon from their machine, they are getting message
    "An unexpected error has occurred". There is no useful information in log file. What may be wrong here?


    Sanjeev
    Thursday, January 19, 2012 9:09 PM

Answers

  • We have Project server 2010. Couple of users are unable to logon to PWA home page from their machines. However they are able to logon on different machines.  When these users logon from their machine, they are getting message
    "An unexpected error has occurred". There is no useful information in log file. What may be wrong here?


    Sanjeev


    Issue resoved . This is what we did

    - run Configuration wizard

    - iisreset

    - waited for 2+ hours./

    Still trying to understand the mystery.

     

     


    Sanjeev
    • Marked as answer by Sanjeev S K Friday, January 20, 2012 11:01 PM
    • Edited by Sanjeev S K Friday, January 20, 2012 11:01 PM
    Friday, January 20, 2012 11:01 PM

All replies

  • Hello Sanjeev,

     

    Try clearing IE cache, also very PWA site is listed under trusted zone.

     

    Thanks,

    Hrishi

     

    Thursday, January 19, 2012 9:44 PM
  • Hello Sanjeev,

     

    Try clearing IE cache, also very PWA site is listed under trusted zone.

     

    Thanks,

    Hrishi

     


    Hrishi, thank you. We did IE cache clear, restarted the machines, PWA site is under trusted zone; still can't logon.


    Sanjeev
    Thursday, January 19, 2012 9:47 PM
  • Try re-saving the user from manage user page

     

    Thursday, January 19, 2012 9:48 PM
  • Try re-saving the user from manage user page

     


    Yes, we did. I already made the user as admin; re-synched with AD. Still user can't access it.
    Sanjeev
    Thursday, January 19, 2012 9:54 PM
  • Is user is able to access Project Workspace site or other PWA pages like Project Center directly

    http://PWA/projects.aspc

     

     

    Thursday, January 19, 2012 9:56 PM
  • Is user is able to access Project Workspace site or other PWA pages like Project Center directly

    http://PWA/projects.aspc

     

     


    No
    Sanjeev
    Thursday, January 19, 2012 9:57 PM
  • What happns if other user login to their machine (affected users machine)

     

    Thursday, January 19, 2012 10:05 PM
  • We have Project server 2010. Couple of users are unable to logon to PWA home page from their machines. However they are able to logon on different machines.  When these users logon from their machine, they are getting message
    "An unexpected error has occurred". There is no useful information in log file. What may be wrong here?


    Sanjeev


    Issue resoved . This is what we did

    - run Configuration wizard

    - iisreset

    - waited for 2+ hours./

    Still trying to understand the mystery.

     

     


    Sanjeev
    • Marked as answer by Sanjeev S K Friday, January 20, 2012 11:01 PM
    • Edited by Sanjeev S K Friday, January 20, 2012 11:01 PM
    Friday, January 20, 2012 11:01 PM
  • Hi Sanjeev,

    Can you also check the certificats are same on both the machine and also the IE setting at tool--> internet options --> Security--> Custom Levels-->user authetication are same at both the machine.

    Thanks
    Vinay


    Vinay Gupta
    Saturday, January 21, 2012 11:13 AM
  • Hi Sanjeev,

    Can you also check the certificats are same on both the machine and also the IE setting at tool--> internet options --> Security--> Custom Levels-->user authetication are same at both the machine.

    Thanks
    Vinay


    Vinay Gupta

    We did.
    Sanjeev
    Monday, January 23, 2012 11:24 PM
  • The same problem.

    Sametimes users cannot logon to the project server. Adding/removal of the rights doesn't help. Activating/inactivating of the project user profile doesn't help. Run Configuration wizard doesn't help.

    https://portal.corporate.com/pswa/default.aspx - An unexpected error has occurred.

    https://portal.corporate.com/pswa/_layouts/pwa/home/personalsettings.aspx - You do not have sufficient permissions to view the specified page.

     https://portal.corporate.com/pswa/Project%20Server%20Workflow%20Tasks/MyItems.aspx - no error, opening correctly.

    After a sametime the error disappears.

    During an error I can do delegation and work under the given user.

     

    ULS logs:

    01/29/2012 23:31:36.52	w3wp.exe (0x1B6C)	0x0DFC	SharePoint Foundation	Logging Correlation Data	xmnv	Medium	Name=Request (GET:https://portal.corporate.com:443/pswa/default.aspx)	53e800b1-5803-4916-ac05-0e28987083cb	
    
    01/29/2012 23:31:36.55	w3wp.exe (0x1B6C)	0x0DFC	SharePoint Foundation	Logging Correlation Data	xmnv	Medium	Site=/pswa	53e800b1-5803-4916-ac05-0e28987083cb	
    
    01/29/2012 23:31:36.55	w3wp.exe (0x1B6C)	0x0DFC	SharePoint Foundation	Monitoring	b4ly	High	Leaving Monitored Scope (PostResolveRequestCacheHandler). Execution Time=16.8557735689871	53e800b1-5803-4916-ac05-0e28987083cb	
    
    01/29/2012 23:31:36.58	w3wp.exe (0x1B6C)	0x0DFC	SharePoint Foundation	Topology	e5mc	Medium	WcfSendRequest: RemoteAddress: 'http://srv-moss01-prod:32843/5b2468ec0f114e2a9ef78115bcb5f6a8/PSI/PWA.svc' Channel: 'Microsoft.Office.Project.Server.Interfaces.IPWA' Action: 'http://schemas.microsoft.com/office/project/server/webservices/PWA/SecurityCheckUserPagePermission' MessageId: 'urn:uuid:73f65063-67da-4156-a37e-2ae0a5717999'	53e800b1-5803-4916-ac05-0e28987083cb	
    
    01/29/2012 23:31:36.60	w3wp.exe (0x0D64)	0x180C	SharePoint Foundation	Topology	e5mb	Medium	WcfReceiveRequest: LocalAddress: 'http://srv-moss01-prod.global.corporate.com:32843/5b2468ec0f114e2a9ef78115bcb5f6a8/PSI/PWA.svc' Channel: 'System.ServiceModel.Channels.ServiceChannel' Action: 'http://schemas.microsoft.com/office/project/server/webservices/PWA/SecurityCheckUserPagePermission' MessageId: 'urn:uuid:73f65063-67da-4156-a37e-2ae0a5717999'	53e800b1-5803-4916-ac05-0e28987083cb	
    
    01/29/2012 23:31:36.60	w3wp.exe (0x0D64)	0x180C	SharePoint Foundation	Monitoring	nasq	Medium	Entering monitored scope (ExecuteWcfServerOperation)	53e800b1-5803-4916-ac05-0e28987083cb	
    
    01/29/2012 23:31:36.60	w3wp.exe (0x0D64)	0x180C	SharePoint Foundation	Monitoring	b4ly	Medium	Leaving Monitored Scope (ExecuteWcfServerOperation). Execution Time=3.80607032458036	53e800b1-5803-4916-ac05-0e28987083cb	
    
    01/29/2012 23:31:36.61	w3wp.exe (0x1B6C)	0x0DFC	SharePoint Foundation	Runtime	tkau	Unexpected	System.Web.Services.Protocols.SoapException: ProjectServerError(s) LastError=GeneralSecurityAccessDenied Instructions: Pass this into PSClientError constructore to access all error information    at Microsoft.Office.Project.Server.WebServiceProxy.PWA.SecurityCheckUserPagePermission(Guid pageUid)     at Microsoft.Office.Project.PWA.PJBaseWebPartPage.CheckPagePermission()     at Microsoft.Office.Project.PWA.PJBaseWebPartPage.OnPreInit(EventArgs e)     at System.Web.UI.Page.PerformPreInit()     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)	53e800b1-5803-4916-ac05-0e28987083cb	
    
    01/29/2012 23:31:36.62	w3wp.exe (0x1B6C)	0x0DFC	SharePoint Foundation	Performance	nask	High	An SPRequest object was not disposed before the end of this thread.  To avoid wasting system resources, dispose of this object or its parent (such as an SPSite or SPWeb) as soon as you are done using it.  This object will now be disposed.  Allocation Id: {F4A0A5A3-09E1-4064-9545-68A1FF261C0D}  To determine where this object was allocated, set Microsoft.SharePoint.Administration.SPWebService.ContentService.CollectSPRequestAllocationCallStacks = true.	53e800b1-5803-4916-ac05-0e28987083cb	
    
    01/29/2012 23:31:36.62	w3wp.exe (0x1B6C)	0x0DFC	SharePoint Foundation	Monitoring	b4ly	Medium	Leaving Monitored Scope (Request (GET:https://portal.corporate.com:443/pswa/default.aspx)). Execution Time=99.17489513332	53e800b1-5803-4916-ac05-0e28987083cb	
    
    Project Server 2010 + SP1 + October CU

    Are there any suggestions? Thanks in advance.

    Monday, January 30, 2012 5:13 AM
  • We have the exact same problems as you described Dmitry.

    Have you ever found a durable solution ?

    Thanks in advance !

    Friday, September 29, 2017 8:22 PM