none
PCI LAN is not showing up in F12 menu RRS feed

  • Question

  • Hi,

    I have a x1 carbon Lenovo from 2013 that I want to reinstall using our pxe boot but the pci lan option does not turn up when pressing f12, Im using a usb 3 ethernet adapter that works when I log on to the PC. Even in BIOS I cannot find the network settings. Do you know why?

    Thanks / Pelle

    Friday, August 7, 2015 7:18 AM

All replies

  • Hello,

    Did you try disabling UEFI in the BIOS?


    David Gustafsson

    Friday, August 7, 2015 11:51 AM
  • Hi,Tried it it dident work.

    Im gonna try to updata drivers for pxe boot and also update bios och pc and other drivers on the pc.

    thanks!

    Friday, August 7, 2015 12:52 PM
  • Or if you want UEFI then enable the UEFI network stack if your machine supports it. Even then your machine may not support PXE booting to a USB Ethernet adapter. I'm guessing it might only work if there was an OEM Ethernet adapter that was supported by your firmware for PXE booting.

    For example I have a brand new Dell XPS 13 and I have UEFI Network stack enabled, however it does not offer the USB Ethernet as a boot option.


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Friday, August 7, 2015 1:07 PM
  • Hi,

    I ran a full system update via Lenovos system update, it updated usb 3 drivers , bios and alot of other drivers, now it works! Now I can choose PCI LAN: Realtek PXE b00 D1D in boot menu, do you guys know what driver I have to add to my wds? Is it the usb 3 driver och usb ethernet adapter driver och chipset update?

    its this model 34xx

    http://support.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-x1-carbon-type-34xx

    edit: love it now it stopped at: a connection could not be made to the deployment share, I have to add drivers to wds..

    Best regards Pelle


    Friday, August 7, 2015 1:34 PM
  • You'd need to add the Realtek drivers to your boot image if they are not already on there.

    If this post is helpful please vote it as Helpful or click Mark for answer.

    Friday, August 7, 2015 1:39 PM
  • hi there is a question mark in the device manager: thinkpad usb lan, I will try to see If I can find the driver for the realtek, strange on their homepage :http://support.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-x1-carbon-type-34xx

    they only have the driver for the wifi, And I cannot find the network card for cable in the device manager, maybe it is broken im calling lenovo again for the 3rd time =).have a great weekand see you on monday

    edit: lenovo will come on tuesday and replace the motherboard
    Friday, August 7, 2015 2:13 PM
  • http://deploymentresearch.com/Research/Post/325/MDT-2013-Lite-Touch-Driver-Management

    Any devices that still have question marks even after you've injected the right drivers are probably because they are child devices. In those cases you'll need to add the installer to your TS or make it a mandatory app for that model in custom settings or if you have a database you can use that to run the installer.


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Friday, August 7, 2015 2:21 PM
  • Hi,

    Strange problem still occurs, there is no lan driver in device manager, but I can boot to the network card. Strange.

    Do you guys also know which windows 10 enterprise version I should use? Im thinking on taking windows 10 normal enterprise? And just create a new wim out of it? I will user mdt test pushing the OS. Can this be done without letting the users to be able to deploy windows 10 when I enable it on MDT? Do I also have to update MDT im using a w2008 server?

      • Windows 10 Enterprise
      • Windows 10 Enterprise Features on Demand
      • Windows 10 Enterprise KN
      • Windows 10 Enterprise KN LTSB
      • Windows 10 Enterprise Language Pack
      • Windows 10 Enterprise LTSB
      • Windows 10 Enterprise LTSB Features on Demand
      • Windows 10 Enterprise LTSB Language Pack
      • Windows 10 Enterprise N
      • Windows 10 Enterprise N LTSB


    Tuesday, August 11, 2015 8:40 AM
  • The driver issue depends on what method you are using for injecting your drivers. Did you look at the link for driver management? If so what method are you using?

    As for which Windows 10 to use, that's your call but it also depends on which country you may live in. I think KN is for south korea and N is for those in the EU, both don't have media players. The LTSB is long term service branch, so with that edition if new features are released at a later date you will not get them. Most volume customers should just use Windows 10 Enterprise.

    How you push your OS depends on many factors. For complete automation you would need WDS, PXE booting and SCCM.

    MDT does not need to be on a server unless you want to use certain features like DFS-R to replicate your deployment share to other servers to load balance, for example.


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Tuesday, August 11, 2015 1:30 PM
  • Hi,

    Thanks for the answer.

    We live in sweden, its a company that has around 800+ employees and we are using lenovo computer about 10+ diffrent versions of lenovo. We are only deploying win7 64 bit but are we want to test windows 10 so it will be optional for the users. So yes I also think the normal enterprise will just work fine.

    Im using the total chaos at the moment, I tried adding drivers for a specific pc from a specific folder but the mdt dident find any drivers or .inf files from my folder. I read yesterday that the drivers are stored in the windows32 folder : C:\Windows\System32\DriverStore\FileRepository

    Can I extract all the drivers from the filerepository folder? Becouse I saw that it contains .inf files. And then make a folder for that pc model so I can use selection profile or do I need to download the drivers from lenovos driver page that I already tried?

    Is it possibly to use our current solution with pxe, wds, mdt 2008 r2 server to deploy a windows 10 enterprise wim? Or do I have to update it to 2013? I think my boss said that they need to upgrade the AD and Exchange also in order for this to work?

    I could follow  this guide then : http://deploymentresearch.com/Research/Post/455/Create-a-Windows-10-reference-image-using-MDT-2013

    Thanks in advance!

    Edit: also why does the deployment stall a littlebit at post-application installtion when its trying to install updates, I think I maybe have to define the wsus ip in customsettings right? Or just do the update manually afterwards, I think the installation would be much faster If I could config the pc in the meanwhile while its updating windows security updates.



    • Edited by Kjell Valge Tuesday, August 11, 2015 2:54 PM
    Tuesday, August 11, 2015 2:51 PM
  • You would probably find it very helpful to get volume 5 of Johan's books it'll answer many of your questions on what you're trying to do. - http://www.deploymentartist.com/Books.aspx

    You can get Lenovo driver packs for MDT from here - https://support.lenovo.com/us/en/documents/ht074984

    I would strongly recommend following the total control method to eliminate driver issues.

    If you have a WSUS server then yes you should define that in your customsettings file. That said it's even faster if you keep your reference image up to date or update it when more than 150MB in updates are needed. This will keep your deployment times lower.


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Tuesday, August 11, 2015 3:09 PM