locked
Response groups forwarding problems RRS feed

  • Question

  • Hello

    We are having some problems with forwarding phone call to another response group, when the call are made outside office hours.

    When we call in the out of office period, the call gets the out of office information, but when the call should be forwarded to another response group, it gets disconnected.

    If we make the call from a local Lync client the forward is working as it should.

    Monday, February 11, 2013 9:13 AM

Answers

All replies

  • You should do SIP Tracing on the Server (ocslogger.exe)

    Use the Resource Kit tools to view the logs and search for problems with snooper.exe


    - Belgian Unified Communications Community : http://www.pro-lync.be - MCM/MVP/MCT

    Tuesday, February 12, 2013 1:22 AM
  • Hi,

    Please double check “How to handle calls” in workflow configuration.

    In addition, please try to enable logging tool to get report for further troubleshooting.

    http://blog.schertz.name/2011/06/using-the-lync-logging-tool/

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Kent Huang
    TechNet Community Support

    Tuesday, February 12, 2013 2:13 AM
  • I'm getting this information:

    SPI/2.0 403 Forbidden

    TL_INFO(TF_PROTOCOL) [1]08D4.1C78::02/12/2013-13:51:25.136.0003ebde (SIPStack,SIPAdminLog::TraceProtocolRecord:SIPAdminLog.cpp(125))$$begin_record
    Trace-Correlation-Id: 1476405399
    Instance-Id: 000037DB
    Direction: incoming
    Peer: lync2010.domain.com:5070
    Message-Type: response
    Start-Line: SIP/2.0 403 Forbidden
    From: <sip:+4578773410@domain.com;user=phone>;tag=25919f2c15;epid=B93912F46C
    To: <sip:+4576540300@domain.com;user=phone>;tag=67c1d0358e;epid=F9C761559D
    CSeq: 1 REFER
    Call-ID: 3fe210d1-99c4-46a3-a876-2f752e2bb2e8
    VIA: SIP/2.0/TLS 172.16.1.15:57171;branch=z9hG4bKDF52C05C.1EE6700A6C9C1C0D;branched=FALSE,SIP/2.0/TLS 172.16.1.15:57186;branch=z9hG4bKead1c4f;ms-received-port=57186;ms-received-cid=36000
    CONTENT-LENGTH: 0
    SERVER: RTCC/4.0.0.0 MediationServer
    ms-diagnostics: 10403;source="Lync2010.domain.com";reason="Gateway responded with 403 Forbidden";component="MediationServer";SipResponseCode="403";SipResponseText="Forbidden"
    ms-diagnostics-public: 10403;reason="Gateway responded with 403 Forbidden";component="MediationServer";SipResponseCode="403";SipResponseText="Forbidden"
    Message-Body: –
    $$end_record

    Tuesday, February 12, 2013 3:02 PM
  • Do you have Enable Refer Support checked within Lync (option in trunk configuration)? If so, uncheck it, let Lync sync for a few minutes to become effective.
    • Proposed as answer by Lucrezia30 Monday, February 18, 2013 11:45 AM
    • Marked as answer by cliffha Tuesday, February 19, 2013 12:49 PM
    Tuesday, February 12, 2013 3:23 PM
  • Hi,

    Thanks that fixed the problem.

    I have now encountered a new problem, I am unable to get a queue to forward the call to a mobile phone, or to a queue.

    I can in the log just see that there is sending a bye, at the end of the call, and there is no error.

    The mobile phone number i forward to is looking like this:

    SIP:+45xxxxxxxx@domain.com

    Friday, February 15, 2013 9:53 AM
  • I had the same issue, and it was a result of my Response Group not having a voice policy assigned. Check for a voice policy:

    Get-CsApplicationEndpoint | Select DisplayName,VoicePolicy

    If no policy is granted to your Response Group, grant one:

    Get-CsApplicationEndpoint | Where-Object {$_.DisplayName -eq $RGName} | Grant-CsVoicePolicy -PolicyName $VoicePolicy
    http://social.technet.microsoft.com/Forums/en-US/ocsvoice/thread/58016f9c-dfb4-48db-b1bf-7cb36bb8b9f4/#58016f9c-dfb4-48db-b1bf-7cb36bb8b9f4
    • Edited by R. Derickson Friday, February 15, 2013 5:08 PM
    • Proposed as answer by Holger Bunkradt Friday, February 15, 2013 5:42 PM
    • Marked as answer by cliffha Tuesday, February 19, 2013 12:49 PM
    Friday, February 15, 2013 5:08 PM
  • I have now added the Voicepolicy, but the second Interactive group is still unable to forward the call to a queue, but it works if it is the first Interactive group there forward to the same queue.

    Monday, February 18, 2013 8:48 AM
  • Then you should re-check the log files to see what is going on. With this information we are flying blind to know what is going on between the queues.
    Monday, February 18, 2013 11:51 AM
  • I think something was broken in the queue, because when I created a new queue it worked.

     

    Is it possible to get a queue to forward the call to a mobile phone immediately?

    I have tried to set the “Enable queue overflow”, maximum number of calls to 0, but then I just get disconnected.

    Monday, February 18, 2013 1:36 PM
  • Not sure but by default you don't have this option. The way I can think of is to play around with the business hours. Set the open hours to a window of 1 minute and the rest is closed. Then you have the option what Lync would do outside the opening hours and then you can forward to a phone number.
    Or use the queue time out option, set it to 1 seconde and then forward to a phone number.
    Not the best way but I think this could work.
    • Edited by Lucrezia30 Tuesday, February 19, 2013 8:05 AM
    Tuesday, February 19, 2013 8:03 AM
  • I have made two Interactive Response Group, the first is for office hours and the second is for out of office.

    I have made one of the choices in the first response group to forward to my "on call queue" this is working, but when I set a choice in the second response group to do the same I am getting an error, not on the Lync server but by my sip provider.

    The provider informs me that there on the call from the first group is a referred by number with the call, but with the second group, there is no referred by number.

    I am using the same queue and voice policy for the two groups.


    • Edited by cliffha Tuesday, February 19, 2013 2:24 PM
    Tuesday, February 19, 2013 2:24 PM
  • To really know what is going on you need to use the log tools available for this to see what Lync is doing.
    But why did you create two response groups to actually do the same? As far as I understand it now you want to have a response group doing something during business hours but when that number is called out of business hours it needs to transfer the call to a mobile number, correct? If that is the case you could just create one response group and define what it needs to do out of business hour e.q. forward to mobile number.

    But to really understand what settings you made I/we need to see those settings.

    Wednesday, February 20, 2013 7:54 AM
  • I have created two response groups because I need the caller to confirm that they want to call the on call phone.
    The choices in the second response group is:
    1. Forward to on call phone
    #. End call
    If i give the second response group a phone number the forward to the mobile phone work, and I am getting a line with a correct referred by.
    The logging tools have this line when the call is correctly route and none if it is wrong:
     TL_INFO(TF_PROTOCOL) [0]0850.1650::02/21/2013-07:30:59.742.00107f30 (S4,SipMessage.DataLoggingHelper:sipmessage.cs(613))[237646923]
    >>>>>>>>>>>>Outgoing SipMessage c=[<SipTcpConnection_C11F15>], 172.16.1.15:49594->xx.xx.xx.66:5060
    INVITE sip:+45xxxxxx55@xx.xx.xx.66;user=phone SIP/2.0
    FROM: <sip:+45xxxxx300@domain.dk;user=phone>;epid=906D73CA6E;tag=1875a7f6d4
    TO: <sip:+45xxxxxx55@xx.xx.xx.66;user=phone>
    CSEQ: 2106 INVITE
    CALL-ID: bac00ef5-2c5d-465c-a603-cba016cfd18c
    MAX-FORWARDS: 70
    VIA: SIP/2.0/TCP 172.16.1.15:49594;branch=z9hG4bKcb82c42
    CONTACT: <sip:Lync2010.domain.domain.dk:5060;transport=Tcp;maddr=172.16.1.15;ms-opaque=a2c296ae11fcf7fc>
    CONTENT-LENGTH: 336
    REFERRED-BY: <tel:+4578xxxx13>
    SUPPORTED: 100rel
    USER-AGENT: RTCC/4.0.0.0 MediationServer
    CONTENT-TYPE: application/sdp
    ALLOW: ACK
    Allow: CANCEL,BYE,INVITE,PRACK,UPDATE
    v=0
    o=- 74 1 IN IP4 172.16.1.15
    s=session
    c=IN IP4 172.16.1.15
    b=CT:1000
    t=0 0
    m=audio 49508 RTP/AVP 97 101 13 0 8
    c=IN IP4 172.16.1.15
    a=rtcp:49509
    a=label:Audio
    a=sendrecv
    a=rtpmap:97 RED/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=rtpmap:13 CN/8000
    a=rtpmap:0 PCMU/8000
    a=rtpmap:8 PCMA/8000
    a=ptime:20
    ------------EndOfOutgoing SipMessage


    Thursday, February 21, 2013 4:34 PM
  • So in the end it was a config problem, good to hear that it is working now as it should.
    Friday, February 22, 2013 9:36 AM
  • It isn’t unfortunately not working yet, I still have problems with the second response group that it won’t forward to a mobile phone unless it has a phone number, and I don’t have a number to use for the out of office response group.

    Tuesday, February 26, 2013 1:01 PM