locked
PowerShell 3.0 Update not applicable Windows Server 2008 R2 SP1 RRS feed

  • Question

  • Hello,

    I am trying to install the update KB2506143 on the windows server 2008 R2 and I'm getting the message: "This update is not applicable to your computer". I tried different approaches and none had worked. I originally had .net 4.5 full version, I tried to remove this version and install using .net 4.0 (also full) but it didn't work.

    I also tried using the pkgmgr to extract and install the cab file.

    What shoud I do?

    Thank you,

    Paulo Borges

    Tuesday, June 11, 2013 7:50 PM

Answers

  • I used a new VM. And it worked just fine. I still don't know the reason for the problem, but it's working now.

    Thank you.

    Monday, July 15, 2013 12:43 PM

All replies

  • Hello,

    I'm trying to update the PowerShell on a Windows Server 2008 R2 SP1 environment and I'm getting this update is not applicable to your computer.

    I already tried different procedures:

    1. Install .net 4.5 full and then double click on the Windows6.1-KB2506143-x64 file.

    2. Extract the Windows6.1-KB2506143-x64 and use pkgmgr to intall the .cab file. No message is shown doing this way, however nothing has changed either.

    3. Uninstall .net 4.5;reboot; Install .net 4.0; reboot; double click on Windows6.1-KB2506143-x64 file.

    4. Tried to use wusa.exe in the cab file but received an error message.

    Anyone can help me install this update?

    Thank you very much.

    Tuesday, June 11, 2013 5:20 PM
  • As the prerequisites, you must have .Net 4.0 full (not just .net 4.0 client profile) and Windows PowerShell ISE feature installed.


    .Net Framework 4.0 full
    http://www.microsoft.com/en-us/download/details.aspx?id=17851


    To install Windows PowerShell ISE feature, go to Server Manager – Add Features.

    Thursday, June 13, 2013 3:01 AM
  • Hello, Thank you for the reply.

    As I mentioned in my post, I have the .net 4.0 full installed and I also have the ISE. 

    I tried uninstalling .net 4.5 and installing only .net 4.0 but it didn't work either.

    Any other ideas?

    Thursday, June 13, 2013 1:23 PM
  • I used a new VM. And it worked just fine. I still don't know the reason for the problem, but it's working now.

    Thank you.

    Monday, July 15, 2013 12:43 PM
  • I'm also having the same issue, with the same OS. I have .NET Framework 4.5.1 installed with KB2901126 and KB2898869 installed and also have the PowerShell ISE installed but when I try to run the KB2506143 I get the error message update is not applicable. I've also tried to install the dotNetFx40_Full_setup.exe but I get the message a newer version is already installed as expected. So why will it not install the PowerShell 3.0 from what I can tell the system meets all prerequisites. Please help. 
    Monday, March 31, 2014 3:45 PM