locked
An error occurred while trying to connect to a Web service + Infopath 2010 + SharePoint 2010 RRS feed

  • Question

  • when we try to get the user data (Department) from SOAP webservice (GetUserProfileByName ) it not retrieving the user data because we are getting

    The SOAP response indicates that an error occurred on the server:

    Server was unable to process request. ---> Attempted to perform an unauthorized operation.

    we have checked in %14hive% logs, it can shown below error messageswe have checked in %14hive% logs, it can shown below error messages

    03/21/2014 07:30:55.91         w3wp.exe (0x32A8)                           0x0EF8 SharePoint Foundation                     Monitoring                             b4ly     Medium          Leaving Monitored Scope (Request (POST:http://sitename/_vti_bin/UserProfileService.asmx)). Execution Time=11.1648966558599            8d0c3d12-45fe-4f46-880d-770c725a24e4

    03/21/2014 07:30:55.92         w3wp.exe (0x32A8)                           0x2108            InfoPath Forms Services                   Runtime - Data Connections            7tfk     Medium          Data adapter failed during OnLoad: The remote server returned an error: (500) Internal Server Error.  Server was unable to process request. ---> Attempted to perform an unauthorized operation.         47da509a-6aa6-4945-95f8-5f225ce34115

    03/21/2014 07:30:55.92         w3wp.exe (0x32A8)                           0x2108            InfoPath Forms Services                   Runtime - Data Connections            eq8l     Warning         The following query failed: GetUserProfileByName (User: domain\username, Form Name: Template, IP: , Connection Target: , Request: http://sitename/forms/Lists/MySPTest/AllItems.aspx, Form ID: urn:schemas-microsoft-com:office:infopath:list:-AutoGen-2014-03-20T11:27:01:234Z Type: DataAdapterException, Exception Message: The remote server returned an error: (500) Internal Server Error.  Server was unable to process request. ---> Attempted to perform an unauthorized operation. The remote server returned an error: (500) Internal Server Error.) 47da509a-6aa6-4945-95f8-5f225ce34115

    03/21/2014 07:30:55.94         w3wp.exe (0x32A8)                           0x2108            SharePoint Foundation                     General                                   8e1f     High                Failed to find the XML file at location '14\Template\Features\PowerPointBroadcastJanitorJob\feature.xml'  47da509a-6aa6-4945-95f8-5f225ce3411

    any one give correct solution on this

    with regards


    ravi sharepoint

    Friday, March 21, 2014 2:48 PM

Answers

All replies

  • 500 level errors generally indicate internal server issues.  These are encountered when web.config or other system configuration XML is modified and malformed to cause invalid XML which results in the error when the server interprets the file.  It can also be caused when components malfunction.  My starting point would be to do an environment reset (if possible) by rebooting all the servers to ensure any cob webs are cleared out.  After validating that all the services on the servers started up correctly, try the web service call again and see if it solves the problem.


    I trust that answers your question...

    Thanks
    C

    | RSS | http://crayveon.com/blog | SharePoint Scripts | Twitter | Google+ | LinkedIn | Facebook | Quix Utilities for SharePoint

    Friday, March 21, 2014 3:36 PM
    Answerer
  • We cannot resolve this issue. whenever we try to get user data by InfoPath form from SOAP services.

    then get below error

    The SOAP response indicates that an error occurred on the server:

    Server was unable to process request. ---> Attempted to perform an unauthorized operation

    let me know give me correct solution now


    ravi sharepoint

    Monday, March 24, 2014 2:27 PM
  • Hi,

    According to your post, my understanding is that you got error when use the soap web service to retrieve the user data.

    You can go to IIS and disable the Anonymous Authentication on all Web Front End Servers. 

    After doing this you can check in Central Admin>Manage Web Applications>Select the appropriate web application>Click on Anonymous Policy in the ribbon. 

    Make sure it is greyed out or if it not select the radio button "none - no policy" under permissions.

    Now, you can check whether it works.

    There are two similar articles about the issue, you can have a look at them.

    http://blogs.msdn.com/b/jingmeili/archive/2007/05/31/how-to-display-current-user-s-full-name-email-and-other-info-in-infopath.aspx

    http://www.sharepointing2010.com/2013/09/the-soap-response-indicates-that-error.html

    Thanks & Regards,

    Jason

    Jason Guo
    TechNet Community Support

    • Marked as answer by Lindali Friday, March 28, 2014 9:02 AM
    Wednesday, March 26, 2014 10:39 AM
  • Hi, disabling Anonymous Authentication  is helping with error "Attempted to perform an unauthorized operation." when I open infopath form from browser.

    But after that I start to recieve a lot of errors "Unexpected response from server. The status code of response is ‘0’" when I'm trying to open permissions page for any list or document library.

    Is there any way to resolve both these errors?

    Wednesday, November 30, 2016 12:20 PM