none
DCom Error 10010 RRS feed

  • Question

  • Folks....As usual I'm not sure where to post this question, so here it is in the Misc category.  Move it as you see fit.

    Running Windows 7 Ultimate (32 bit) on an HP Pavilion DV6000 laptop. Yesterday I noticed some DCOM errors in the event log:

    • "the application-specific permission settings do not grant local launch permission for the com server application with clsid {c97fcc79-e628-407d-ae68-a06ad6d8b4d1} and appid {344ed43d-d086-4961-86a6-1106f4acad9b} to the user nt authority\system sid (s-1-5-18) from address localhost (using lrpc). this security permission can be modified using the component services administrative tool."

    I followed the steps in the link below and that seemed to get rid of the above error in the event log:

    (http://www.itexperience.net/event-10016-the-application-specific-permission-settings-do-not-grant-local-launch-permission-for-the-com-server-application-with-clsid-c97fcc79-e628-407d-ae68-a06ad6d8b4d1/)

    Now, I now see two new errors in the event log when I boot up the machine:

    • The server {49BD2028-1523-11D1-AD79-00C04FD8FDFF} did not register with DCOM within the required timeout.
    • The server {E2B3C97F-6AE1-41AC-817A-F6F92166D7DD} did not register with DCOM within the required timeout.

    My search of the web has turned up several articles on this subject but they all seem to be dealing with Windows XP or Server 2003/2008.

    Can someone help me with this issue? What is causing it? Is it critical? How can I fix it?

    Thanks.....RDK45


    Friday, April 13, 2012 4:10 PM

All replies

  • 1. DCOMCNFG.EXE is you friend. Use it to pinpoint the causeof your trobles.

    2. Try to analyze what happened before occurence of these errors (installation, change of configuration, updates)

    Regards

    Milos

    Friday, April 13, 2012 4:54 PM
  • Milos.....Thanks for you reply and ideas.   I have already run DComCnfg and it did not show any errors.

    By looking at the Event log I have determined that all three errors started 29 Nov, 2011, over 4 months ago.  No new programs were installed prior to that for at least a month nor any MS updates for at least three weeks prior to that.

    I have backups, but since these issues have been there for 4 months with out any apparent problems, I'm reluctant to revert to a backup copy.  My preference it to fix the problem.  But I do not wish to use the Windows XP/Server 2003/2008 references on a Wndows 7 machine with out some "expert guidance".

    .....RDK45

    Friday, April 13, 2012 8:01 PM
  • Folks....Additional information, one of the web references to this error and symptoms is:

    http://blogs.msdn.com/b/distributedservices/archive/2009/01/21/dcom-error-10010-in-the-event-logs-and-sluggish-server-performance.aspx

    but it seems to be for Windows XP and Server 2003.  Can/Should I apply this to my situation?....RDK45

    Saturday, April 14, 2012 5:15 AM
  • Hi,

    I just got the following information about “Event ID: 10010”:

    Event ID 10010 — Application or Service Restart Status (Windows 2008 R2 is similar with Windows 7.)

    http://technet.microsoft.com/en-us/library/dd393071(WS.10).aspx

    From this document, we can see it should be related to a certain application or service. If an application crash issue appeared, please also let us know. Meanwhile, please try the method in this page and check if it is helpful.

    Considering this issue is related some applications, pleases also have a check in Clean Boot environment:

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

    http://support.microsoft.com/kb/929135

    Windows 2008 R2 is similar with Windows 7.

    Hope this helps.


    Ivan-Liu

    TechNet Community Support

    Monday, April 16, 2012 7:22 AM
  • Dear Ivan.....Thanks for the information.  I looked at the Technet article and it does not seem to be related to my issue.  It only talks about "Restart Manager can be used to restart applications and services".  My issues seems to be

    • The server {49BD2028-1523-11D1-AD79-00C04FD8FDFF} did not register with DCOM within the required timeout.
    • The server {E2B3C97F-6AE1-41AC-817A-F6F92166D7DD} did not register with DCOM within the required timeout.

    I have also looked at the second MS Support reference and I will follow that to see if I can identify the source service for my errors.

    Let me know if the first reference was not intended for my error. Thanks....RDK45

    Monday, April 16, 2012 7:58 AM
  • Dear Ivan....OK, I tried to get started with "Clean Boot" process but I am confused about what I see in the MSConfig utility. In the image below, after I have hidden all Microsoft services, I already see some services checked and some not, and there does not seem to be any relationship between the "checks" and the current "Status" of the service.  However, the "Date Disabled" column does seem to correlate with the "not checked", even though it is obvious that some of those services are not disabled, ie they are "running".

    I will admit that I have used the "Manage" function to start, stop and disable some 3-party services which I do not feel are necessary to start every time I use the computer.

    How should I proceed?  Normally, does checked in MSConfig mean that it is "enabled" or "disabled"?.....RDK45

    Wednesday, April 18, 2012 6:32 AM
  • Hi,

    When you reboot system, the service you disabled will not enable. Actually, you may disable all the other third party services.


    Ivan-Liu

    TechNet Community Support

    Thursday, April 19, 2012 1:46 AM
  • I had similar problem after installs updates on win8;

    Metro apps stop work and DCOM error appears in Event log;

    Tried DCOMCNFG, and many other;

    And only takes owner on all files to Administrators under C: and adding full access for all resolve my problem....

    Thursday, December 6, 2012 12:13 PM