locked
Outlook Only Keeping One Month of Email RRS feed

  • Question

  • my inbox only keeping one month email. i.e. today is 5 Mar and the oldest email in inbox is 5 Feb. i can't find any button that i can select not to delete email in inbox automatically. thanks.

    p.s. I didn't do any setting in AutoArchive.

    • Edited by aaacheung Monday, March 5, 2018 5:19 AM
    Monday, March 5, 2018 5:14 AM

Answers

  • Hi,

    Thank you for your update.

    Does this account work properly on the web mail?

    Please check the following option to see if issue continues.

    1. Go to File > Account Settings > Account Settings.

    2. Double click your IMAP account.

    3. Set the “Mail to keep offline” to All.

    4. Restart Outlook.

    Besides, have you configured this account on multiple devices? Such as phone? If this account was set as a POP account on another device, it will download messages from server to local folders and then messages are deleted from server. IMAP account reads mail directly from server so that you may find messages disappearing as they were downloaded to another device. Please check whether this is the case for you.

    What's more, in case there was a corrupted data file, we could also recreate OST file to see the result. To do this, please go to File > Account Settings > Account Settings. Under Date Files tab, choose your account and then click Open File Location. Delete the account OST file and then restart Outlook.

    Hope this is helpful to you.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by aaacheung Friday, March 9, 2018 5:21 AM
    Thursday, March 8, 2018 1:15 AM

All replies

  • Hi,

    What's your account type? Exchange, POP or IMAP?

    Are all messages shown correctly on the web mail?

    If you scroll down to the bottom of the list, will you see a message shown as the following picture?

    For Exchange account, you could set Mail to keep offline to a long time such as 1 year via Account Settings > Account Settings > offline settings.

    To double confirm the AutoArchive setting, please right click your Inbox and choose Properties. Under AutoArchive tab, make sure the option below is ticked.

    Besides, in case there is a filter applied, please try resetting view to check the result. To do this, please go to View > Reset View.

    If issue continues, we could also create a new profile.

    Any updates, please feel free to post back.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.



    • Edited by Perry-Pan Tuesday, March 6, 2018 5:13 AM
    Tuesday, March 6, 2018 5:10 AM
  • Thanks for your help. I think my account is IMAP (sure not Exchange). The inbox properties already checked "do not archive items in this folder". And confirm no filter rule is applied.

    My outlook contains two email accounts, the second account is fine and normal. Not sure is two accounts in one outlook the reason of this problem.

    Wednesday, March 7, 2018 10:12 AM
  • Hi,

    Thank you for your update.

    Does this account work properly on the web mail?

    Please check the following option to see if issue continues.

    1. Go to File > Account Settings > Account Settings.

    2. Double click your IMAP account.

    3. Set the “Mail to keep offline” to All.

    4. Restart Outlook.

    Besides, have you configured this account on multiple devices? Such as phone? If this account was set as a POP account on another device, it will download messages from server to local folders and then messages are deleted from server. IMAP account reads mail directly from server so that you may find messages disappearing as they were downloaded to another device. Please check whether this is the case for you.

    What's more, in case there was a corrupted data file, we could also recreate OST file to see the result. To do this, please go to File > Account Settings > Account Settings. Under Date Files tab, choose your account and then click Open File Location. Delete the account OST file and then restart Outlook.

    Hope this is helpful to you.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by aaacheung Friday, March 9, 2018 5:21 AM
    Thursday, March 8, 2018 1:15 AM
  • Yes, I find it in Account Setting. Thank you Perry. The problem is solved.
    Friday, March 9, 2018 5:20 AM